]> git.pld-linux.org Git - packages/codeblocks.git/blobdiff - codeblocks.spec
- up to 13.12
[packages/codeblocks.git] / codeblocks.spec
index cb825b12bd33c8bfcbe40f9364e2a29b3cdefafb..dd322d31d60673d95e94de7420aecad4614a6dd3 100644 (file)
@@ -1,29 +1,32 @@
-%define                _rc     rc2
-%define                _snap   20060721
+
 Summary:       An open source, cross platform, free C++ IDE
-Summary(pl.UTF-8):   Wieloplatformowe, darmowe IDE do C++ o otwartych źródłach
+Summary(pl.UTF-8):     Wieloplatformowe, darmowe IDE do C++ o otwartych źródłach
 Name:          codeblocks
-Version:       1.0
-#Release:      0.%{_rc}.0.5
-Release:       0.%{_snap}
-License:       GPL
-Group:         Development/Languages
-# Source0:    http://dl.sourceforge.net/codeblocks/%{name}-%{version}%{_rc}.tgz
-Source0:       %{name}-%{_snap}.tar.gz
-# Source0-md5: 1ec8c03eff46629cdb1cbc1516ffa78e
-Source1:       %{name}.conf
-Patch0:                %{name}-ac.patch
-Patch1:                %{name}-fhs.patch
-Patch2:                %{name}-pwd.patch
-Patch3:                %{name}-gcc-4.1.patch
+Version:       13.12
+Release:       1
+License:       GPL v3
+Group:         X11/Development/Tools
+Source0:       http://download.sourceforge.net/codeblocks/%{name}_%{version}-1.tar.gz
+# Source0-md5: 4b450f620d9f1875ecf6882ab3c11402
+Patch0:                %{name}-FHS-plugins.patch
+Patch2:                %{name}-ac.patch
+Patch3:                %{name}-pwd.patch
 URL:           http://www.codeblocks.org/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-BuildRequires: dos2unix
+BuildRequires: bzip2-devel
+BuildRequires: gtk+2-devel
 BuildRequires: libtool
+BuildRequires: pkgconfig
+BuildRequires: sed >= 4.0
+BuildRequires: hunspell-devel
 BuildRequires: unixODBC-devel
-BuildRequires: wxGTK2-devel >= 2.6.0
+BuildRequires: wxGTK2-unicode-devel >= 2.8.0
 BuildRequires: zip
+BuildRequires: zlib-devel
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): gtk-update-icon-cache
+Requires(post,postun): shared-mime-info
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pluginsdir %{_libdir}/%{name}/plugins
@@ -36,7 +39,7 @@ Code::Blocks can be extended with plugin DLLs. It includes a plugin
 wizard so you can compile your own plugins!
 
 Highlights:
- - Open Source! GPL 2, no hidden costs
+ - Open Source! GPL 3, no hidden costs
  - Cross-platform; runs on Linux or Windows (uses wxWidgets)
  - Made in GNU C++; no interpreted languages or proprietary libs needed
  - Extensible thru plugins
@@ -76,7 +79,7 @@ rozszerzać. Zawiera czarodzieja dla wtyczek, więc można kompilować
 własne.
 
 Główne cechy:
- - otwarte źródła na licencji GPL 2, bez ukrytych kosztów
+ - otwarte źródła na licencji GPL 3, bez ukrytych kosztów
  - wieloplatformowość - działa na Linuksie i Windows (przy użyciu
    wxWidgets)
  - stworzone w GNU C++, nie wymaga języków interpretowanych ani
@@ -112,8 +115,8 @@ Cechy interfejsu:
 
 %package devel
 Summary:       Development files for Code::Blocks
-Summary(pl.UTF-8):   Pliki nagłówkowe Code::Blocks
-Group:         Development/Libraries
+Summary(pl.UTF-8):     Pliki nagłówkowe Code::Blocks
+Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
@@ -125,72 +128,95 @@ Ten pakiet dostarcza plików nagłówkowych Code::Blocks. Należy
 instalować ten pakiet tylko w celu pisania wtyczek do Code::Blocks.
 
 %prep
-#%setup -q -n %{name}-%{version}%{_rc}
-%setup -q -n %{name}-%{_snap}
-find . -type f -and -not -name "*.cpp" -and -not -name "*.h" -and -not -name "*.png" -and -not -name "*.bmp" -and -not -name "*.c" -and -not -name "*.cxx" -and -not -name "*.ico" | sed "s/.*/\"\\0\"/" | xargs dos2unix
-chmod a+x acinclude.m4 src/update
-#%patch0 -p1
-#%patch1 -p1
-#%patch2 -p1
-%patch3 -p0
+%setup -q
+%patch0 -p1
+%patch2 -p1
+%patch3 -p1
 
-%build
-# Because of new bootstrap script, crating revision.m4
-echo "m4_define([SVN_REVISION], trunk-r0)" > ./revision.m4
+#hardcode libdir, continue of patch0
+sed -i 's|@libdir@|%{_libdir}|' src/sdk/configmanager.cpp
+
+# fix version inside the configure script
+sed -i 's/1\.0svn/%{version}/g' revision.m4
 
+%build
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       --with-wx-config=wx-gtk2-ansi-config
+       --with-wx-config=wx-gtk2-unicode-config \
+       --with-contrib-plugins=all
+
 %{__make}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_sysconfdir}
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-cp %{SOURCE1} "$RPM_BUILD_ROOT%{_sysconfdir}/Code::Blocks v1.0"
+       DESTDIR=$RPM_BUILD_ROOT \
+       mimeicondir=%{_iconsdir}/hicolor/48x48/mimetypes
+
+%{__rm} $RPM_BUILD_ROOT%{_pluginsdir}/*.la
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/{codeblocks/wxContribItems/,}*.la
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post
+/sbin/ldconfig
+%update_icon_cache hicolor
+%update_desktop_database_post
+%update_mime_database
+
+%postun
+/sbin/ldconfig
+%update_icon_cache hicolor
+%update_desktop_database_postun
+%update_mime_database
 
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS BUGS COMPILERS README TODO ChangeLog
-%config(noreplace) %verify(not md5 mtime size) "%{_sysconfdir}/Code::Blocks v1.0"
+%attr(755,root,root) %{_bindir}/cb_share_config
 %attr(755,root,root) %{_bindir}/codeblocks
+%attr(755,root,root) %{_bindir}/codesnippets
 %attr(755,root,root) %{_bindir}/cb_console_runner
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
-%{_desktopdir}/*.desktop
+%attr(755,root,root) %{_libdir}/libwxsmithlib.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libwxsmithlib.so.0
+%attr(755,root,root) %{_libdir}/libcodeblocks.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcodeblocks.so.0
+%{_desktopdir}/codeblocks.desktop
 %{_pixmapsdir}/*.png
-%{_iconsdir}/gnome/48x48/mimetypes/*.png
-%{_datadir}/application-registry/codeblocks.applications
+%{_iconsdir}/hicolor/48x48/mimetypes/*.png
 %{_datadir}/mime/packages/codeblocks.xml
-%{_datadir}/mime-info/codeblocks*
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/scripts
-%dir %{_datadir}/%{name}/plugins
-%{_datadir}/%{name}/scripts
+%{_datadir}/%{name}/scripts/*
 %{_datadir}/%{name}/*.zip
 %{_datadir}/%{name}/*.txt
+%{_datadir}/%{name}/SpellChecker
+%{_datadir}/%{name}/compilers
 %{_datadir}/%{name}/icons
 %{_datadir}/%{name}/images
 %{_datadir}/%{name}/lexers
+%{_datadir}/%{name}/lib_finder
 %{_datadir}/%{name}/templates
-%{_datadir}/%{name}/plugins/*
-#%dir %{_pluginsdir}
-#%attr(755,root,root) %{_pluginsdir}/*.so
-%{_pkgconfigdir}/codeblocks.pc
-%{_mandir}/man1/*
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/wxContribItems
+%dir %{_pluginsdir}
+%attr(755,root,root) %{_pluginsdir}/*.so
+%attr(755,root,root) %{_libdir}/%{name}/wxContribItems/*.so.*
+%{_mandir}/man1/*.1*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/*.la
+%attr(755,root,root) %{_libdir}/libcodeblocks.so
+%attr(755,root,root) %{_libdir}/libwxsmithlib.so
+%attr(755,root,root) %{_libdir}/%{name}/wxContribItems/*.so
+%{_pkgconfigdir}/cb_*.pc
+%{_pkgconfigdir}/codeblocks.pc
+%{_pkgconfigdir}/wxsmith*.pc
 %{_includedir}/codeblocks
+%{_includedir}/wxsmith
This page took 0.034413 seconds and 4 git commands to generate.