]> git.pld-linux.org Git - packages/busybox.git/blobdiff - busybox.spec
- enabled nc (netcat)
[packages/busybox.git] / busybox.spec
index bb846156cf9d50f2a1a88ae12b6caff27983cd42..fe3fc25334718e703d1098c9f984bd96241344f7 100644 (file)
@@ -1,16 +1,21 @@
 Summary:       Set of common unix utils for embeded systems
 Name:          busybox
 Version:       0.51
-Release:       1
+Release:       10
 License:       GPL
-Group:         Applications/File
-Group(de):     Applikationen/Datei
-Group(pl):     Aplikacje/Pliki
+Group:         Applications
+Group(de):     Applikationen
+Group(pl):     Aplikacje
 Source0:       ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
 Source1:       %{name}-config.h
 Patch0:                %{name}-logconsole.patch
 Patch1:                %{name}-tee.patch
+Patch2:                %{name}-sh-name.patch
+Patch3:                %{name}-printf-gettext.patch
+Patch4:                %{name}-loadfont.patch
+Patch5:                %{name}-cread.patch
 URL:           http://busybox.lineo.com/
+%{?BOOT:BuildRequires: uClibc-devel-BOOT >= 20010521-3}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -30,18 +35,47 @@ customize your embedded systems. To create a working system, just add
 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
 ae).
 
+%package BOOT
+Summary:       busybox for PLD bootdisk
+Group:         Applications
+Group(de):     Applikationen
+Group(pl):     Aplikacje
+
+%description BOOT
+busybox for PLD bootdisk.
+
 %prep
 %setup -q
 %patch0
 %patch1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
+# BOOT
 cp %{SOURCE1} Config.h
-%{__make}
+%{__make} \
+       CFLAGS_EXTRA="-m386 -I%{_libdir}/bootdisk%{_includedir}" \
+       LDFLAGS="-nostdlib -s" \
+       LIBRARIES="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
+
+# TODO make main package dynamically linked
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__install} -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/busybox,%{_mandir}/man1}
+%{__install} -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
+%{__install} -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/{bin,%{_libdir}/busybox}
+
+%{__install} busybox $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/
+
+for i in `cat busybox.links`; do
+       ln -sfn busybox "$RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/`basename $i`"
+done
+%{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
+# change sh to lash (see sh_name patch)
+mv -f $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/{sh,lash}
 
 %{__install} busybox $RPM_BUILD_ROOT%{_bindir}
 %{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
@@ -59,3 +93,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/*
 %{_libdir}/busybox
 %{_mandir}/man1/*
+
+%files BOOT
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/bootdisk/bin/*
+%{_libdir}/bootdisk%{_libdir}/*
This page took 0.23525 seconds and 4 git commands to generate.