]> git.pld-linux.org Git - packages/busybox.git/blobdiff - busybox.spec
- rel 2; fix build with external printf (like on mksh)
[packages/busybox.git] / busybox.spec
index 65d5fa8a5a12b532d346ba3d76a41dc712d025ff..e7d835a0eb984c40a28b4d7f69988f85c361d886 100644 (file)
@@ -13,6 +13,7 @@
 #
 %bcond_with    altconfig       # use alternative config (defined by cfgfile)
 %bcond_with    linkfl          # creates links to busybox binary and puts them into file list
+%bcond_without dynamic         # don't build dynamic (base) version
 %bcond_without static          # don't build static version
 %bcond_without initrd          # don't build initrd version
 %bcond_with    dietlibc        # build dietlibc-based initrd and static versions
@@ -36,18 +37,24 @@ Summary(pl.UTF-8):  Zestaw narzędzi uniksowych dla systemów wbudowanych
 Summary(pt_BR.UTF-8):  BusyBox é um conjunto de utilitários UNIX em um único binário
 Name:          busybox
 # stable line only
-Version:       1.18.3
+Version:       1.19.2
 Release:       2
-License:       GPL
+License:       GPL v2
 Group:         Applications
 Source0:       http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 660af4d44661d32b22025a66f4f78df2
+# Source0-md5: 50267054345f1a0b77fe65f6e0e5ba29
 Source1:       %{name}.config
 Source2:       %{name}-initrd.config
 %{?with_altconfig:Source3:     %{cfgfile}}
-Patch100:      busybox-1.18.3-buildsys.patch
-Patch101:      busybox-1.18.3-modutils24.patch
-Patch102:      busybox-1.18.3-wget.patch
+Patch100:      busybox-1.19.2-android.patch
+Patch101:      busybox-1.19.2-buildsys.patch
+Patch102:      busybox-1.19.2-chpasswd.patch
+Patch103:      busybox-1.19.2-crond.patch
+Patch104:      busybox-1.19.2-inetd.patch
+Patch105:      busybox-1.19.2-syslogd.patch
+Patch106:      busybox-1.19.2-tail.patch
+Patch107:      busybox-1.19.2-tftp.patch
+Patch0:                %{name}-git.patch
 Patch1:                %{name}-logconsole.patch
 Patch2:                %{name}-printf-gettext.patch
 Patch3:                %{name}-loadfont.patch
@@ -157,6 +164,13 @@ Statycznie skonsolidowany busybox dla initrd.
 %patch100 -p1
 %patch101 -p1
 %patch102 -p1
+%patch103 -p1
+%patch104 -p1
+%patch105 -p1
+%patch106 -p1
+%patch107 -p1
+%patch0 -p1
+
 %patch1 -p1
 %patch2 -p1
 #%patch3 -p1
@@ -174,7 +188,7 @@ install %{SOURCE2} .config
 %{__make} \
        %{?with_verbose:V=1} \
        CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
-       LDFLAGS="%{ld_rpmldflags} -static" \
+       LDFLAGS="%{rpmldflags} -static" \
 %if %{with dietlibc}
        LIBRARIES="-lrpc" \
        CC="diet %{__cc}"
@@ -194,7 +208,6 @@ mv -f busybox built/busybox.initrd
 %{__make} clean
 %endif
 
-
 %if %{with altconfig}
 install %{SOURCE3} .config
 %else
@@ -206,7 +219,7 @@ install %{SOURCE1} .config
 %{__make} \
        %{?with_verbose:V=1} \
        CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
-       LDFLAGS="%{ld_rpmldflags} -static" \
+       LDFLAGS="%{rpmldflags} -static" \
 %if %{with dietlibc}
        LIBRARIES="-lrpc" \
        CC="diet %{__cc}"
@@ -226,25 +239,32 @@ mv -f busybox built/busybox.static
 %{__make} clean
 %endif
 
+%if %{with dynamic}
 %{__make} oldconfig
 %{__make} \
        %{?with_verbose:V=1} \
        %{CrossOpts} \
        CFLAGS_EXTRA="%{rpmcflags}" \
-       LDFLAGS="%{ld_rpmldflags}" \
+       LDFLAGS="%{rpmldflags}" \
        CC="%{__cc}"
 %{__make} busybox.links docs/busybox.1
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
 
-%{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
+%if %{with static}
+install -d $RPM_BUILD_ROOT%{_bindir}
+install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
+%endif
+
 %if %{with initrd}
 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
 %endif
 
+%if %{with dynamic}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
@@ -255,10 +275,12 @@ install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
 %else
 install busybox $RPM_BUILD_ROOT%{_bindir}
 %endif
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with dynamic}
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS README .config
@@ -274,6 +296,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %{_libdir}/busybox
 %{_mandir}/man1/*
+%endif
 
 %if %{with static}
 %files static
This page took 0.078755 seconds and 4 git commands to generate.