]> git.pld-linux.org Git - packages/busybox.git/blobdiff - busybox.spec
- rel 2; verbose build by default; upstream nc fix; enable loadfont features in initrd
[packages/busybox.git] / busybox.spec
index 568be6844e035d57b9d6e221af3b91b838dbbe3d..c02ce7c15652d8f72d3e1278bbaf303cf3b87e6f 100644 (file)
@@ -1,15 +1,24 @@
 # TODO:
-#      - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
-#      - make internal commands work even if busybox is not in /bin/busybox (initrd)
-#        or when /proc is not mounted (static / normal)
+# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
+#   if it still serves a purpose
+# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
+# - make internal commands work even if busybox is not in /bin/busybox (initrd)
+#   or when /proc is not mounted (static / normal)
 #
 # Conditional build:
 # alternative busybox config file (replaces default one) you should
 # define cfgfile macro, i.e.
 #
 #      rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
+#
 %bcond_with    altconfig       # use alternative config (defined by cfgfile)
 %bcond_with    linkfl          # creates links to busybox binary and puts them into file list
+%bcond_without dynamic         # don't build dynamic (base) version
+%bcond_without static          # don't build static version
+%bcond_without initrd          # don't build initrd version
+%bcond_with    dietlibc        # build dietlibc-based initrd and static versions
+%bcond_with    glibc           # build glibc-based initrd and static versions
+%bcond_without verbose         # verbose build
 # Options below are useful, when you want fileutils and grep providing.
 # For example, ash package requires fileutils and grep.
 %bcond_with    fileutl_prov    # adds fileutils providing
 # Fileutils, grep and shell provided with busybox have not such
 # functionality as their GNU countenders.
 #
-%bcond_without static          # don't build static version
-%bcond_without initrd          # don't build initrd version
-%bcond_with    dietlibc        # build dietlibc-based initrd version
-%bcond_with    glibc           # build glibc-based initrd version
-#
-%ifnarch %{ix86} %{x8664} ppc sparc64
+%ifnarch %{ix86} %{x8664} ppc
 %define with_glibc 1
 %endif
-Summary:       Set of common unix utils for embeded systems
+Summary:       Set of common Unix utilities for embeded systems
 Summary(pl.UTF-8):     Zestaw narzędzi uniksowych dla systemów wbudowanych
 Summary(pt_BR.UTF-8):  BusyBox é um conjunto de utilitários UNIX em um único binário
 Name:          busybox
-Version:       1.6.0
-Release:       3
-License:       GPL
+# stable line only
+Version:       1.22.1
+Release:       2
+License:       GPL v2
 Group:         Applications
 Source0:       http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: b587dd978fed23467b42ef959b6aa449
+# Source0-md5: 337d1a15ab1cb1d4ed423168b1eb7d7e
 Source1:       %{name}.config
 Source2:       %{name}-initrd.config
 %{?with_altconfig:Source3:     %{cfgfile}}
+Patch100:      http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-ash.patch
+# Patch100-md5:        538d8cddbdfc449239b25a40bc8d1575
+Patch101:      http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-date.patch
+# Patch101-md5:        bc381f9ceb3824141c968f5bc4353943
+Patch102:      http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-iplink.patch
+# Patch102-md5:        24686ec2750a8703feb57fc9c6aaed1d
+Patch103:      http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-nc.patch
+# Patch103-md5:        69eecaae5f812d08655dfdf34b60503f
 Patch1:                %{name}-logconsole.patch
 Patch2:                %{name}-printf-gettext.patch
 Patch3:                %{name}-loadfont.patch
-Patch4:                %{name}-ash_exec.patch
-Patch5:                %{name}-kernel_headers.patch
-Patch6:                %{name}-insmod-morearchs.patch
-Patch7:                %{name}-dhcp.patch
-Patch8:                %{name}-fix_64_archs.patch
-Patch9:                %{name}-echo.patch
+Patch4:                %{name}-kernel_headers.patch
+Patch5:                %{name}-insmod-morearchs.patch
+Patch6:                %{name}-dhcp.patch
+Patch7:                %{name}-fix_64_archs.patch
+Patch9:                %{name}-ash-export-PATH.patch
 URL:           http://www.busybox.net/
 BuildRequires: gcc >= 3.2
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.333
-%{?with_static:BuildRequires:  glibc-static}
-%if %{with initrd}
+BuildRequires: rpmbuild(macros) >= 1.652
+%if %{with initrd} || %{with static}
        %if %{with dietlibc}
 BuildRequires: dietlibc-static
        %else
                %if %{with glibc}
 BuildRequires: glibc-static
                %else
-%if "%{_target_base_arch}" != "%{_arch}"
+%if "%{_target_base_arch}" != "%{_host_base_arch}"
 BuildRequires: cross%{_target_base_arch}-uClibc-static
 %else
        %ifarch ppc %{x8664}
-BuildRequires: uClibc-static >= 2:0.9.29
+BuildRequires: uClibc-static >= 3:0.9.30.1
        %else
-BuildRequires: uClibc-static >= 2:0.9.21
+BuildRequires: uClibc-static >= 3:0.9.30.1
        %endif
 %endif
                %endif
        %endif
 %endif
+%{?with_sh_prov:Provides:      /bin/sh}
 %{?with_fileutl_prov:Provides: fileutils}
 %{?with_grep_prov:Provides:    grep}
-%{?with_sh_prov:Provides:      /bin/sh}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
-%define                _initrd_bindir  /bin
 
-%if "%{_target_base_arch}" != "%{_arch}"
+%if "%{_target_base_arch}" != "%{_host_base_arch}"
        %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
 %else
        %define CrossOpts %{nil}
 %endif
 
+%define                filterout_ld    -Wl,-z,(combreloc|relro)
+
 %description
 BusyBox combines tiny versions of many common UNIX utilities into a
 single small executable. It provides minimalist replacements for most
@@ -137,8 +149,8 @@ Statycznie skonsolidowany busybox.
 %package initrd
 Summary:       Static busybox for initrd
 Summary(pl.UTF-8):     Statycznie skonsolidowany busybox dla initrd
-Group:         Applications
-Conflicts:     geninitrd < 3075
+Group:         Base
+Conflicts:     geninitrd < 10000.20
 
 %description initrd
 Static busybox for initrd.
@@ -148,14 +160,17 @@ Statycznie skonsolidowany busybox dla initrd.
 
 %prep
 %setup -q
+%patch100 -p1
+%patch101 -p1
+%patch102 -p1
+%patch103 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+#%patch3 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
 %patch9 -p1
 
 %build
@@ -164,19 +179,20 @@ install -d built
 install %{SOURCE2} .config
 %{__make} oldconfig
 %{__make} \
+       %{?with_verbose:V=1} \
        CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
-       LDFLAGS="%{ld_rpmldflags} -static" \
+       LDFLAGS="%{rpmldflags} -static" \
 %if %{with dietlibc}
        LIBRARIES="-lrpc" \
-       CC="diet gcc"
+       CC="diet %{__cc}"
 %else
 %if %{with glibc}
        %{CrossOpts} \
        CC="%{__cc}"
 %else
-    %if "%{_target_base_arch}" != "%{_arch}"
+       %if "%{_target_base_arch}" != "%{_host_base_arch}"
        CROSS="%{_target_cpu}-uclibc-" \
-    %endif
+       %endif
        CC="%{_target_cpu}-uclibc-gcc"
 %endif
 %endif
@@ -185,7 +201,6 @@ mv -f busybox built/busybox.initrd
 %{__make} clean
 %endif
 
-
 %if %{with altconfig}
 install %{SOURCE3} .config
 %else
@@ -195,32 +210,56 @@ install %{SOURCE1} .config
 %if %{with static}
 %{__make} oldconfig
 %{__make} \
+       %{?with_verbose:V=1} \
+       CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
+       LDFLAGS="%{rpmldflags} -static" \
+%if %{with dietlibc}
+       LIBRARIES="-lrpc" \
+       CC="diet %{__cc}"
+%else
+%if %{with glibc}
        %{CrossOpts} \
-       CFLAGS_EXTRA="%{rpmcflags}" \
-       LDFLAGS="%{ld_rpmldflags} -static" \
        CC="%{__cc}"
+%else
+       %if "%{_target_base_arch}" != "%{_host_base_arch}"
+       CROSS="%{_target_cpu}-uclibc-" \
+       %endif
+       CC="%{_target_cpu}-uclibc-gcc"
+%endif
+%endif
+
 mv -f busybox built/busybox.static
 %{__make} clean
 %endif
 
+%if %{with dynamic}
 %{__make} oldconfig
 %{__make} \
+       %{?with_verbose:V=1} \
        %{CrossOpts} \
        CFLAGS_EXTRA="%{rpmcflags}" \
-       LDFLAGS="%{ld_rpmldflags}" \
+       LDFLAGS="%{rpmldflags}" \
        CC="%{__cc}"
-%{__make} busybox.links docs/BusyBox.1
+%{__make} busybox.links docs/busybox.1
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
 
-%{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
-%{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
+%if %{with static}
+install -d $RPM_BUILD_ROOT%{_bindir}
+install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
+%endif
+
+%if %{with initrd}
+install -d $RPM_BUILD_ROOT%{_libdir}/initrd
+install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
+%endif
 
+%if %{with dynamic}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
-install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
-echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
+install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 # install links to busybox binary, when linkfl is defined
 %if %{with linkfl}
@@ -229,10 +268,12 @@ echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
 %else
 install busybox $RPM_BUILD_ROOT%{_bindir}
 %endif
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with dynamic}
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS README .config
@@ -247,7 +288,8 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %{_libdir}/busybox
-%{_mandir}/man1/*
+%{_mandir}/man1/busybox.1*
+%endif
 
 %if %{with static}
 %files static
@@ -258,5 +300,5 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with initrd}
 %files initrd
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_initrd_bindir}/initrd-busybox
+%attr(755,root,root) %{_libdir}/initrd/busybox
 %endif
This page took 0.042752 seconds and 4 git commands to generate.