]> git.pld-linux.org Git - packages/busybox.git/blobdiff - busybox.spec
- up to 1.31.1
[packages/busybox.git] / busybox.spec
index 5f8f1e78c99829525e103cf2a9eb516813730626..7c360c39912d25a43125d093586e87c22b2ff2ca 100644 (file)
@@ -18,7 +18,7 @@
 %bcond_without initrd          # don't build initrd version
 %bcond_with    dietlibc        # build dietlibc-based initrd and static versions
 %bcond_with    glibc           # build glibc-based initrd and static versions
-%bcond_with    verbose         # verbose build
+%bcond_without verbose         # verbose build
 # Options below are useful, when you want fileutils and grep providing.
 # For example, ash package requires fileutils and grep.
 %bcond_with    fileutl_prov    # adds fileutils providing
 # functionality as their GNU countenders.
 #
 %ifnarch %{ix86} %{x8664} ppc
-%define with_glibc 1
+%define                with_glibc      1
+%endif
+%ifarch x32
+# until uClibc builds on x32
+%undefine      with_static
 %endif
 Summary:       Set of common Unix utilities for embeded systems
 Summary(pl.UTF-8):     Zestaw narzędzi uniksowych dla systemów wbudowanych
 Summary(pt_BR.UTF-8):  BusyBox é um conjunto de utilitários UNIX em um único binário
 Name:          busybox
 # stable line only
-Version:       1.19.2
+Version:       1.31.1
 Release:       1
 License:       GPL v2
 Group:         Applications
 Source0:       http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 50267054345f1a0b77fe65f6e0e5ba29
+# Source0-md5: 70913edaf2263a157393af07565c17f0
 Source1:       %{name}.config
 Source2:       %{name}-initrd.config
 %{?with_altconfig:Source3:     %{cfgfile}}
-Patch100:      busybox-1.19.2-android.patch
-Patch101:      busybox-1.19.2-buildsys.patch
-Patch102:      busybox-1.19.2-chpasswd.patch
-Patch103:      busybox-1.19.2-crond.patch
-Patch104:      busybox-1.19.2-inetd.patch
-Patch105:      busybox-1.19.2-syslogd.patch
-Patch106:      busybox-1.19.2-tail.patch
-Patch107:      busybox-1.19.2-tftp.patch
+Patch0:                x32.patch
 Patch1:                %{name}-logconsole.patch
 Patch2:                %{name}-printf-gettext.patch
 Patch3:                %{name}-loadfont.patch
@@ -62,11 +59,10 @@ Patch5:             %{name}-insmod-morearchs.patch
 Patch6:                %{name}-dhcp.patch
 Patch7:                %{name}-fix_64_archs.patch
 Patch9:                %{name}-ash-export-PATH.patch
-Patch10:       %{name}-toolongcmd.patch
 URL:           http://www.busybox.net/
 BuildRequires: gcc >= 3.2
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.333
+BuildRequires: rpmbuild(macros) >= 1.652
 %if %{with initrd} || %{with static}
        %if %{with dietlibc}
 BuildRequires: dietlibc-static
@@ -74,7 +70,7 @@ BuildRequires:        dietlibc-static
                %if %{with glibc}
 BuildRequires: glibc-static
                %else
-%if "%{_target_base_arch}" != "%{_arch}"
+%if "%{_target_base_arch}" != "%{_host_base_arch}"
 BuildRequires: cross%{_target_base_arch}-uClibc-static
 %else
        %ifarch ppc %{x8664}
@@ -89,11 +85,12 @@ BuildRequires:      uClibc-static >= 3:0.9.30.1
 %{?with_sh_prov:Provides:      /bin/sh}
 %{?with_fileutl_prov:Provides: fileutils}
 %{?with_grep_prov:Provides:    grep}
+Provides:      busybox-implementation = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
 
-%if "%{_target_base_arch}" != "%{_arch}"
+%if "%{_target_base_arch}" != "%{_host_base_arch}"
        %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
 %else
        %define CrossOpts %{nil}
@@ -152,6 +149,7 @@ Summary:    Static busybox for initrd
 Summary(pl.UTF-8):     Statycznie skonsolidowany busybox dla initrd
 Group:         Base
 Conflicts:     geninitrd < 10000.20
+Provides:      busybox-implementation = %{version}-%{release}
 
 %description initrd
 Static busybox for initrd.
@@ -161,15 +159,7 @@ Statycznie skonsolidowany busybox dla initrd.
 
 %prep
 %setup -q
-%patch100 -p1
-%patch101 -p1
-%patch102 -p1
-%patch103 -p1
-%patch104 -p1
-%patch105 -p1
-%patch106 -p1
-%patch107 -p1
-
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 #%patch3 -p1
@@ -178,7 +168,6 @@ Statycznie skonsolidowany busybox dla initrd.
 %patch6 -p1
 %patch7 -p1
 %patch9 -p1
-%patch10 -p1
 
 %build
 install -d built
@@ -197,7 +186,7 @@ install %{SOURCE2} .config
        %{CrossOpts} \
        CC="%{__cc}"
 %else
-       %if "%{_target_base_arch}" != "%{_arch}"
+       %if "%{_target_base_arch}" != "%{_host_base_arch}"
        CROSS="%{_target_cpu}-uclibc-" \
        %endif
        CC="%{_target_cpu}-uclibc-gcc"
@@ -228,7 +217,7 @@ install %{SOURCE1} .config
        %{CrossOpts} \
        CC="%{__cc}"
 %else
-       %if "%{_target_base_arch}" != "%{_arch}"
+       %if "%{_target_base_arch}" != "%{_host_base_arch}"
        CROSS="%{_target_cpu}-uclibc-" \
        %endif
        CC="%{_target_cpu}-uclibc-gcc"
@@ -286,7 +275,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS README .config
 
 %if %{with linkfl}
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) /bin/*
 %attr(755,root,root) /sbin/*
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/*
@@ -295,7 +284,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %{_libdir}/busybox
-%{_mandir}/man1/*
+%{_mandir}/man1/busybox.1*
 %endif
 
 %if %{with static}
This page took 0.042686 seconds and 4 git commands to generate.