]> git.pld-linux.org Git - packages/busybox.git/blobdiff - busybox.spec
- updated to 1.3.1, updated configs
[packages/busybox.git] / busybox.spec
index b01691ff295688e28958bb1eea126767637d1f63..6e43c89a4e9d807549bd2dd14209bebdb61a8aa7 100644 (file)
@@ -1,8 +1,7 @@
-#
 # TODO:
-#      - sparc64 modules support in sparc(32) version
-#      - make internal commands work even if busybox is not in /bin/busybox
-# 
+#      - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
+#      - make internal commands work even if busybox is not in /bin/busybox (initrd)
+#        or when /proc is not mounted (static / normal)
 #
 # Conditional build:
 # alternative busybox config file (replaces default one) you should
 %bcond_with    grep_prov       # adds grep providing
 # Option below is useful, when busybox is built with shell support.
 %bcond_with    sh_prov         # adds /bin/sh providing
-# WARNING! Shell, filetuils and grep providing may depend on config file!
+# WARNING! Shell, fileutils and grep providing may depend on config file!
 # Fileutils, grep and shell provided with busybox have not such
 # functionality as their GNU countenders.
 #
 %bcond_without static          # don't build static version
 %bcond_without initrd          # don't build initrd version
-%bcond_with    dietlibc        # build dietlibc-based initrd version
+#%%bcond_with  dietlibc        # build dietlibc-based initrd version
 %bcond_with    glibc           # build glibc-based initrd version
 #
-%ifnarch %{ix86}
+%ifnarch %{ix86} %{x8664} ppc sparc64
 %define with_glibc 1
 %endif
+%ifarch ppc
+%undefine      with_dietlibc
+%endif
 Summary:       Set of common unix utils for embeded systems
 Summary(pl):   Zestaw narzêdzi uniksowych dla systemów wbudowanych
 Summary(pt_BR):        BusyBox é um conjunto de utilitários UNIX em um único binário
 Name:          busybox
-Version:       1.00
-Release:       2
+Version:       1.3.1
+Release:       1
 License:       GPL
 Group:         Applications
 Source0:       http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 5c7ea9b5d3b3677dfcdcec38b281a756
+# Source0-md5: 571531cfa83726947ccb566de017ad4f
 Source1:       %{name}.config
 Source2:       %{name}-initrd.config
 %{?with_altconfig:Source3:     %{cfgfile}}
-Patch0:                %{name}-logconsole.patch
-Patch1:                %{name}-printf-gettext.patch
-Patch2:                %{name}-loadfont.patch
-Patch3:                %{name}-pivot_root.patch
-Patch4:                %{name}-raid_start.patch
-Patch5:                %{name}-force-dietlibc.patch
-Patch6:                %{name}-ash_exec.patch
-Patch7:                %{name}-kernel_headers.patch
-Patch8:                %{name}-insmod-morearchs.patch
-Patch9:                %{name}-dhcp.patch
-Patch10:       %{name}-switchroot.patch
-Patch11:       %{name}-fix_64_archs.patch
-Patch12:       %{name}-LFS.patch
-Patch13:       %{name}-ftpput.patch
+Patch1:                %{name}-logconsole.patch
+Patch2:                %{name}-printf-gettext.patch
+Patch3:                %{name}-loadfont.patch
+Patch4:                %{name}-ash_exec.patch
+Patch5:                %{name}-kernel_headers.patch
+Patch6:                %{name}-insmod-morearchs.patch
+Patch7:                %{name}-dhcp.patch
+Patch8:                %{name}-fix_64_archs.patch
+Patch9:                %{name}-LFS.patch
+Patch10:       %{name}-noshadow.patch
 URL:           http://www.busybox.net/
 BuildRequires: gcc >= 3.2
+BuildRequires: perl-tools-pod
 %{?with_static:BuildRequires:  glibc-static}
 %if %{with initrd}
        %if %{with dietlibc}
@@ -66,7 +65,15 @@ BuildRequires:       dietlibc-static
                %if %{with glibc}
 BuildRequires: glibc-static
                %else
-BuildRequires: uClibc-static >= 0.9.21
+%if "%{_target_base_arch}" != "%{_arch}"
+BuildRequires: cross%{_target_base_arch}-uClibc-static
+%else
+       %ifarch ppc %{x8664}
+BuildRequires: uClibc-static >= 2:0.9.29
+       %else
+BuildRequires: uClibc-static >= 2:0.9.21
+       %endif
+%endif
                %endif
        %endif
 %endif
@@ -75,9 +82,16 @@ BuildRequires:       uClibc-static >= 0.9.21
 %{?with_sh_prov:Provides:      /bin/sh}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-
 %define                _bindir         /bin
 %define                _initrd_bindir  /bin
+# ld is used to link applets
+%define                filterout_ld    -Wl,--as-needed
+
+%if "%{_target_base_arch}" != "%{_arch}"
+       %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
+%else
+       %define CrossOpts %{nil}
+%endif
 
 %description
 BusyBox combines tiny versions of many common UNIX utilities into a
@@ -139,7 +153,6 @@ Statycznie skonsolidowany busybox dla initrd.
 
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -150,61 +163,66 @@ Statycznie skonsolidowany busybox dla initrd.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
-%patch12 -p1
-%patch13 -p1
 
 %build
-install %{SOURCE1} .config
-
+install -d built
 %if %{with initrd}
 install %{SOURCE2} .config
 %{__make} oldconfig
 %{__make} \
-       CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
+       CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
        LDFLAGS="%{rpmldflags} -static" \
 %if %{with dietlibc}
        LIBRARIES="-lrpc" \
        CC="diet gcc"
 %else
 %if %{with glibc}
+       %{CrossOpts} \
        CC="%{__cc}"
 %else
+    %if "%{_target_base_arch}" != "%{_arch}"
+       CROSS="%{_target_cpu}-uclibc-" \
+    %endif
        CC="%{_target_cpu}-uclibc-gcc"
 %endif
 %endif
 
-mv -f busybox busybox.initrd
+mv -f busybox built/busybox.initrd
 %{__make} clean
-install %{SOURCE1} .config
 %endif
 
+
 %if %{with altconfig}
 install %{SOURCE3} .config
+%else
+install %{SOURCE1} .config
 %endif
 
 %if %{with static}
 %{__make} oldconfig
 %{__make} \
+       %{CrossOpts} \
        CFLAGS_EXTRA="%{rpmcflags}" \
        LDFLAGS="%{rpmldflags} -static" \
        CC="%{__cc}"
-mv -f busybox busybox.static
+mv -f busybox built/busybox.static
 %{__make} clean
 %endif
 
 %{__make} oldconfig
 %{__make} \
+       %{CrossOpts} \
        CFLAGS_EXTRA="%{rpmcflags}" \
        LDFLAGS="%{rpmldflags}" \
        CC="%{__cc}"
+%{__make} busybox.links docs/BusyBox.1
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
 
-%{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
-%{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
+%{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
+%{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
 
 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
@@ -223,7 +241,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS Changelog README .config
+%doc AUTHORS README .config
 
 %if %{with linkfl}
 %attr(755,root,root) /bin/*
This page took 0.066082 seconds and 4 git commands to generate.