]> git.pld-linux.org Git - packages/brlcad.git/blobdiff - brlcad.spec
- remove th bcond
[packages/brlcad.git] / brlcad.spec
index 8b30abea4d85f0f6d352149fe104e27d9dcbc04c..bc0674818dcfa5dc55c474fb667afc8eca943f25 100644 (file)
 #
-# Conditional build:
-%bcond_with    tests           # build with tests
-%bcond_without tests           # build without tests
+# TODO 
+#      - files fixes, what is -static?
+#      - build with system libs: 
 #
-Summary:       BRL CAD
-Summary(pl):   BRL CAD
+Summary:       BRL CAD - solid modeling system
+Summary(pl.UTF-8):     BRL CAD - system modelowania brył
 Name:          brlcad
-Version:       7.8.0
+Version:       7.8.2
 Release:       0.1
 License:       GPL
-Group:         Applications/CAD
-Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
-# Source0-md5: bb4c5fd83ae1dd1b5dd84384f7894fc8
-#Source1:      -
-# Source1-md5: -
-#Patch0:               %{name}-DESTDIR.patch
-URL:           -
-%if %{with initscript}
-BuildRequires: rpmbuild(macros) >= 1.228
-Requires(post,preun):  /sbin/chkconfig
-%endif
-#BuildRequires:        -
-#BuildRequires:        autoconf
-#BuildRequires:        automake
-#BuildRequires:        intltool
-#BuildRequires:        libtool
-#Requires(postun):     -
-#Requires(pre,post):   -
-#Requires(preun):      -
-#Requires:     -
-#Provides:     -
-#Provides:     group(foo)
-#Provides:     user(foo)
-#Obsoletes:    -
-#Conflicts:    -
-#BuildArch:    noarch
-#ExclusiveArch:        %{ix86}
+Group:         X11/Applications/Graphics
+Source0:       http://dl.sourceforge.net/brlcad/%{name}-%{version}.tar.bz2
+# Source0-md5: 38854509545cb4a1b037d1ac47aac731
+URL:           http://brlcad.sourceforge.net/
+BuildRequires: xorg-lib-libICE-devel
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXext-devel
+BuildRequires: xorg-lib-libXi-devel
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXt-devel
+BuildRequires: xorg-lib-libSM-devel
+BuildRequires: SDL-devel
+#Buildrequires:        itcl-devel
+#BuildRequires:        itk-devel
+BuildRequires: python
+BuildRequires: tcl-devel
+BuildRequires: tk-devel
+#BuildRequires:        tk-Img-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-
-%description -l pl
-
-%package subpackage
-Summary:       -
-Summary(pl):   -
-Group:         -
-
-%description subpackage
-
-%description subpackage -l pl
-
-%package libs
-Summary:       -
-Summary(pl):   -
-Group:         Libraries
-
-%description libs
-
-%description libs -l pl
-
+The BRL-CAD package is a powerful Constructive Solid Geometry (CSG)
+solid modeling system with over 20 years development and production
+use by the U.S. military. BRL-CAD includes an interactive geometry
+editor, parallel ray-tracing support for rendering and geometric
+analysis, path-tracing for realistic image synthesis, network
+distributed framebuffer support, image-processing and
+signal-processing tools. The entire package is distributed in source
+code form.
+
+%description -l pl.UTF-8
+BRL-CAD to potężny system modelowania brył CSG (Constructive Solid
+Geometry) rozwijany i używany produkcyjnie od ponad 20 lat w
+amerykańskim wojsku. BRL-CAD zawiera interaktywny edytor geometryczny,
+obsługę równoległego ray-tracingu do renderowania i analizy
+geometrycznej, path-tracing do realistycznej syntezy obrazu, obsługę
+rozproszonego framebuffera po sieci oraz narzędzia do przetwarzania
+obrazu i sygnału. Cały pakiet jest dostępny z kodem źródłowym.
 
 %package devel
-Summary:       Header files for ... library
-Summary(pl):   Pliki nag³ówkowe biblioteki ...
+Summary:       Header files for BRL-CAD
+Summary(pl.UTF-8):     Pliki nagłówkowe pakietu BRL-CAD
 Group:         Development/Libraries
 #Requires:     %{name} = %{version}-%{release}
 
 %description devel
-This is the package containing the header files for ... library.
+This is the package containing the header files for BRL-CAD.
 
-%description devel -l pl
-Ten pakiet zawiera pliki nag³ówkowe biblioteki ....
+%description devel -l pl.UTF-8
+Ten pakiet zawiera pliki nagłówkowe pakietu BRL-CAD.
 
 %package static
-Summary:       Static ... library
-Summary(pl):   Statyczna biblioteka ...
+Summary:       Static BRL-CAD library
+Summary(pl.UTF-8):     Statyczna biblioteka BRL-CAD
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-Static ... library.
+Static BRL-CAD library.
 
-%description static -l pl
-Statyczna biblioteka ....
+%description static -l pl.UTF-8
+Statyczna biblioteka BRL-CAD.
 
 %prep
 %setup -q
-#%setup -q -c -T
-#%setup -q -n %{name}
-#%%setup -q -n %{name}-%{version}.orig -a 1
-#%patch0 -p1
-
-# undos the source
-#find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
-
-# remove CVS control files
-#find -name CVS -print0 | xargs -0 rm -rf
 
 %build
-# if ac/am/* rebuilding is necessary, do it in this order and add
-# appropriate BuildRequires
-#%%{__intltoolize}
-#%%{__gettextize}
-#%%{__libtoolize}
-#%%{__aclocal}
-#%%{__autoconf}
-#%%{__autoheader}
-#%%{__automake}
-#cp -f /usr/share/automake/config.sub .
-%configure
+#/autogen.sh
+%configure \
+       --disable-blt-build \
+       --disable-itcl-build \
+       --disable-itk-build \
+       --disable-png-build \
+       --disable-regex-build \
+       --disable-tcl-build \
+       --disable-tkimg-build \
+       --disable-zlib-build \
+       --disable-debug \
+       --disable-profiling \
+       --enable-optimized \
+       --with-gnu-ld \
+       --prefix=/usr \
+       --exec-prefix=/usr \
+       --bindir=%{_bindir} \
+       --sbindir=%{_sbindir} \
+       --datadir=%{_datadir} \
+       --mandir=%{_mandir} \
+       --sysconfdir=%{_sysconfdir}
 %{__make}
 
 #%{__make} \
@@ -118,64 +105,31 @@ Statyczna biblioteka ....
 
 %install
 rm -rf $RPM_BUILD_ROOT
-# create directories if necessary
-#install -d $RPM_BUILD_ROOT
-#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       DESTIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%pre
-
-%post
-
-%preun
-
-%postun
-
-%if %{with ldconfig}
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
-%endif
-
-%if %{with initscript}
-%post init
-/sbin/chkconfig --add %{name}
-%service %{name} restart
-
-%preun init
-if [ "$1" = "0" ]; then
-       %service -q %{name} stop
-       /sbin/chkconfig --del %{name}
-fi
-%endif
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
-
-%if 0
-# if _sysconfdir != /etc:
-#%%dir %{_sysconfdir}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
-%attr(755,root,root) %{_bindir}/*
+#doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
+%{_bindir}/*
+%{_libdir}/*
+#%%{_libdir}/tk7.4
+#%%{_libdir}/iwidgets4.0.1
 %{_datadir}/%{name}
-%endif
+%{_mandir}/man?/*
 
-# initscript and its config
-%if %{with initscript}
-%attr(754,root,root) /etc/rc.d/init.d/%{name}
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
-%endif
-
-#%{_examplesdir}/%{name}-%{version}
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/brlcad
+%{_includedir}/*.h
 
-%if %{with subpackage}
-%files subpackage
+%files static
 %defattr(644,root,root,755)
-#%doc extras/*.gz
-#%{_datadir}/%{name}-ext
-%endif
+%{_libdir}/*.la
This page took 0.247297 seconds and 4 git commands to generate.