]> git.pld-linux.org Git - packages/bopm.git/blobdiff - bopm.spec
- release 4
[packages/bopm.git] / bopm.spec
index 55d096926e6d1adc32e16fe3014f62b941b7224a..b822fafc333213e3d146dc6155b62004c477eedb 100644 (file)
--- a/bopm.spec
+++ b/bopm.spec
@@ -9,14 +9,11 @@
 # Conditional build:
 %bcond_without tests   # do not perform "make test"
 %bcond_without supervise       # install initscript instead of supervise
-#
-%include       /usr/lib/rpm/macros.perl
-%define                pnam    OPM
 Summary:       Open proxy monitor and blocker, designed for use with ircds
 Summary(pl.UTF-8):     Monitorowanie i blokowanie otwartych proxy do używania z ircd
 Name:          bopm
 Version:       3.1.3
-Release:       0.1
+Release:       4
 License:       GPL
 Group:         Applications/Communications
 Source0:       http://static.blitzed.org/www.blitzed.org/bopm/files/%{name}-%{version}.tar.gz
@@ -25,16 +22,22 @@ Source1:    %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}-supervise.tar.bz2
 # Source3-md5: 247c0438a5e2860097d09a374a521151
+Source4:       http://autoconf-archive.cryp.to/ac_func_snprintf.m4
+# Source4-md5: 9a21dbeadbd731b324e7f740aadea697
+Source5:       http://www.sfr-fresh.com/unix/www/cherokee-0.7.2.tar.gz:t/cherokee-0.7.2/m4/etr_socket_nsl.m4
+# Source5-md5: 137b516e92db49874d3ed1dcf45ea4a9
+Source6:       %{name}.tmpfiles
 Patch0:                %{name}-DESTDIR.patch
 Patch1:                %{name}-shared.patch
 Patch2:                %{name}-cr-connect.patch
 Patch3:                http://www.nedworks.org/bopm/%{name}.whitelists.3.1.2.diff
-Patch4:                http://dgl.cx/2006/09/bopm-conf-cmd.diff
+Patch4:                http://dgl.cx/2006/09/%{name}-conf-cmd.diff
 URL:           http://wiki.blitzed.org/BOPM
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: bison
+BuildRequires: flex
 BuildRequires: libtool
-BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.268
 %{!?with_supervise:Requires(post,preun):       /sbin/chkconfig}
 Requires(postun):      /usr/sbin/groupdel
@@ -44,12 +47,13 @@ Requires(pre):      /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      %{name}-libs = %{version}-%{release}
-%{!?with_supervise:Requires:   rc-scripts >= 0.4.0.17}
 %{?with_supervise:Requires:    daemontools >= 0.76-5}
+%{!?with_supervise:Requires:   rc-scripts >= 0.4.0.17}
 Provides:      group(%{name})
 Provides:      user(%{name})
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%undefine      __cxx
 %define                _supervise      /etc/supervise/%{name}
 
 %description
@@ -113,20 +117,6 @@ Static libopm library.
 %description static -l pl.UTF-8
 Statyczna biblioteka libopm.
 
-%package -n perl-%{pnam}
-Summary:       OPM - Perl interface to libopm open proxy scanning library
-Summary(pl.UTF-8):     OPM - perlowy interfejs do biblioteki libopm szukającej otwartych proxy
-Group:         Development/Languages/Perl
-Requires:      %{name}-libs = %{version}-%{release}
-# should here be Version: 0.01 due to "Provides: OPM.so perl(OPM) = 0.01"?
-
-%description -n perl-%{pnam}
-OPM - Perl interface to libopm open proxy scanning library.
-
-%description -n perl-%{pnam} -l pl.UTF-8
-OPM - perlowy interfejs do biblioteki libopm szukającej otwartych
-proxy.
-
 %prep
 %setup -q
 %patch0 -p1
@@ -141,8 +131,10 @@ find -name CVS | xargs -r rm -rf
 rm -f contrib/bopm.spec
 
 %build
+install %{SOURCE4} .
+install %{SOURCE5} .
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I .
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -152,13 +144,6 @@ rm -f contrib/bopm.spec
 
 %{__make}
 
-cd src/libopm/OPM
-%{__perl} Makefile.PL \
-       INSTALLDIRS=vendor
-%{__make} \
-       OPTIMIZE="%{rpmcflags}"
-%{?with_tests:%{__make} test}
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/var/log/%{name}
@@ -167,7 +152,9 @@ install -d $RPM_BUILD_ROOT/var/log/%{name}
        DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with supervise}
-install -d $RPM_BUILD_ROOT%{_supervise}
+install -d $RPM_BUILD_ROOT%{_supervise} \
+       $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
+
 tar xf %{SOURCE3} -C $RPM_BUILD_ROOT%{_supervise}
 
 install -d $RPM_BUILD_ROOT%{_supervise}/{,log/}supervise
@@ -178,20 +165,16 @@ mkfifo $RPM_BUILD_ROOT%{_supervise}/{,log/}supervise/ok
 
 %else
 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-install -d $RPM_BUILD_ROOT/var/run/%{name}
 %endif
 
+install -d $RPM_BUILD_ROOT/var/run/%{name}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 > $RPM_BUILD_ROOT/var/log/%{name}/bopm.log
 > $RPM_BUILD_ROOT/var/log/%{name}/scan.log
 
-# Perl module
-cd src/libopm/OPM
-%{__make} pure_install \
-       DESTDIR=$RPM_BUILD_ROOT
-rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{pnam}/.packlist
-install -d $RPM_BUILD_ROOT%{_examplesdir}/perl-%{pnam}-%{version}
-mv $RPM_BUILD_ROOT{%{perl_vendorarch},%{_examplesdir}/perl-%{pnam}-%{version}}/bopchecker.pl
+install %{SOURCE6} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
+
+rm $RPM_BUILD_ROOT%{_datadir}/bopm.conf.blitzed
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -238,7 +221,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog INSTALL README bopm.conf.sample
+%doc ChangeLog INSTALL README bopm.conf.sample bopm.conf.blitzed
 %doc contrib/ network-bopm/
 %attr(640,root,bopm) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
 %attr(755,root,root) %{_sbindir}/%{name}
@@ -255,9 +238,9 @@ fi
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_supervise}/log/supervise/*
 %else
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
-%attr(770,root,bopm) %dir /var/run/%{name}
 %endif
-
+/usr/lib/tmpfiles.d/%{name}.conf
+%attr(770,root,bopm) %dir /var/run/%{name}
 %attr(770,root,bopm) %dir /var/log/%{name}
 %attr(640,bopm,bopm) %ghost /var/log/%{name}/bopm.log
 %attr(640,bopm,bopm) %ghost /var/log/%{name}/scan.log
@@ -265,6 +248,7 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libopm.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libopm.so.0
 
 %files devel
 %defattr(644,root,root,755)
@@ -273,16 +257,8 @@ fi
 %{_includedir}/opm_error.h
 %{_includedir}/opm_types.h
 %{_libdir}/libopm.la
+%{_libdir}/libopm.so
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libopm.a
-
-%files -n perl-%{pnam}
-%defattr(644,root,root,755)
-%{perl_vendorarch}/OPM.pm
-%dir %{perl_vendorarch}/auto/OPM
-%{perl_vendorarch}/auto/OPM/OPM.bs
-%attr(755,root,root) %{perl_vendorarch}/auto/OPM/OPM.so
-%{_examplesdir}/perl-OPM-%{version}
-%{_mandir}/man3/OPM.3pm*
This page took 0.104049 seconds and 4 git commands to generate.