]> git.pld-linux.org Git - packages/blender.git/blobdiff - blender.spec
- man page for blender, so some will know how to handle rendering from command line...
[packages/blender.git] / blender.spec
index b8d5a6edc17adde9b7fe6ceb12b7b611cb686c16..f8e22c538f30d2a00025483dbc6ce9e32e59217a 100644 (file)
@@ -1,32 +1,46 @@
+# TODO:
+# - enable internalization support (BR libftgl)
+# - enable OpenAL support
+# - libsolid/libqhull/libode BR ?
+# - package python scripts
+
 Summary:       3D modeling, rendering, animation and game creation package
 Summary(pl):   Pakiet do tworzenia animacji 3D oraz gier
 Name:          blender
-Version:       2.30
-Release:       1
+Version:       2.36
+Release:       3
 License:       GPL
 Group:         X11/Applications/Graphics
-Source0:       http://download.blender.org/source/%{name}-%{version}.tar.bz2
-# Source0-md5: b1e00a4d8f63ca2a7598e20c89a0b7fd
+Source0:       http://download.blender.org/source/%{name}-%{version}.tar.gz
+# Source0-md5: 8e2237c86b12e6061935632495aec875
 Source1:       %{name}.desktop
 Source2:       %{name}.png
+Source3:       %{name}-config.opts
+Source4:       %{name}-wrapper
+Patch0:                %{name}-po_and_locale_names.patch
+Patch1:                %{name}-noxml-yafray.patch
 URL:           http://www.blender.org/
-#BuildRequires:        OpenAL-devel
+BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-devel
 BuildRequires: SDL-devel
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: ftgl-devel
+#BuildRequires:        autoconf
+#BuildRequires:        automake
 #BuildRequires:        esound-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
+BuildRequires: freetype-devel
 BuildRequires: libtool
 BuildRequires: libvorbis-devel
-BuildRequires: openssl-devel >= 0.9.7c
-BuildRequires: python-devel
+BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: python-devel >= 1:2.3
+BuildRequires: scons
 #BuildRequires:        smpeg-devel
 BuildRequires: zlib-devel
 Requires:      OpenGL
 Requires:      python-modules
+Requires:       freetype
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        _noautoreqdep   libGL.so.1 libGLU.so.1
@@ -41,37 +55,65 @@ Blender to darmowy i w pe
 3D oraz gier, dostêpny dla systemów Unix, Windows i BeOS.
 
 %prep
-%setup -q
+%setup -q -n %{name}
+%patch0 -p1
+%patch1 -p1
+mv -f po/pt_{br,BR}.po
+install %{SOURCE3} config.opts
 
 %build
 rm -f missing
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-%{__automake}
-%configure
 
-%{__make}
+RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
+RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
+
+sed -i -e "s|^CCFLAGS =.*|CCFLAGS = [$RPMCFLAGS]|" \
+       -e "s|^CXXFLAGS =.*|CXXFLAGS = [$RPMCFLAGS]|" \
+       -e "s|^LDFLAGS =.*|LDFLAGS = [$RPMLDFLAGS]|" \
+       config.opts
+sed -i -e "s|TARGET_CC =.*|TARGET_CC = '%{__cc}'|" \
+       -e "s|TARGET_CXX =.*|TARGET_CXX = '%{__cxx}'|" \
+       config.opts
+sed -i 's/python2\.3/python%{py_ver}/' config.opts
+
+scons
+%{__make} -C po OCGDIR=..
+
+install -d release/plugins/include
+install -m 644 source/blender/blenpluginapi/*.h release/plugins/include
+chmod +x release/plugins/bmake
+make -C release/plugins/
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir}}
-
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}}
 
+install -m755 blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
+install -m755 %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
+install -m755 blenderplayer $RPM_BUILD_ROOT%{_bindir}
 install -c %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 install -c %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
-cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}
-
-%find_lang %{name} --all-name
+install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
+install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
+install -m644 ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
+install -m644 ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
+install -d $RPM_BUILD_ROOT%{_datadir}/blender/
+cp -a ./release/bpydata $RPM_BUILD_ROOT%{_datadir}/blender/
+cp -a ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender/
+install -m644 ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender/
+install -m644 ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender/
+install -m644 ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender/
+cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}/blender
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files -f %{name}.lang
+%files
 %defattr(644,root,root,755)
-%doc README release*.txt
+%doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt 
+%doc release/text/{blender.html,release*.txt}
 %attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_datadir}
+%attr(755,root,root) %{_libdir}
 %{_desktopdir}/*.desktop
 %{_pixmapsdir}/*.png
This page took 0.064763 seconds and 4 git commands to generate.