]> git.pld-linux.org Git - packages/binutils.git/blobdiff - binutils.spec
- rel 3; replace fix with official upstream one
[packages/binutils.git] / binutils.spec
index 5cb36dfdb1c74790b99d7474cb297bd68b283a84..fc23ef81b15d343425a01be4d35e3bd8caae3975 100644 (file)
@@ -7,7 +7,7 @@
 %bcond_without gold            # don't build gold (no C++ dependencies)
 %bcond_without default_bfd     # default ld.bfd instead of gold
 %bcond_without gasp            # gasp
-%bcond_with    tests
+%bcond_with    tests           # check target
 
 %ifnarch %{ix86} %{x8664} x32
 %undefine      with_gold
@@ -23,30 +23,28 @@ Summary(ru.UTF-8):  Набор инструментов GNU для построе
 Summary(tr.UTF-8):     GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
-Version:       2.25.51.0.1
-Release:       1
-Epoch:         3
+Version:       2.31.1
+Release:       3
+Epoch:         4
 License:       GPL v3+
 Group:         Development/Tools
-# Source0:     https://www.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.xz
-
-# release with no tarball - https://sourceware.org/git/?p=binutils-gdb.git;a=summary
-Source0:       %{name}-%{version}.tar.xz
-# Source0-md5: 4d3bd9694a1c9c318e7afe6db4a23b69
-
+Source0:       http://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
+# Source0-md5: a517a836dd5747cc9e64d81addc517ad
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
 Patch0:                %{name}-gasp.patch
 Patch1:                %{name}-info.patch
 Patch2:                %{name}-libtool-relink.patch
 Patch3:                %{name}-pt_pax_flags.patch
-Patch5:                %{name}-discarded.patch
+Patch4:                %{name}-libdir.patch
+
 Patch6:                %{name}-absolute-gnu_debuglink-path.patch
 Patch7:                %{name}-libtool-m.patch
 Patch8:                %{name}-build-id.patch
 Patch9:                %{name}-tooldir.patch
 Patch10:       %{name}-sanity-check.patch
-Patch11:       %{name}-am.patch
+Patch11:       binutils-bug-23499.patch
+Patch12:       fd-leak.patch
 URL:           http://sources.redhat.com/binutils/
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
@@ -55,13 +53,13 @@ BuildRequires:      flex
 BuildRequires: gettext-tools
 %{?with_gold:BuildRequires:    libstdc++-devel >= 6:4.0-1}
 %{?with_tests:BuildRequires:   libstdc++-static >= 6:4.0}
+BuildRequires: lzip
 BuildRequires: perl-tools-pod
 %ifarch sparc sparc32
 BuildRequires: sparc32
 %endif
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.2
-BuildRequires: xz
 BuildRequires: zlib-devel
 %{?with_tests:BuildRequires:   zlib-static}
 Conflicts:     gcc-c++ < 5:3.3
@@ -80,8 +78,7 @@ Binutils is a collection of binary utilities, including:
 - size - list the section sizes of an object or archive file,
 - strings - list printable strings from files,
 - strip - discard symbols,
-- addr2line - convert addresses to file and line,
-- nlmconv - convert object code into an NLM.
+- addr2line - convert addresses to file and line.
 
 %description -l es.UTF-8
 Binutils es una colección de utilitarios necesarios para compilar
@@ -169,13 +166,15 @@ niektórych pakietów.
 %patch1 -p1
 %patch2 -p1
 %{?with_pax:%patch3 -p1}
-%patch5 -p1
+%patch4 -p1
+
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 # file contains hacks for ac 2.59 only
 %{__rm} config/override.m4
@@ -224,25 +223,26 @@ CXX="%{__cxx}"; export CXX
 sparc32 \
 %endif
 ./configure %{_target_platform} \
-       --disable-debug \
-       --disable-werror \
-       --enable-build-warnings=,-Wno-missing-prototypes \
-       --enable-shared \
-       --enable-lto \
-       --enable-plugins \
-       --with-zlib=yes \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
-       --with-tooldir=%{_prefix} \
-       %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
+       --disable-debug \
+       --disable-werror \
 %ifarch sparc
        --enable-64-bit-bfd \
 %else
        %{?with_allarchs:--enable-64-bit-bfd} \
 %endif
+       --enable-build-warnings=,-Wno-missing-prototypes \
+       --enable-install-libiberty \
+       --enable-lto \
+       --enable-plugins \
+       --enable-shared \
        %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
+       %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
+       --with-tooldir=%{_prefix} \
+       --with-zlib \
 %if %{with gold}
        --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
 %endif
@@ -253,19 +253,19 @@ sparc32 \
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
 
-install -d $RPM_BUILD_ROOT%{_prefix}/lib/bfd-plugins
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 # remove these man pages unless we cross-build for win*/netware platforms.
 # however, this should be done in Makefiles.
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
-cp -p include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
-cp -p libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
+# overwrite libiberty.a with PIC version
+cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
 
 # remove evil -L pointing inside builder's home
 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
@@ -335,13 +335,26 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/size
 %attr(755,root,root) %{_bindir}/strings
 %attr(755,root,root) %{_bindir}/strip
+%{_prefix}/lib/ldscripts
 %{_infodir}/as.info*
 %{_infodir}/binutils.info*
 %{_infodir}/gprof.info*
 %{_infodir}/ld.info*
-%{_prefix}/lib/bfd-plugins
-%{_prefix}/lib/ldscripts
-%{_mandir}/man1/*
+%{_mandir}/man1/addr2line.1*
+%{_mandir}/man1/ar.1*
+%{_mandir}/man1/as.1*
+%{_mandir}/man1/c++filt.1*
+%{_mandir}/man1/elfedit.1*
+%{_mandir}/man1/gprof.1*
+%{_mandir}/man1/ld.1*
+%{_mandir}/man1/nm.1*
+%{_mandir}/man1/objcopy.1*
+%{_mandir}/man1/objdump.1*
+%{_mandir}/man1/ranlib.1*
+%{_mandir}/man1/readelf.1*
+%{_mandir}/man1/size.1*
+%{_mandir}/man1/strings.1*
+%{_mandir}/man1/strip.1*
 %lang(cs) %{_mandir}/cs/man1/*
 %lang(de) %{_mandir}/de/man1/*
 %lang(es) %{_mandir}/es/man1/*
@@ -353,8 +366,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libs -f %{name}-libs.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libbfd-*.so
-%attr(755,root,root) %{_libdir}/libopcodes-*.so
+%attr(755,root,root) %{_libdir}/libbfd-%{version}.so
+%attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
+%dir %{_libdir}/bfd-plugins
 
 %files devel
 %defattr(644,root,root,755)
@@ -366,10 +380,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/ansidecl.h
 %{_includedir}/bfd.h
 %{_includedir}/bfdlink.h
+%{_includedir}/diagnostics.h
 %{_includedir}/dis-asm.h
-%{_includedir}/libiberty.h
 %{_includedir}/plugin-api.h
 %{_includedir}/symcat.h
+%{_includedir}/libiberty
 %{_infodir}/bfd.info*
 
 %files static
This page took 0.095856 seconds and 4 git commands to generate.