]> git.pld-linux.org Git - packages/binutils.git/blobdiff - binutils.spec
- up to 2.19.51.0.4
[packages/binutils.git] / binutils.spec
index 730d8b3640de8788c7ae67f624ca1e4908d97653..c6c1a25fb77d4f19a3f08afb631fae5a826ec82f 100644 (file)
@@ -2,6 +2,13 @@
 # Conditional build:
 %bcond_with    allarchs        # enable all targets
 # define addtargets x,y,z      # build with additional targets x,y,z (e.g. x86_64-linux)
+%bcond_with    gold            # enable gold (gnu ld successor) on supported archs (x86/sparc)
+                               # http://sourceware.org/ml/binutils/2008-03/msg00162.html
+%bcond_without pax             # without PaX flags (for upstream bugreports)
+#
+%ifnarch %{ix86} %{x8664} sparc
+%undefine      with_gold
+%endif
 #
 Summary:       GNU Binary Utility Development Utilities
 Summary(de.UTF-8):     GNU Binary Utility Development Utilities
@@ -13,13 +20,13 @@ Summary(ru.UTF-8):  Набор инструментов GNU для построе
 Summary(tr.UTF-8):     GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
-Version:       2.17.50.0.16
-Release:       2
+Version:       2.19.51.0.4
+Release:       1
 Epoch:         3
-License:       GPL
+License:       GPL v3+
 Group:         Development/Tools
 Source0:       ftp://ftp.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
-# Source0-md5: 1404fe9bc6105dcc27c85787b3222885
+# Source0-md5: 7b0d5a4fd434237922aeeab0409f146d
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
 Patch0:                %{name}-gasp.patch
@@ -31,19 +38,21 @@ Patch5:             %{name}-flex.patch
 Patch6:                %{name}-discarded.patch
 Patch7:                %{name}-absolute-gnu_debuglink-path.patch
 Patch8:                %{name}-libtool-m.patch
-Patch9:                %{name}-pr4497.patch
+Patch9:                %{name}-build-id.patch
 URL:           http://sources.redhat.com/binutils/
-BuildRequires: autoconf >= 2.59
+BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.8.2
 BuildRequires: bison
 BuildRequires: flex
 BuildRequires: gettext-devel
+%if %{with gold}
+BuildRequires: libstdc++-devel >= 6:4.0-1
+%endif
 BuildRequires: perl-tools-pod
 %ifarch sparc sparc32
 BuildRequires: sparc32
 %endif
 BuildRequires: texinfo >= 4.2
-Requires(post,postun): /sbin/ldconfig
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Conflicts:     gcc-c++ < 5:3.3
 Conflicts:     modutils < 2.4.17
@@ -146,7 +155,7 @@ niektórych pakietów.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+%{?with_pax:%patch3 -p1}
 %patch4 -p0
 %patch5 -p1
 %patch6 -p1
@@ -154,14 +163,20 @@ niektórych pakietów.
 %patch8 -p1
 %patch9 -p1
 
+# hacks for ac 2.59 only
+rm config/override.m4
+
 %build
 # non-standard regeneration (needed because of gasp patch)
-cd gas
-aclocal
-automake --cygnus Makefile
-automake --cygnus doc/Makefile
-autoconf
-cd ..
+# AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
+for dir in gas bfd; do
+       cd $dir || exit 1
+       aclocal -I .. -I ../config -I ../bfd
+       automake --cygnus Makefile
+       automake --cygnus doc/Makefile
+       autoconf
+       cd ..
+done
 
 # More targets
 TARGETS=
@@ -198,7 +213,8 @@ sparc32 \
 %else
        %{?with_allarchs:--enable-64-bit-bfd} \
 %endif
-       %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout}
+       %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout} \
+       %{?with_gold:--enable-gold}
 
 %{__make} -j1 configure-bfd
 %{__make} -j1 headers -C bfd
@@ -230,11 +246,16 @@ install libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
 # remove evil -L pointing inside builder's home
 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
 
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir
+
 %find_lang bfd
 %find_lang binutils
 %find_lang gas
 %find_lang gprof
+touch ld.lang
+%if %{without gold}
 %find_lang ld
+%endif
 %find_lang opcodes
 cat bfd.lang opcodes.lang > %{name}-libs.lang
 cat gas.lang gprof.lang ld.lang >> %{name}.lang
@@ -242,32 +263,34 @@ cat gas.lang gprof.lang ld.lang >> %{name}.lang
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%postun        -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%postun        devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README
 %attr(755,root,root) %{_bindir}/[!g]*
 %attr(755,root,root) %{_bindir}/g[!a]*
-%{_prefix}/lib/ldscripts
 %{_infodir}/as.info*
 %{_infodir}/binutils.info*
 %{_infodir}/configure.info*
 %{_infodir}/gprof.info*
+%if %{without gold}
 %{_infodir}/ld.info*
+%{_prefix}/lib/ldscripts
+%endif
 %{_mandir}/man1/*
 %lang(cs) %{_mandir}/cs/man1/*
 %lang(de) %{_mandir}/de/man1/*
This page took 0.255416 seconds and 4 git commands to generate.