]> git.pld-linux.org Git - packages/beryl-core.git/blobdiff - beryl-core.spec
- restored nl lang
[packages/beryl-core.git] / beryl-core.spec
index d83daa08654a694c4be3a7783a197c40d5a2a409..54284039d2272d74b077667193527c28b40fc069 100644 (file)
@@ -1,27 +1,42 @@
+#
+# Conditional build:
+%bcond_without beryl_mesa      # beryl-xgl statically linked with own libGL
+#
 Summary:       OpenGL window and compositing manager
 Summary(pl):   OpenGL-owy zarz±dca okien i sk³adania
 Name:          beryl-core
-Version:       20061004
+Version:       0.1.99.2
 Release:       1
+Epoch:         1
 License:       MIT
 Group:         X11
-Source0:       http://distfiles.xgl-coffee.org/beryl-core/%{name}-%{version}.tar.bz2
-# Source0-md5: 20cd640455a2968ca8fc6354360b0c70
-Patch0:                %{name}-aiglx.patch
+Source0:       http://releases.beryl-project.org/%{version}/%{name}-%{version}.tar.bz2
+# Source0-md5: e439403ce19130e37f46185a65465c9b
+Source1:       http://releases.beryl-project.org/%{version}/beryl-mesa-%{version}.tar.bz2
+# Source1-md5: 387d068091bc5c6fa28f6d754e1296d1
+Patch0:                %{name}-link.patch
+URL:           http://beryl-project.org/
+BuildRequires: GConf2-devel >= 2.0
+BuildRequires: OpenGL-GLX-devel
 BuildRequires: autoconf >= 2.57
-BuildRequires: automake
+BuildRequires: automake >= 1:1.9
 BuildRequires: glib2-devel >= 2.0
+BuildRequires: intltool >= 0.35.0
 BuildRequires: libpng-devel
 BuildRequires: libtool
 BuildRequires: pkgconfig
+BuildRequires: sed >= 4.0
 BuildRequires: startup-notification-devel >= 0.7
 BuildRequires: xorg-lib-libSM-devel
 BuildRequires: xorg-lib-libXcomposite-devel >= 0.3
 BuildRequires: xorg-lib-libXdamage-devel
+BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-proto-glproto-devel
 BuildRequires: xorg-util-makedepend
+Requires:      xorg-app-xvinfo
 Provides:      compiz
+Obsoletes:     compiz-quinnstorm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -48,16 +63,19 @@ dostarczaj
 %package devel
 Summary:       Header files for beryl
 Summary(pl):   Pliki nag³ówkowe dla beryla
-Group:         Development
-Requires:      %{name} = %{version}-%{release}
-Requires:      OpenGL-devel
+Group:         X11/Development/Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      OpenGL-GLX-devel
+Requires:      glib2-devel >= 2.0
 Requires:      libpng-devel
 Requires:      startup-notification-devel >= 0.7
 Requires:      xorg-lib-libSM-devel
 Requires:      xorg-lib-libXcomposite-devel >= 0.3
 Requires:      xorg-lib-libXdamage-devel
+Requires:      xorg-lib-libXinerama-devel
 Requires:      xorg-lib-libXrandr-devel
-Conflicts:     compiz-devel
+Requires:      xorg-proto-glproto-devel
+Obsoletes:     compiz-quinnstorm-devel
 
 %description devel
 Header files for beryl.
@@ -65,15 +83,76 @@ Header files for beryl.
 %description devel -l pl
 Pliki nag³ówkowe dla beryla.
 
+%package gconf
+Summary:       GConf settings plugin for beryl
+Summary(pl):   Wtyczka ustawieñ GConf dla beryla
+Group:         Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description gconf
+GConf settings plugin for beryl.
+
+%description gconf -l pl
+Wtyczka ustawieñ GConf dla beryla.
+
 %prep
-%setup -q -n snapshots/%{name}
+%setup -q %{?with_beryl_mesa: -a1}
 %patch0 -p1
 
+mv -f po/{ca_ES,ca}.po
+mv -f po/{de_DE,de}.po
+mv -f po/{es_ES,es}.po
+mv -f po/{fr_FR,fr}.po
+mv -f po/{hu_HU,hu}.po
+mv -f po/{it_IT,it}.po
+mv -f po/{ja_JP,ja}.po
+mv -f po/{ko_KR,ko}.po
+mv -f po/{pt_PT,pt}.po
+mv -f po/{ru_RU,ru}.po
+mv -f po/{sv_SE,sv}.po
+mv -f po/{uk_UA,uk}.po
+# sv_FI is identical to sv_SE
+
+# NOTE: check the list after any upgrade!
+cat > po/LINGUAS <<EOF
+ca
+de
+es
+es_AR
+fr
+hu
+it
+ja
+ko
+nl
+pl
+pt_BR
+pt
+ru
+sv
+uk
+zh_CN
+zh_HK
+zh_TW
+EOF
+
 %build
-autoreconf -v --install
+%{__glib_gettextize}
+%{__intltoolize} --automake
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+
+# bashisms inside
+sed -i -e 's@^#! /bin/sh$@#!/bin/bash@' configure
 
 %configure \
-       --disable-static
+       %{?with_beryl_mesa:--with-berylmesadir=beryl-mesa} \
+       --disable-static \
+       --enable-gconf
+
 %{__make}
 
 %install
@@ -82,18 +161,48 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+rm -f $RPM_BUILD_ROOT%{_libdir}/beryl/backends/*.la
+
+# program removed
+rm -f $RPM_BUILD_ROOT%{_mandir}/man1/beryl-settings-dump.1
+
+%find_lang %{name}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README TODO
-%attr(755,root,root) %{_bindir}/*
+%doc AUTHORS README TODO
+%attr(755,root,root) %{_bindir}/beryl
+%attr(755,root,root) %{_bindir}/beryl-settings-tool
+%attr(755,root,root) %{_libdir}/libberyldecoration.so.*.*.*
+%attr(755,root,root) %{_libdir}/libberylsettings.so.*.*.*
+%dir %{_libdir}/beryl
+%dir %{_libdir}/beryl/backends
+%attr(755,root,root) %{_libdir}/beryl/backends/libini.so
 %{_datadir}/beryl
-%{_mandir}/man1/*
+%{_mandir}/man1/beryl.1*
+%if %{with beryl_mesa}
+%attr(755,root,root) %{_bindir}/beryl-xgl
+%{_mandir}/man1/beryl-xgl.1*
+%endif
 
 %files devel
 %defattr(644,root,root,755)
-%dir %{_includedir}/beryl
-%{_includedir}/beryl/beryl.h
+%attr(755,root,root) %{_libdir}/libberyldecoration.so
+%attr(755,root,root) %{_libdir}/libberylsettings.so
+%{_libdir}/libberyldecoration.la
+%{_libdir}/libberylsettings.la
+%{_includedir}/beryl
 %{_pkgconfigdir}/beryl.pc
+%{_pkgconfigdir}/berylsettings.pc
+%{_pkgconfigdir}/libberyldecoration.pc
+%{_mandir}/man3/*.3*
+
+%files gconf
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/beryl/backends/libgconf.so
This page took 0.057204 seconds and 4 git commands to generate.