]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- merged libbeecrypt move to /%{_lib} from AC-branch (but in simpler way)
[packages/beecrypt.git] / beecrypt.spec
index da363cf63494110fb3cb7e0113b9ab36a1929f7a..fc250176e6cd41c50ff9a6ea730495d1a33bd318 100644 (file)
@@ -2,15 +2,17 @@
 # WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
 #
 # Conditional build:
-%bcond_without javaglue        # build with Java support
+%bcond_without java    # build with Java support
 %bcond_with    javac           # use javac instead of gcj
 %bcond_without python          # don't build python module
+%bcond_without doc             # don't build documentation
+%bcond_without static_libs     # don't build static libraries
 #
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
 Version:       4.1.2
-Release:       1
+Release:       4
 Epoch:         2
 License:       LGPL
 Group:         Libraries
@@ -22,24 +24,35 @@ Patch2:             %{name}-ac_python.patch
 URL:           http://sourceforge.net/projects/beecrypt/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+%if %{with doc}
 BuildRequires: doxygen
-%if %{with javaglue} && !%{with javac}
-BuildRequires: gcj
 %endif
+%if %{with java} && !%{with javac}
+BuildRequires: gcc-java
+%endif
+%if %{with doc}
 BuildRequires: ghostscript
 BuildRequires: graphviz
-%if %{with javaglue} && %{with javac}
+%endif
+%if %{with java} && %{with javac}
 BuildRequires: jdk
 %endif
 BuildRequires: libtool
+%if %{with java} && !%{with javac}
 BuildRequires: libgcj-devel
+%endif
 %if %{with python}
 BuildRequires: python-devel
 BuildRequires: python-modules
 %endif
+BuildRequires: rpmbuild(macros) >= 1.213
+%if %{with doc}
 BuildRequires: tetex-dvips
 BuildRequires: tetex-format-latex
 BuildRequires: tetex-latex-dstroke
+# note: this is incorrect place, it should be somewhere in tetex packages
+BuildRequires: tetex-metafont
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags_alpha          -mno-explicit-relocs 
@@ -164,9 +177,14 @@ Pythonie na u
 %configure \
        %{?with_javac:ac_cv_have_gcj=no} \
        --without-cplusplus \
-       --with%{!?with_javaglue:out}-javaglue \
+       --with%{!?with_java:out}-javaglue \
        --with-cpu=%{_target_cpu} \
+       %{!?with_static_libs:--enable-static=no} \
+%ifarch %{x8664}
+       --with-arch=x86_64 \
+%else
        --with-arch=%{_target_cpu} \
+%endif
        --with-pic \
        --with%{!?with_python:out}-python
 %{__make}
@@ -175,10 +193,13 @@ Pythonie na u
 %{__make} -C python
 %endif
 
+%if %{with doc}
 doxygen
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/%{_lib}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -188,6 +209,10 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
+mv -f $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.so.*.*.* $RPM_BUILD_ROOT/%{_lib}
+ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libbeecrypt.so.*.*.*) \
+       $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.so
+
 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
 
 %clean
@@ -202,7 +227,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
-%attr(755,root,root) %{_libdir}/libbeecrypt.so.*.*.*
+%attr(755,root,root) /%{_lib}/libbeecrypt.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
@@ -210,11 +235,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libbeecrypt.la
 %{_includedir}/beecrypt
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libbeecrypt.a
+%endif
 
-%if %{with javaglue}
+%if %{with java}
 %files java
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libbeecrypt_java.so.*.*.*
@@ -224,14 +251,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libbeecrypt_java.so
 %{_libdir}/libbeecrypt_java.la
 
+%if %{with static_libs}
 %files java-static
 %defattr(644,root,root,755)
 %{_libdir}/libbeecrypt_java.a
 %endif
+%endif
 
+%if %{with doc}
 %files doc
 %defattr(644,root,root,755)
 %doc docs/html/*
+%endif 
 
 %if %{with python}
 %files -n python-beecrypt
This page took 0.691812 seconds and 4 git commands to generate.