]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- orphaned, outdated
[packages/beecrypt.git] / beecrypt.spec
index c025ac454622d319969e8089a91d2683c81115a6..e0d8d874f9c5aa02786daa37b24943258a6b57a4 100644 (file)
@@ -1,29 +1,62 @@
 #
+# WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
+#
 # Conditional build:
-%bcond_with    javaglue        # build with Java support
+%bcond_without java    # build with Java support
+%bcond_with    javac           # use javac instead of gcj
 %bcond_without python          # don't build python module
+%bcond_without doc             # don't build documentation
 #
-%include       /usr/lib/rpm/macros.python
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
-Version:       3.1.0
-Release:       3
+Version:       4.1.2
+Release:       4
 Epoch:         2
 License:       LGPL
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
-# Source0-md5: 1472cada46e2ab9f532f984de9740386
+Source0:       http://heanet.dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
+# Source0-md5: 820d26437843ab0a6a8a5151a73a657c
 Patch0:                %{name}-opt.patch
-Patch1:                %{name}-python.patch
-Patch2:                %{name}-lib64_fix.patch
+Patch1:                %{name}-lib64_fix.patch
+Patch2:                %{name}-ac_python.patch
 URL:           http://sourceforge.net/projects/beecrypt/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+%if %{with doc}
+BuildRequires: doxygen
+%endif
+%if %{with java} && !%{with javac}
+BuildRequires: gcc-java
+%endif
+%if %{with doc}
+BuildRequires: ghostscript
+BuildRequires: graphviz
+%endif
+%if %{with java} && %{with javac}
+BuildRequires: jdk
+%endif
 BuildRequires: libtool
+%if %{with java} && !%{with javac}
+BuildRequires: libgcj-devel
+%endif
+%if %{with python}
+BuildRequires: python-devel
+BuildRequires: python-modules
+%endif
+BuildRequires: rpmbuild(macros) >= 1.213
+%if %{with doc}
+BuildRequires: tetex-dvips
+BuildRequires: tetex-format-latex
+BuildRequires: tetex-latex-dstroke
+# note: this is incorrect place, it should be somewhere in tetex packages
+BuildRequires: tetex-metafont
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        specflags_alpha         "-mno-explicit-relocs"
+%define                _libaltdir              /%{_lib}
+
+%define                specflags_alpha          -mno-explicit-relocs 
 
 %description
 BeeCrypt is an open source cryptography library that contains highly
@@ -60,12 +93,60 @@ The BeeCrypt Cryptography Library - static library.
 %description static -l pl
 Biblioteka statyczna BeeCrypt.
 
+%package doc
+Summary:       Development documentation for BeeCrypt
+Summary(pl):   Dokumentacja programisty dla biblioteki BeeCrypt
+Group:         Documentation
+
+%description doc
+Development documentation for BeeCrypt.
+
+%description doc -l pl
+Dokumentacja programisty dla biblioteki BeeCrypt.
+
+%package java
+Summary:       BeeCrypt Java glue library
+Summary(pl):   Biblioteka ³±cz±ca BeeCrypt z Jav±
+Group:         Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description java
+BeeCrypt Java glue library.
+
+%description java -l pl
+Biblioteka ³±cz±ca BeeCrypt z Jav±.
+
+%package java-devel
+Summary:       Development files for BeeCrypt Java glue library
+Summary(pl):   Pliki programistyczne biblioteki ³±cz±cej Beecrypt z Jav±
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+Requires:      %{name}-java = %{epoch}:%{version}-%{release}
+
+%description java-devel
+Development files for BeeCrypt Java glue library.
+
+%description java-devel -l pl
+Pliki programistyczne biblioteki ³±cz±cej Beecrypt z Jav±.
+
+%package java-static
+Summary:       BeeCrypt Java glue static library
+Summary(pl):   Statyczna biblioteka ³±cz±ca BeeCrypt z Jav±
+Group:         Development/Libraries
+Requires:      %{name}-java-devel = %{epoch}:%{version}-%{release}
+
+%description java-static
+BeeCrypt Java glue static library.
+
+%description java-static -l pl
+Statyczna biblioteka ³±cz±ca BeeCrypt z Jav±.
+
 %package -n python-beecrypt
 Summary:       Python interface to BeeCrypt library
 Summary(pl):   Pythonowy interfejs do biblioteki BeeCrypt
 Group:         Development/Languages/Python
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-%pyrequires_eq python
+%pyrequires_eq python-libs
 
 %description -n python-beecrypt
 The python-beecrypt package contains a module which permits applications
@@ -77,31 +158,45 @@ Pakiet python-beecrypt zawiera modu
 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2
+%patch2 -p1
+
+# --with-cplusplus or building (even empty) *.cxx into libbeecrypt
+# makes it (and thus rpm) depending on libstdc++ which is unacceptable
+%{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
+# only html docs
+%{__perl} -pi -e 's/^GENERATE_LATEX .*/GENERATE_LATEX = NO/' Doxyfile.in
 
 %build
-rm -f missing
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       --with%{!?with_javaglue:out}-javaglue \
+       %{?with_javac:ac_cv_have_gcj=no} \
+       --without-cplusplus \
+       --with%{!?with_java:out}-javaglue \
        --with-cpu=%{_target_cpu} \
+%ifarch %{x8664}
+       --with-arch=x86_64 \
+%else
        --with-arch=%{_target_cpu} \
+%endif
        --with-pic \
        --with%{!?with_python:out}-python
+
 %{__make} \
-       libaltdir=%{_libdir} \
-       pylibdir=%{py_libdir}
+       libaltdir=%{_libaltdir}
 
 %if %{with python}
-%{__make} -C python \
-       pylibdir=%{py_libdir}
+%{__make} -C python
+%endif
+
+%if %{with doc}
+doxygen
 %endif
 
 %install
@@ -109,36 +204,74 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_libdir}
 
 %{__make} install \
-       libaltdir=%{_libdir} \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       libaltdir=%{_libaltdir}
 
 %if %{with python}
 %{__make} install -C python \
-       libaltdir=%{_libdir} \
-       pylibdir=%{py_libdir} \
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
+rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
+
+ln -sf %{_libaltdir}/$(cd $RPM_BUILD_ROOT%{_libaltdir} ; echo libbeecrypt.so.*.*.*) \
+        $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.so
+%{__sed} "s|libdir='%{_libaltdir}'|libdir='%{_libdir}'|" \
+        $RPM_BUILD_ROOT%{_libaltdir}/libbeecrypt.la > $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.la 
+mv $RPM_BUILD_ROOT%{_libaltdir}/libbeecrypt.a $RPM_BUILD_ROOT%{_libdir}/
+
+%if %{with java}
+mv $RPM_BUILD_ROOT%{_libaltdir}/libbeecrypt_java* $RPM_BUILD_ROOT%{_libdir}/
+%{__sed} -i "s|libdir='%{_libaltdir}'|libdir='%{_libdir}'|" \
+        $RPM_BUILD_ROOT%{_libdir}/libbeecrypt_java.la
+%endif
+
+rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%post  java -p /sbin/ldconfig
+%postun        java -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libaltdir}/libbeecrypt.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/*
+%attr(755,root,root) %{_libdir}/libbeecrypt.so
+%{_libdir}/libbeecrypt.la
+%{_includedir}/beecrypt
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libbeecrypt.a
+
+%if %{with java}
+%files java
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libbeecrypt_java.so.*.*.*
+
+%files java-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libbeecrypt_java.so
+%{_libdir}/libbeecrypt_java.la
+
+%files java-static
+%defattr(644,root,root,755)
+%{_libdir}/libbeecrypt_java.a
+%endif
+
+%if %{with doc}
+%files doc
+%defattr(644,root,root,755)
+%doc docs/html/*
+%endif 
 
 %if %{with python}
 %files -n python-beecrypt
This page took 0.083466 seconds and 4 git commands to generate.