]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- documentation generated with doxygen
[packages/beecrypt.git] / beecrypt.spec
index 9bb20a8869c73fd08a611fab59478c8c66896e45..7d55be80007679eda4f331d159de358a09fdf54b 100644 (file)
@@ -1,18 +1,35 @@
-# _with_javaglue
-%define                snap 20030516
+#
+# WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
+# Conditional build:
+%bcond_with    javaglue        # build with Java support
+%bcond_without python          # don't build python module
+#
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
-Version:       3.0.0
-Release:       0.%{snap}.1
+Version:       4.0.0
+Release:       2
 Epoch:         2
 License:       LGPL
-Group:         Development/Libraries
-Source0:       http://dl.sf.net/%{name}/%{name}-%{version}pre.%{snap}.tar.gz
-Patch0:                %{name}-from_rpm.patch
+Group:         Libraries
+Source0:       http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
+# Source0-md5: f19e060ecc4fc23d8f1268e1b145614f
+Patch0:                %{name}-opt.patch
+Patch1:                %{name}-lib64_fix.patch
+Patch2:                %{name}-ac_python.patch
 URL:           http://sourceforge.net/projects/beecrypt/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake
+BuildRequires: doxygen
+BuildRequires: libtool
+%if %{with python}
+BuildRequires: python-devel
+BuildRequires: python-modules
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                specflags_alpha          -mno-explicit-relocs 
+
 %description
 BeeCrypt is an open source cryptography library that contains highly
 optimized C and assembler implementations of many well-known
@@ -28,7 +45,7 @@ szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
 Summary:       The BeeCrypt Cryptography Library - development files
 Summary(pl):   Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
 The BeeCrypt Cryptography Library - development files.
@@ -40,7 +57,7 @@ Biblioteka kryptograficzna BeeCrypt - pliki dla programist
 Summary:       The BeeCrypt Cryptography Library - static library
 Summary(pl):   Biblioteka statyczna BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 The BeeCrypt Cryptography Library - static library.
@@ -48,43 +65,90 @@ The BeeCrypt Cryptography Library - static library.
 %description static -l pl
 Biblioteka statyczna BeeCrypt.
 
+%package -n python-beecrypt
+Summary:       Python interface to BeeCrypt library
+Summary(pl):   Pythonowy interfejs do biblioteki BeeCrypt
+Group:         Development/Languages/Python
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+%pyrequires_eq python
+
+%description -n python-beecrypt
+The python-beecrypt package contains a module which permits applications
+written in the Python programming language to use the interface
+supplied by BeeCrypt libraries.
+
+%description -n python-beecrypt -l pl
+Pakiet python-beecrypt zawiera modu³, który pozwala aplikacjom napisanym w
+Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
+
 %prep
-%setup  -q -n %{name}-%{version}pre
+%setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+
+# --with-cplusplus or building (even empty) *.cxx into libbeecrypt
+# makes it (and thus rpm) depending on libstdc++ which is unacceptable
+%{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
 
 %build
-rm -f missing
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       --with%{?!_with_javaglue:out}-javaglue
+       --without-cplusplus \
+       --with%{!?with_javaglue:out}-javaglue \
+       --with-cpu=%{_target_cpu} \
+       --with-arch=%{_target_cpu} \
+       --with-pic \
+       --with%{!?with_python:out}-python
 %{__make}
 
+%if %{with python}
+%{__make} -C python
+%endif
+
+doxygen
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%if %{with python}
+%{__make} install -C python \
+       DESTDIR=$RPM_BUILD_ROOT
+%endif
+
+rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc README* CONTRIBUTORS AUTHORS BUGS NEWS 
+%doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/lib*.so
+%doc docs/html/*
+%attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_includedir}/*
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
+
+%if %{with python}
+%files -n python-beecrypt
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/*.so
+%endif
This page took 0.099314 seconds and 4 git commands to generate.