]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- doxygen needs ghostscript,tetex-dvips,tetex-format-latex,tetex-latex-dstroke
[packages/beecrypt.git] / beecrypt.spec
index d4e222c74d5c2d50e4dc73a3098b2f457e3dfcae..0584aca8057735fa021e97b8aaaa1b5d570dea7b 100644 (file)
@@ -1,27 +1,39 @@
 #
+# WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
 # Conditional build:
-# _with_javaglue
+%bcond_with    javaglue        # build with Java support
+%bcond_without python          # don't build python module
 #
-%include       /usr/lib/rpm/macros.python
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
-Version:       3.0.0
-Release:       4
+Version:       4.1.0
+Release:       1
 Epoch:         2
 License:       LGPL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
-# Source0-md5: 18f20c22443f85bd4e285925b56198d9
+# Source0-md5: 073e224bdb27de411c2450717e9aa94c
 Patch0:                %{name}-opt.patch
-Patch1:                %{name}-python.patch
-Patch2:                %{name}-lib64_fix.patch
+Patch1:                %{name}-lib64_fix.patch
+Patch2:                %{name}-ac_python.patch
 URL:           http://sourceforge.net/projects/beecrypt/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+BuildRequires: doxygen
+BuildRequires: ghostscript
 BuildRequires: libtool
+%if %{with python}
+BuildRequires: python-devel
+BuildRequires: python-modules
+%endif
+BuildRequires: tetex-dvips
+BuildRequires: tetex-format-latex
+BuildRequires: tetex-latex-dstroke
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                specflags_alpha          -mno-explicit-relocs 
+
 %description
 BeeCrypt is an open source cryptography library that contains highly
 optimized C and assembler implementations of many well-known
@@ -37,7 +49,7 @@ szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
 Summary:       The BeeCrypt Cryptography Library - development files
 Summary(pl):   Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
 The BeeCrypt Cryptography Library - development files.
@@ -49,7 +61,7 @@ Biblioteka kryptograficzna BeeCrypt - pliki dla programist
 Summary:       The BeeCrypt Cryptography Library - static library
 Summary(pl):   Biblioteka statyczna BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{epoch}:%{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 The BeeCrypt Cryptography Library - static library.
@@ -57,11 +69,22 @@ The BeeCrypt Cryptography Library - static library.
 %description static -l pl
 Biblioteka statyczna BeeCrypt.
 
+%package doc
+Summary:       Development documentation for BeeCrypt
+Summary(pl):   Dokumentacja programisty dla biblioteki BeeCrypt
+Group:         Documentation
+
+%description doc
+Development documentation for BeeCrypt.
+
+%description doc -l pl
+Dokumentacja programisty dla biblioteki BeeCrypt.
+
 %package -n python-beecrypt
 Summary:       Python interface to BeeCrypt library
 Summary(pl):   Pythonowy interfejs do biblioteki BeeCrypt
 Group:         Development/Languages/Python
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 %pyrequires_eq python
 
 %description -n python-beecrypt
@@ -74,26 +97,37 @@ Pakiet python-beecrypt zawiera modu
 Pythonie na u¿ywanie interfejsu dostarczanego przez bibliotekê BeeCrytp.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2
+%patch2 -p1
+
+# --with-cplusplus or building (even empty) *.cxx into libbeecrypt
+# makes it (and thus rpm) depending on libstdc++ which is unacceptable
+%{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
+# only html docs
+%{__perl} -pi -e 's/^GENERATE_LATEX .*/GENERATE_LATEX = NO/' Doxyfile.in
 
 %build
-rm -f missing
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       --with%{?!_with_javaglue:out}-javaglue \
+       --without-cplusplus \
+       --with%{!?with_javaglue:out}-javaglue \
        --with-cpu=%{_target_cpu} \
        --with-arch=%{_target_cpu} \
-       --with-python
+       --with-pic \
+       --with%{!?with_python:out}-python
 %{__make}
 
+%if %{with python}
 %{__make} -C python
+%endif
+
+doxygen
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -101,8 +135,12 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with python}
 %{__make} install -C python \
        DESTDIR=$RPM_BUILD_ROOT
+%endif
+
+rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -117,7 +155,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_includedir}/*
 
@@ -125,6 +163,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
 
+%files doc
+%defattr(644,root,root,755)
+%doc docs/html/*
+
+%if %{with python}
 %files -n python-beecrypt
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/*.so
+%endif
This page took 0.08375 seconds and 4 git commands to generate.