]> git.pld-linux.org Git - packages/beagle.git/blobdiff - beagle.spec
- 0.1.2
[packages/beagle.git] / beagle.spec
index 60984d3797cccae3b42d42cba996a59c6966accc..fe930605a5b9a9892d0ebad17f5d612d20986082 100644 (file)
@@ -1,24 +1,25 @@
 #
-# TODO:
-# - package 'crawl' files
-# - check .desktop files
-# - separate libs (future proof)
+# TODO: 
+#      - finish crawl system
+#       - separtate CLI utilities
 #
 %include       /usr/lib/rpm/macros.mono
 #
 # Conditional build:
-%bcond_without epiphany        # don't build epiphany extension
-%bcond_without evolution       # don't include evolution support
+%bcond_with    epiphany        # don't build epiphany extension
+%bcond_with    evolution       # don't include evolution support
 #
 Summary:       Beagle - An indexing subsystem
 Summary(pl):   Beagle - podsystem indeksuj±cy
 Name:          beagle
-Version:       0.1.0
-Release:       0.1
+Version:       0.1.2
+Release:       0.9
 License:       Various
 Group:         Libraries
 Source0:       http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
-# Source0-md5: 79d43b6b3ff0de919b54b08844b5cea2
+# Source0-md5: 944553979659ed21a68bba307126126a
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-crawl.patch
 URL:           http://beaglewiki.org/Main_Page
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
@@ -43,6 +44,7 @@ BuildRequires:        pkgconfig
 BuildRequires: sqlite-devel
 BuildRequires: wv-devel >= 1.0.0
 BuildRequires: zip
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      dotnet-gmime-sharp >= 2.1.16-2
 %{?with_epiphany:Requires:     epiphany-extensions}
 Requires:      gtk+2 >= 2:2.4.0
@@ -57,11 +59,22 @@ Lucene.Net.
 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
 bazie Lucene.Net.
 
+%package libs
+Summary:       Beagle libraries
+Summary(pl):   Bibiloteki Beagle
+Group:         Libraries
+
+%description libs
+Beagle libraries.
+
+%description libs -l pl
+Bibiloteki Beagle.
+
 %package devel
 Summary:       Beagle development files
 Summary(pl):   Pliki programistyczne Beagle
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description devel
 Beagle development files.
@@ -69,13 +82,35 @@ Beagle development files.
 %description devel -l pl
 Pliki programistyczne Beagle.
 
+%package static
+Summary:       Beagle static libraries
+Summary(pl):   Statyczne biblioteki Beagle
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Beagle static libraries.
+
+%description static -l pl
+Statyczne biblioteki Beagle.
+
+%package crawl-system
+Summary:       Beagle crawl system
+Summary(pl):   System przeszukuj±cy beagle-crawl 
+Group:         Applications/System
+
+%description crawl-system
+Beagle crawl system.
+
+%description crawl-system -l pl
+System przeszukuj±cy beagle-crawl.
+
 %package -n epiphany-extension-beagle
 Summary:       Epiphany extension - beagle
 Summary(pl):   Rozszerzenie dla Epiphany - beagle
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
 Requires:      epiphany >= 1.2.1
-Requires:      epiphany < 1.3.0
 
 %description -n epiphany-extension-beagle
 Epiphany extension that allows Beagle to index every page the user
@@ -87,6 +122,8 @@ odwiedzan
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -94,13 +131,12 @@ odwiedzan
 %{__autoconf}
 %{__automake}
 %configure \
-       --disable-static \
+       --enable-static \
        --enable-gtk-doc \
        --with-html-dir=%{_gtkdocdir} \
        --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
        --%{!?with_evoultion:dis}%{?with_evolution:en}able-evolution-sharp
        
-
 %{__make} \
        MOZILLA_HOME=%{_libdir}/mozilla
 
@@ -121,37 +157,52 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS COPYING ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_sbindir}/*
 
-%dir %{_libdir}/%{name}
 %{_libdir}/%{name}/Filters
 %{_libdir}/%{name}/*.exe
 %{_libdir}/%{name}/*.dll*
 
-# to be separtated
-%attr(755,root,root) %{_libdir}/lib*.so*
-%attr(755,root,root) %{_libdir}/%{name}/lib*.so*
 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
 
 %{_pixmapsdir}/*.png
 %{_desktopdir}/*.desktop
 %{_mandir}/man*/*
 
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/lib*.so.*.*.*
+
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/*.so
+%attr(755,root,root) %{_libdir}/%{name}/*.so
 %{_includedir}/libbeagle
 %{_libdir}/*.la
-%{_libdir}/*.so
 %{_gtkdocdir}/beagle
 %{_pkgconfigdir}/*
 
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/*.a
+%{_libdir}/%{name}/*.a
+
+# not finished yet
+%files crawl-system
+%defattr(644,root,root,755)
+%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
+%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
+%attr(755,root,root) %{_sbindir}/*
+%{_libdir}/beagle-crawl-system
+
 %if %{with epiphany}
 %files -n epiphany-extension-beagle
 %defattr(644,root,root,755)
This page took 0.116514 seconds and 4 git commands to generate.