]> git.pld-linux.org Git - packages/beagle.git/blobdiff - beagle.spec
- TODO updated
[packages/beagle.git] / beagle.spec
index b92bcc1130cf7288f26e8d0778733e3da99bbc92..b8f997f133a531261d79b763b86a5bb014cb6572 100644 (file)
@@ -1,40 +1,54 @@
 #
-# Conditional build:
-%bcond_without epiphany        # don't build epiphany extension (it requires
-                               # epiphany-1.2.x)
+# TODO:
+# - MOZILLA_HOME misdetected
 #
-%define                snap 20040813
-
+# Conditional build:
+%bcond_with    epiphany        # build epiphany extension
+                               # (just a hack)
 Summary:       Beagle - An indexing subsystem
 Summary(pl):   Beagle - podsystem indeksuj±cy
 Name:          beagle
-Version:       0.0.3
-Release:       0.%{snap}.1
+Version:       0.0.12
+Release:       0.1
 License:       Various
 Group:         Libraries
-Source0:       %{name}-%{version}-%{snap}.tar.bz2
-# Source0-md5: 318d6918ab80d8d9b75b07b1b2524b02
-#Source0:      http://ftp.gnome.org/pub/gnome/sources/%{name}/0.0/%{name}-%{version}.tar.bz2
+#Source0:      %{name}-%{version}-%{snap}.tar.bz2
+Source0:       http://ftp.gnome.org/pub/gnome/sources/beagle/0.0/%{name}-%{version}.tar.bz2
+# Source0-md5: 27bfdc64982a471a7d9c2a86c620752d
 Patch0:                %{name}-Filters-dir.patch
 Patch1:                %{name}-pc.patch
-URL:           http://www.gnome.com/
+Patch2:                %{name}-bash.patch
+URL:           http://beaglewiki.org/Main_Page
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
-BuildRequires: dotnet-evolution-sharp-devel >= 0.3
+BuildRequires: dbus-devel
+BuildRequires: dotnet-dbus-sharp-devel >= 0.23.4
+BuildRequires: dotnet-evolution-sharp-devel >= 0.6
+BuildRequires: dotnet-gecko-sharp-devel = 0.6
+BuildRequires: dotnet-gmime-sharp-devel
+#BuildRequires:        dotnet-gsf-sharp-devel >= 0.2
+#BuildRequires:        dotnet-gst-sharp-devel
+BuildRequires: dotnet-gtk-sharp-gnome-devel
 BuildRequires: dotnet-gtk-sharp-devel
-BuildRequires: dotnet-dbus-sharp-devel >= 0.22
-%if %{with epiphany}
-BuildRequires: epiphany-devel >= 1.2.1
-BuildRequires: epiphany-devel < 1.3.0
-%endif
+%{?with_epiphany:BuildRequires:        epiphany-devel >= 1.6}
+BuildRequires: gnome-vfs2-devel
 BuildRequires: gtk+2-devel >= 2:2.4.0
+BuildRequires: libexif-devel >= 0.5.0
+BuildRequires: libgnome-devel
+BuildRequires: libpng-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.6.0
-BuildRequires: mono-csharp
+BuildRequires: mono-csharp >= 1.0.6
+BuildRequires: mozilla-devel
 BuildRequires: pkgconfig
-Requires:      dotnet-evolution-sharp >= 0.3
+BuildRequires: sqlite3-devel
+BuildRequires: wv-devel >= 1.0.0
+BuildRequires: zip
+Requires:      dotnet-dbus-sharp >= 0.23.4
+Requires:      dotnet-evolution-sharp = 0.6
+#Requires:     dotnet-gsf-sharp >= 0.2
+#Requires:     dotnet-gst-sharp
 Requires:      dotnet-gtk-sharp
-Requires:      dotnet-dbus-sharp >= 0.22
 Requires:      gtk+2 >= 2:2.4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -76,8 +90,9 @@ odwiedzan
 
 %prep
 %setup -q
-%patch0 -p0
-%patch1 -p0
+#%patch0 -p0
+#%patch1 -p0
+#%patch2 -p0
 
 %build
 %{__libtoolize}
@@ -85,6 +100,7 @@ odwiedzan
 %{__autoconf}
 %{__automake}
 %configure \
+       --disable-static \
 %if %{with epiphany}
        --enable-epiphany-extension
 %else
@@ -100,26 +116,42 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # Kill useless files
-rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/extensions/*.{a,la}
+rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/extensions/*.la \
+       $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.4.0/filesystems/*.la \
+       $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
+
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS COPYING ChangeLog NEWS README
 %attr(755,root,root)%{_bindir}/*
-%{_libdir}/%{name}
-%{_libdir}/libbeaglechooserhack.so.*
+%dir %{_libdir}/%{name}
+%{_libdir}/%{name}/Filters
+%{_libdir}/%{name}/*.exe
+%{_libdir}/%{name}/*.dll*
+%attr(755,root,root) %{_libdir}/lib*.so*
+%attr(755,root,root) %{_libdir}/%{name}/lib*.so*
+%attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
+%attr(755,root,root) %{_libdir}/gtk-2.0/2.4.0/filesystems/libbeaglechooserhack.so*
+%{_pixmapsdir}/*.png
+%{_desktopdir}/*.desktop
+%{_mandir}/man1/*
 
 %files devel
 %defattr(644,root,root,755)
+%{_includedir}/libbeagle
 %{_pkgconfigdir}/*
-%{_libdir}/libbeaglechooserhack.la
 
 %if %{with epiphany}
 %files -n epiphany-extension-beagle
 %defattr(644,root,root,755)
 %doc epiphany-extension/README
-%attr(755,root,root)%{_libdir}/epiphany/extensions/libbeagleextension.so*
+%attr(755,root,root) %{_libdir}/epiphany/extensions/libbeagleextension.so*
 %endif
This page took 0.052673 seconds and 4 git commands to generate.