]> git.pld-linux.org Git - packages/beagle.git/blobdiff - beagle.spec
- force unbroken evo dotnet version, fix rights for beagle-crawl-system
[packages/beagle.git] / beagle.spec
index be653a1c850be70f3342fed1d3183055d8f86c75..859fa6c7e973c30af56f8053c0161f2a09a1bb8d 100644 (file)
@@ -1,23 +1,23 @@
 #
 # TODO:
-#      - finish crawl system
 #       - separtate CLI utilities
 #
 %include       /usr/lib/rpm/macros.mono
 #
 # Conditional build:
-%bcond_with    epiphany        # don't build epiphany extension
-%bcond_with    evolution       # don't include evolution support
+%bcond_with    epiphany        # build epiphany extension
+%bcond_with    gsf             # build with libgsf support
+%bcond_without evolution       # don't include evolution support
 #
 Summary:       Beagle - An indexing subsystem
 Summary(pl):   Beagle - podsystem indeksuj±cy
 Name:          beagle
-Version:       0.2.0
-Release:       0.9
+Version:       0.2.1
+Release:       2
 License:       Various
 Group:         Libraries
 Source0:       http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
-# Source0-md5: faa236b812db1a8ee72c58d2cb810010
+# Source0-md5: 325ed91dc66fb6be060d0a5f4c8f56dd
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-crawl.patch
 URL:           http://beaglewiki.org/Main_Page
@@ -25,7 +25,7 @@ BuildRequires:        autoconf >= 2.52
 BuildRequires: automake
 %{?with_evolution:BuildRequires:       dotnet-evolution-sharp-devel >= 0.10.2}
 BuildRequires: dotnet-gmime-sharp-devel >= 2.1.19
-BuildRequires: dotnet-gsf-sharp-devel >= 0.7
+%{?with_gsf:BuildRequires:     dotnet-gsf-sharp-devel >= 0.7}
 #BuildRequires:        dotnet-gst-sharp-devel
 BuildRequires: dotnet-gtk-sharp2-gnome-devel >= 2.3.90
 %{?with_epiphany:BuildRequires:        epiphany-devel >= 1.8}
@@ -49,7 +49,6 @@ Requires:     dotnet-gmime-sharp >= 2.1.19
 %{?with_epiphany:Requires:     epiphany-extensions}
 Requires:      gtk+2 >= 2:2.6.0
 Requires:      sqlite
-
 ExcludeArch:   alpha i386 sparc sparc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -100,6 +99,9 @@ Statyczne biblioteki Beagle.
 Summary:       Beagle crawl system
 Summary(pl):   System przeszukuj±cy beagle-crawl
 Group:         Applications/System
+Requires:      crondaemon
+Provides:      group(beagleindex)
+Provides:      user(beagleindex)
 
 %description crawl-system
 Beagle crawl system.
@@ -107,6 +109,20 @@ Beagle crawl system.
 %description crawl-system -l pl
 System przeszukuj±cy beagle-crawl.
 
+%package evolution
+Summary:       Beagle Evolution backend
+Summary(pl):   Backend Beagle dla Evolution
+Group:         X11/Applications/Networking
+Requires:      %{name} = %{version}-%{release}
+Requires:      dotnet-evolution-sharp >= 0.10.2-4
+Requires:      evolution
+
+%description
+Beagle Evolution backend.
+
+%description evolution -l pl
+Backend Beagle dla Evolution.
+
 %package -n epiphany-extension-beagle
 Summary:       Epiphany extension - beagle
 Summary(pl):   Rozszerzenie dla Epiphany - beagle
@@ -137,8 +153,8 @@ Wi
 
 %prep
 %setup -q
-#%patch0 -p1
-#%patch1 -p1
+%patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -158,6 +174,7 @@ Wi
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -177,6 +194,16 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre crawl-system
+%groupadd -g 166 -r -f beagleindex
+%useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
+
+%postun crawl-system
+if [ "$1" = "0" ]; then
+        %userremove beagleindex
+        %groupremove beagleindex
+fi
+
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
@@ -185,7 +212,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS COPYING ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
-
+%dir %{_libdir}/%{name}/Backends
 %{_libdir}/%{name}/Filters
 %attr(755,root,root) %{_libdir}/%{name}/*.exe
 %{_libdir}/%{name}/*.dll*
@@ -213,13 +240,19 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/*.a
 
-# not finished yet
 %files crawl-system
 %defattr(644,root,root,755)
-%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
-%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
+%attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
+%dir %{_sysconfdir}/beagle
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
+%dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
+%dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
 %attr(755,root,root) %{_sbindir}/*
-%{_libdir}/beagle-crawl-system
+%attr(755,root,root) %{_libdir}/beagle-crawl-system
+
+%files evolution
+%defattr(644,root,root,755)
+%{_libdir}/%{name}/Backends/Evolution*
 
 %if %{with epiphany}
 %files -n epiphany-extension-beagle
This page took 0.043443 seconds and 4 git commands to generate.