]> git.pld-linux.org Git - packages/beagle.git/blobdiff - beagle.spec
- 0.2.4, added filtertiff patch (compilation fix for mono 1.1.14), updated
[packages/beagle.git] / beagle.spec
index 9776087e65306eebc590c0ede0d06e85cd246ef4..7441b626aa2dc62e2bdb1688972181d73a7be2bb 100644 (file)
@@ -5,11 +5,14 @@
 %include       /usr/lib/rpm/macros.mono
 #
 # Conditional build:
-%bcond_with    epiphany        # build epiphany extension
-%bcond_with    gsf             # build with libgsf support
 %bcond_without apidocs         # don't build API documentation
 %bcond_without evolution       # don't include evolution support
+%bcond_without galago          # build without galago support
+%bcond_without gsf             # build without libgsf support
 %bcond_without gui             # don't build GNOME based GUI
+%bcond_without python          # don't build python libraries
+%bcond_with    epiphany        # build epiphany extension
+%bcond_with    sqlite3         # use sqlite3 instead of sqlite2
 #
 %if %{without gui}
 %undefine      with_evolution
 Summary:       Beagle - An indexing subsystem
 Summary(pl):   Beagle - podsystem indeksuj±cy
 Name:          beagle
-Version:       0.2.1
-Release:       2.1
+Version:       0.2.4
+Release:       1
 License:       Various
 Group:         Libraries
 Source0:       http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
-# Source0-md5: 325ed91dc66fb6be060d0a5f4c8f56dd
+# Source0-md5: bd915b5f7de56c91dae2c26121c586fa
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-crawl.patch
+Patch2:                %{name}-kill_exec_a.patch
+Patch3:                %{name}-filtertiff.patch
 URL:           http://beaglewiki.org/Main_Page
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 %{?with_evolution:BuildRequires:       dotnet-evolution-sharp-devel >= 0.10.2}
+%{?with_galago:BuildRequires:  dotnet-galago-sharp-devel}
 BuildRequires: dotnet-gmime-sharp-devel >= 2.1.19
 %{?with_gsf:BuildRequires:     dotnet-gsf-sharp-devel >= 0.7}
 #BuildRequires:        dotnet-gst-sharp-devel
@@ -38,15 +44,23 @@ BuildRequires:      dotnet-gtk-sharp2-devel >= 2.3.90
 BuildRequires: gtk+2-devel >= 2:2.6.0
 %{?with_apidocs:BuildRequires: gtk-doc}
 BuildRequires: libexif-devel >= 0.5.0
+BuildRequires: librsvg-devel
 BuildRequires: libpng-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.6.19
-BuildRequires: mono-csharp >= 1.1.10
-BuildRequires: mozilla-devel
+BuildRequires: mono-csharp >= 1.1.13.4
+# not used atm
+#BuildRequires:        mozilla-devel
+%{?with_python:BuildRequires:  python-pygtk-devel}
 BuildRequires: pkgconfig
+BuildRequires: perl-XML-Parser
 BuildRequires: python-devel
+%if %{with sqlite3}
+BuildRequires: sqlite3-devel >= 3.3.4
+%else
 BuildRequires: sqlite-devel
-BuildRequires: wv-devel >= 1.0.0
+%endif
+BuildRequires: wv-devel >= 1.2.1
 BuildRequires: zip
 # GUI BRs
 %if %{with gui}
@@ -56,9 +70,11 @@ BuildRequires:       libgnome-devel
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      dotnet-gmime-sharp >= 2.1.19
-%{?with_epiphany:Requires:     epiphany-extensions}
-Requires:      gtk+2 >= 2:2.6.0
+%if %{with sqlite3}
+Requires:      sqlite3
+%else
 Requires:      sqlite
+%endif
 ExcludeArch:   alpha i386 sparc sparc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -138,7 +154,7 @@ Summary:    Epiphany extension - beagle
 Summary(pl):   Rozszerzenie dla Epiphany - beagle
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
-Requires:      epiphany >= 1.2.1
+Requires:      epiphany-extensions
 
 %description -n epiphany-extension-beagle
 Epiphany extension that allows Beagle to index every page the user
@@ -166,6 +182,7 @@ Summary:    GNOME based Beagle GUI
 Summary(pl):   Bazowane na GNOME GUI dla Beagle
 Group:         Libraries/Python
 Requires:      %{name} = %{version}-%{release}
+Requires:      gtk+2 >= 2:2.6.0
 
 %description search-gui
 GNOME based Beagle GUI.
@@ -177,6 +194,8 @@ Bazowane na GNOME GUI dla Beagle.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p0
 
 %build
 %{__libtoolize}
@@ -234,7 +253,9 @@ fi
 %defattr(644,root,root,755)
 %doc AUTHORS COPYING ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/beagle-config
+%attr(755,root,root) %{_bindir}/beagled
 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
+%attr(755,root,root) %{_bindir}/beagle-extract-content
 %attr(755,root,root) %{_bindir}/beagle-index-info
 %attr(755,root,root) %{_bindir}/beagle-index-url
 %attr(755,root,root) %{_bindir}/beagle-info
@@ -242,21 +263,18 @@ fi
 %attr(755,root,root) %{_bindir}/beagle-query
 %attr(755,root,root) %{_bindir}/beagle-shutdown
 %attr(755,root,root) %{_bindir}/beagle-status
-%attr(755,root,root) %{_bindir}/beagled
-%attr(755,root,root) %{_libdir}/%{name}/lib*.so*
+%attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
+%attr(755,root,root) %{_libdir}/%{name}/*.exe
+%dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/Backends
 %{_libdir}/%{name}/Filters
-%attr(755,root,root) %{_libdir}/%{name}/*.exe
 %{_libdir}/%{name}/*.dll*
-
 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
-
 %{_mandir}/man*/*
 
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
-%dir %{_libdir}/%{name}
 
 %files devel
 %defattr(644,root,root,755)
@@ -272,7 +290,7 @@ fi
 
 %files crawl-system
 %defattr(644,root,root,755)
-%attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
+%attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
 %dir %{_sysconfdir}/beagle
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
@@ -294,14 +312,19 @@ fi
 %{_libdir}/epiphany/1.8/extensions/*.xml
 %endif
 
+%if %{with python}
 %files -n python-%{name}
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/*.so
+%endif
 
 %if %{with gui}
 %files search-gui
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/beagle-search
+%attr(755,root,root) %{_bindir}/beagle-imlogviewer
+%attr(755,root,root) %{_bindir}/beagle-settings
+%attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
 %{_pixmapsdir}/*.png
 %{_desktopdir}/*.desktop
 %endif
This page took 0.09856 seconds and 4 git commands to generate.