]> git.pld-linux.org Git - packages/bash-completion.git/blobdiff - bash-completion.spec
- update to 20020601
[packages/bash-completion.git] / bash-completion.spec
index f780de5773bcac83530c44ebddf5537692eb66f7..bbd07e7261596728b16c7755de2828cf19c97fac 100644 (file)
@@ -1,49 +1,51 @@
-%define bashversion 2.05a
+%define _noautocompressdoc larch p4 isql lilypond harbour dict ri
+# it doesnt't work properly on all systems
+
+Summary:       bash-completion offers programmable completion for bash
+Summary(pl):   Programowalne uzupe³nianie nazw dla basha
 Name:          bash-completion
-Summary:       bash-completion offers programmable completion for bash %{bashversion}
-Version:       20020328
+Version:       20020601
 Release:       1
-Group:         System Environment/Shells
 License:       GPL
+Group:         Applications/Shells
 Source0:       http://www.caliban.org/files/bash/%{name}-%{version}.tar.bz2
 URL:           http://www.caliban.org/bash/
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Requires(post):        grep
+Requires(postun):      sed
 BuildArch:     noarch
 Requires:      bash >= 2.05a-3
-Requires(post):          grep
-Requires(postun): sed
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 bash-completion is a collection of shell functions that take advantage
 of the programmable completion feature of bash 2.04 and later.
-To use this collection, you ideally need bash 2.05a or later
 
 %description -l pl
-bash-completion jest kolekcja funkcji shella, które opieraj sie
-na wbudowanych rozszerzeniach basha 2.04 lub pózniejszego.
-Aby uzywac tej kolekcji, potrzebujesz basha 2.05 lub pózniejszego
+bash-completion jest kolekcj± funkcji shella, które opieraj± siê na
+wbudowanych rozszerzeniach basha 2.04 lub pó¼niejszego umo¿liwiaj±cego
+kompletowanie parametrów linii poleceñ.
 
 %prep
 %setup -q -n bash_completion
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_sysconfdir}
-install bash_completion $RPM_BUILD_ROOT%{_sysconfdir}
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
 
-gzip -9nf README Changelog
+install bash_completion $RPM_BUILD_ROOT%{_sysconfdir}
+
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 if ! grep -q '\[ -f '%{_sysconfdir}'/bash_completion \]' \
-     %{_sysconfdir}/bashrc 2>/dev/null; then
-    cat <<'EOF' >> %{_sysconfdir}/bashrc
+       %{_sysconfdir}/bashrc 2>/dev/null; then
+               cat <<'EOF' >> %{_sysconfdir}/bashrc
 # START bash completion -- do not remove this line
 bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
-if [ "$PS1" ] && [ $bmajor -eq 2 ] && [ $bminor '>' 04 ] \
-   && [ -f %{_sysconfdir}/bash_completion ]; then      # interactive shell
+if [ "$PS1" ] && [ "$bmajor" -eq 2 ] && [ "$bminor" '>' 04 ] \
+       && [ -f %{_sysconfdir}/bash_completion ]; then  # interactive shell
        # Source completion code
         . %{_sysconfdir}/bash_completion
 fi
@@ -54,14 +56,14 @@ fi
 
 %postun
 if [ "$1" -eq 0 ]; then
-    sed -e '/^# START bash completion/,/^# END bash completion/d' /etc/bashrc \
-       > /etc/bashrc.tmp
-    mv -f /etc/bashrc.tmp /etc/bashrc
+       sed -e '/^# START bash completion/,/^# END bash completion/d' /etc/bashrc \
+               > /etc/bashrc.tmp
+       mv -f /etc/bashrc.tmp /etc/bashrc
 fi
-
+chmod 644 /etc/bashrc
 
 %files
 %defattr(644,root,root,755)
+%doc README Changelog contrib
 %{_sysconfdir}/bash_completion
 %dir %{_sysconfdir}/bash_completion.d/
-%doc *.gz  contrib/
This page took 0.032759 seconds and 4 git commands to generate.