]> git.pld-linux.org Git - packages/bash-completion.git/blobdiff - bash-completion.spec
- added bash-completion-man-fix.patch
[packages/bash-completion.git] / bash-completion.spec
index 946505ed5e3bbf6bb9dbe7db33d333ee99ea365d..987980606f3948995d3993b4693e507412f231d4 100644 (file)
@@ -1,30 +1,33 @@
 %define bashversion 2.05a
-Name:          bash-completion
 Summary:       bash-completion offers programmable completion for bash %{bashversion}
-Version:       20020328
-Release:       1
-Group:         System Environment/Shells
+Summary(pl):   Programowalne uzupe³nianie nazw dla basha %{bashversion}
+Name:          bash-completion
+Version:       20020418
+Release:       2
+Group:         Applications/Shells
 License:       GPL
 Source0:       http://www.caliban.org/files/bash/%{name}-%{version}.tar.bz2
+Patch0:                %{name}-man-fix.patch
 URL:           http://www.caliban.org/bash/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 BuildArch:     noarch
-Requires:      bash >= 2.05a-3
+Requires:      bash >= %{bashversion}-3
 Requires(post):        grep
-Requires(postun):      sed
+Requires(postun): sed
 
 %description
 bash-completion is a collection of shell functions that take advantage
-of the programmable completion feature of bash 2.04 and later.
-To use this collection, you ideally need bash 2.05a or later
+of the programmable completion feature of bash 2.04 and later. To use
+this collection, you ideally need bash 2.05a or later.
 
 %description -l pl
-bash-completion jest kolekcja funkcji shella, które opieraj sie
-na wbudowanych rozszerzeniach basha 2.04 lub pózniejszego.
-Aby uzywac tej kolekcji, potrzebujesz basha 2.05 lub pózniejszego
+bash-completion jest kolekcj± funkcji shella, które opieraj± siê na
+wbudowanych rozszerzeniach basha 2.04 lub pó¼niejszego. Aby u¿ywaæ tej
+kolekcji, potrzebujesz basha 2.05a lub pó¼niejszego.
 
 %prep
 %setup -q -n bash_completion
+%patch0 -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -32,6 +35,8 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}
 install bash_completion $RPM_BUILD_ROOT%{_sysconfdir}
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
 
+gzip -9nf README Changelog
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -41,7 +46,7 @@ if ! grep -q '\[ -f '%{_sysconfdir}'/bash_completion \]' \
     cat <<'EOF' >> %{_sysconfdir}/bashrc
 # START bash completion -- do not remove this line
 bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
-if [ "$PS1" ] && [ $bmajor -eq 2 ] && [ $bminor '>' 04 ] \
+if [ "$PS1" ] && [ "$bmajor" -eq 2 ] && [ "$bminor" '>' 04 ] \
    && [ -f %{_sysconfdir}/bash_completion ]; then      # interactive shell
        # Source completion code
         . %{_sysconfdir}/bash_completion
@@ -62,4 +67,4 @@ fi
 %defattr(644,root,root,755)
 %{_sysconfdir}/bash_completion
 %dir %{_sysconfdir}/bash_completion.d/
-%doc README Changelog contrib/
+%doc *.gz  contrib/
This page took 0.065182 seconds and 4 git commands to generate.