]> git.pld-linux.org Git - packages/bash-completion.git/blobdiff - bash-completion.spec
- updated to 20030607
[packages/bash-completion.git] / bash-completion.spec
index fbcce2cd8592ff933cd14350e2b338bb6c7a8fdc..716b48365cbd37f73f80673d37b5f42f83aa4a96 100644 (file)
@@ -1,51 +1,54 @@
-%define bashversion 2.05a
+Summary:       bash-completion offers programmable completion for bash
+Summary(pl):   Programowalne uzupe³nianie nazw dla basha
 Name:          bash-completion
-Summary:       bash-completion offers programmable completion for bash %{bashversion}
-Version:       20020402
+Version:       20030607
 Release:       1
-Group:         Applications/Shells
 License:       GPL
+Group:         Applications/Shells
 Source0:       http://www.caliban.org/files/bash/%{name}-%{version}.tar.bz2
+# Source0-md5: 739ff2ba95f5a0d991e639892f645df2
 URL:           http://www.caliban.org/bash/
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-BuildArch:     noarch
-Requires:      bash >= %{bashversion}-3
+Requires(post,preun):  bash
 Requires(post):        grep
+Requires(post):        textutils
+Requires(postun):      fileutils
 Requires(postun):      sed
+BuildArch:     noarch
+Requires:      bash >= 2.05a-3
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 bash-completion is a collection of shell functions that take advantage
-of the programmable completion feature of bash 2.04 and later. To use
-this collection, you ideally need bash 2.05a or later.
+of the programmable completion feature of bash 2.04 and later.
 
 %description -l pl
 bash-completion jest kolekcj± funkcji shella, które opieraj± siê na
-wbudowanych rozszerzeniach basha 2.04 lub pó¼niejszego. Aby u¿ywac tej
-kolekcji, potrzebujesz basha 2.05a lub pó¼niejszego.
+wbudowanych rozszerzeniach basha 2.04 lub pó¼niejszego umo¿liwiaj±cego
+kompletowanie parametrów linii poleceñ.
 
 %prep
 %setup -q -n bash_completion
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_sysconfdir}
-install bash_completion $RPM_BUILD_ROOT%{_sysconfdir}
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
 
-gzip -9nf README Changelog
+install bash_completion $RPM_BUILD_ROOT%{_sysconfdir}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 if ! grep -q '\[ -f '%{_sysconfdir}'/bash_completion \]' \
-     %{_sysconfdir}/bashrc 2>/dev/null; then
-    cat <<'EOF' >> %{_sysconfdir}/bashrc
+       %{_sysconfdir}/bashrc 2>/dev/null; then
+               umask 022
+               cat <<'EOF' >> %{_sysconfdir}/bashrc
 # START bash completion -- do not remove this line
 bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
-if [ "$PS1" ] && [ $bmajor -eq 2 ] && [ $bminor '>' 04 ] \
-   && [ -f %{_sysconfdir}/bash_completion ]; then      # interactive shell
+if [ "$PS1" ] && [ "$bmajor" -eq 2 ] && [ "$bminor" '>' 04 ] \
+       && [ -f %{_sysconfdir}/bash_completion ]; then  # interactive shell
        # Source completion code
-        . %{_sysconfdir}/bash_completion
+       . %{_sysconfdir}/bash_completion
 fi
 unset bash bmajor bminor
 # END bash completion -- do not remove this line
@@ -54,14 +57,14 @@ fi
 
 %postun
 if [ "$1" -eq 0 ]; then
-    sed -e '/^# START bash completion/,/^# END bash completion/d' /etc/bashrc \
-       > /etc/bashrc.tmp
-    mv -f /etc/bashrc.tmp /etc/bashrc
+       umask 022
+       sed -e '/^# START bash completion/,/^# END bash completion/d' /etc/bashrc \
+               > /etc/bashrc.tmp
+       mv -f /etc/bashrc.tmp /etc/bashrc
 fi
 
-
 %files
 %defattr(644,root,root,755)
+%doc README Changelog contrib
 %{_sysconfdir}/bash_completion
-%dir %{_sysconfdir}/bash_completion.d/
-%doc *.gz  contrib/
+%dir %{_sysconfdir}/bash_completion.d
This page took 0.070801 seconds and 4 git commands to generate.