]> git.pld-linux.org Git - packages/avifile.git/blobdiff - avifile.spec
- freetype2 is back thanks to qboosh for xft patch
[packages/avifile.git] / avifile.spec
index 58039accd42c23332318aafc9186f85c69281fcd..031b5e9772431497a119e358c76053df3d3bf4cd 100644 (file)
@@ -2,25 +2,27 @@
 #
 # Conditional build:
 # _without_qt          - disables QT support
-# _with_divx4          - enables divx4linux support (proprietary, binary-only lib)
+# _with_divx           - enables divx4linux support (proprietary, binary-only
+#                        lib)  note: if disabled, divx is decoded by ffmpeg
 #
-%define                _snapver        20020913
+%define                _snapver        20030107
 %define                _snap           %{_snapver}
 Summary:       Library for playing AVI files
 Summary(pl):   Biblioteka do odtwarzania plików AVI
 Summary(pt_BR):        Biblioteca para reproduzir formatos de áudio e vídeo usando binários win32
 Name:          avifile
-Version:       0.7.16
-Release:       0.%{_snap}.3
+Version:       0.7.24
+Release:       0.%{_snap}.%{?_with_divx:+divx}
 Epoch:         3
 License:       GPL
 Group:         X11/Libraries
-Source0:       http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
+Source0:       %{name}0.7-%{version}-%{_snap}.tar.bz2
 Source1:       %{name}.desktop
 Patch0:                %{name}-shareware.patch
 Patch1:                %{name}-no_libnsl.patch
-Patch2:                %{name}-vidix.patch
-Patch3:                %{name}-configure.patch
+Patch2:                %{name}-configure.patch
+Patch3:                %{name}-fix-keys.patch
+Patch4:                %{name}-xft.patch
 URL:           http://avifile.sourceforge.net/
 BuildRequires: SDL-devel >= 1.2.0
 BuildRequires: XFree86-devel
@@ -28,14 +30,14 @@ BuildRequires:      a52dec-libs-devel
 BuildRequires: audiofile-devel
 BuildRequires: autoconf
 BuildRequires: automake
-%{?_with_divx4:BuildRequires:  divx4linux-devel}
+%{?_with_divx:BuildRequires:   divx4linux-devel}
 BuildRequires: lame-libs-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libogg-devel
 BuildRequires: libtool >= 0:1.4.2-9
 BuildRequires: libvorbis-devel >= 1:1.0
 BuildRequires: nas-devel
-%{?!_without_qt:BuildRequires: qt-devel >= 3.0.5}
+%{?!_without_qt:BuildRequires: qt-devel >= 2.0.0}
 BuildRequires: unzip
 %ifarch %{ix86} ppc
 BuildRequires: xvid-devel
@@ -165,7 +167,7 @@ Dekoder i koder MPEG-4 DivX.
 
 %package vorbis
 Summary:       Vorbis audio plugin
-Summary(pl):   Plugin vorbis audio.
+Summary(pl):   Plugin vorbis audio
 Group:         X11/Libraries
 Requires:      %{name} = %{version}
 
@@ -218,29 +220,37 @@ Dekoder i koder XVID.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
-rm -f missing aclocal.m4
-%{__libtoolize}
-%{__aclocal}
-autoheader
-%{__autoconf}
-%{__automake}
+#rm -f missing aclocal.m4
+#%%{__libtoolize}
+#%%{__aclocal} -I m4
+#%%{__autoheader}
+#%%{__autoconf}
+#%%{__automake}
 
-cd plugins/libmad/libmad
-%{__autoconf}
-cd ../../..
+#cd plugins/libmad/libmad
+#%%{__autoconf}
+#cd ../../..
 
-cd libmmxnow
-%{__autoconf}
-cd ..
+#cd libmmxnow
+#%%{__autoconf}
+#cd ..
+
+./autogen.sh
 
 # This is The WRONG Way (tm)
+%if %{!?_without_qt:1}%{?_without_qt:0}
 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
+%endif
+
+#Temporary removed -I/usr/include/freetype2 cause it break build, I don't know why :(
 
 %configure \
-       CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
+       CPPFLAGS="-I/usr/include/divx -I/usr/include/xvid -I/usr/include/freetype2" \
+       AS="%{__cc}" \
        FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
        --with-qt-includes=%{_includedir}/qt \
        --with-qt-libraries=%{_libdir} \
@@ -248,9 +258,14 @@ for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
        --enable-release \
        --enable-ffmpeg \
        --enable-ffmpeg-a52 \
-       %{?_with_divx4:--enable-divx4} \
+       %{?_with_divx:--enable-divx4} \
+%ifarch i586 i686 athlon
+       --enable-x86opt \
+%else
        --disable-x86opt \
-       %{?_without_qt:--without-qt}
+%endif
+       %{?_without_qt:--without-qt} \
+       %{?_without_qt:--disable-samples}
 
 touch lib/dummy.cpp
 %{__make}
@@ -281,20 +296,20 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 %dir %{_libdir}/avifile*
 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
-%attr(755,root,root) %{_libdir}/avifile*/audiodec.la
+%{_libdir}/avifile*/audiodec.la
 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
-%attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.la
+%{_libdir}/avifile*/mpeg_audiodec.la
 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
-%attr(755,root,root) %{_libdir}/avifile*/ac3pass.la
+%{_libdir}/avifile*/ac3pass.la
 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
-%attr(755,root,root) %{_libdir}/avifile*/mjpeg.la
+%{_libdir}/avifile*/mjpeg.la
 
 %files devel
 %defattr(644,root,root,755)
 %doc doc/README-DEVEL*
 %attr(755,root,root) %{_bindir}/avifile-config
 %attr(755,root,root) %{_bindir}/mmxnow-config
-%attr(755,root,root) %{_libdir}/lib*.la
+%{_libdir}/lib*.la
 %{_libdir}/lib*.so
 %{_includedir}/%{name}
 %{_includedir}/*.h
@@ -319,39 +334,39 @@ rm -rf $RPM_BUILD_ROOT
 %files win32
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
-%attr(755,root,root) %{_libdir}/avifile*/win32.la
+%{_libdir}/avifile*/win32.la
 %endif
 
 %files ffmpeg
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
-%attr(755,root,root) %{_libdir}/avifile*/ffmpeg.la
+%{_libdir}/avifile*/ffmpeg.la
 
-%if %{?_with_divx4:1}%{!?_with_divx4:0}
+%if %{?_with_divx:1}%{!?_with_divx:0}
 %files divx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
-%attr(755,root,root) %{_libdir}/avifile*/divx*.la
+%{_libdir}/avifile*/divx*.la
 %endif
 
 %files vorbis
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
-%attr(755,root,root) %{_libdir}/avifile*/vorbis*.la
+%{_libdir}/avifile*/vorbis*.la
 
 %files mad
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
-%attr(755,root,root) %{_libdir}/avifile*/mad*.la
+%{_libdir}/avifile*/mad*.la
 
 %files lame_audioenc
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
-%attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.la
+%{_libdir}/avifile*/mp3lamebin_audioenc.la
 
-%ifarch %{ix86} ppc sparc sparc64 sparcv9
+%ifarch %{ix86} ppc
 %files xvid
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
-%attr(755,root,root) %{_libdir}/avifile*/xvid.la
+%{_libdir}/avifile*/xvid.la
 %endif
This page took 0.065677 seconds and 4 git commands to generate.