]> git.pld-linux.org Git - packages/avifile.git/blobdiff - avifile.spec
- freetype2 is back thanks to qboosh for xft patch
[packages/avifile.git] / avifile.spec
index 0494f70931f348a7d807e0a7092229288fdbb594..031b5e9772431497a119e358c76053df3d3bf4cd 100644 (file)
@@ -1,46 +1,45 @@
 # It's sick.
-
+#
 # Conditional build:
-# _without_qt - disables QT support 
-
-%define                _snapver        20020816
+# _without_qt          - disables QT support
+# _with_divx           - enables divx4linux support (proprietary, binary-only
+#                        lib)  note: if disabled, divx is decoded by ffmpeg
+#
+%define                _snapver        20030107
 %define                _snap           %{_snapver}
-%define                _ver    0.7.15
 Summary:       Library for playing AVI files
 Summary(pl):   Biblioteka do odtwarzania plików AVI
+Summary(pt_BR):        Biblioteca para reproduzir formatos de áudio e vídeo usando binários win32
 Name:          avifile
-Version:       %{_ver}
-Release:       0.%{_snap}.1
+Version:       0.7.24
+Release:       0.%{_snap}.%{?_with_divx:+divx}
 Epoch:         3
 License:       GPL
 Group:         X11/Libraries
-Source0:       http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
+Source0:       %{name}0.7-%{version}-%{_snap}.tar.bz2
 Source1:       %{name}.desktop
-URL:           http://avifile.sourceforge.net/
 Patch0:                %{name}-shareware.patch
-Patch1:                %{name}-deplib.patch
-Patch2:                %{name}-ac3.patch
-Patch3:                %{name}-size_t.patch
-Patch4:                %{name}-amfix.patch
-Patch5:                %{name}-xvid.patch
+Patch1:                %{name}-no_libnsl.patch
+Patch2:                %{name}-configure.patch
+Patch3:                %{name}-fix-keys.patch
+Patch4:                %{name}-xft.patch
+URL:           http://avifile.sourceforge.net/
 BuildRequires: SDL-devel >= 1.2.0
 BuildRequires: XFree86-devel
-BuildRequires: ac3dec-devel >= 0.6.1
+BuildRequires: a52dec-libs-devel
 BuildRequires: audiofile-devel
 BuildRequires: autoconf
 BuildRequires: automake
-%ifarch %{ix86}
-BuildRequires: divx4linux-devel
-%endif
+%{?_with_divx:BuildRequires:   divx4linux-devel}
 BuildRequires: lame-libs-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libogg-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 0:1.4.2-9
 BuildRequires: libvorbis-devel >= 1:1.0
 BuildRequires: nas-devel
-%{?!_without_qt:BuildRequires: qt-devel >= 3.0.5}
+%{?!_without_qt:BuildRequires: qt-devel >= 2.0.0}
 BuildRequires: unzip
-%ifarch %{ix86} ppc sparc sparc64 sparcv9
+%ifarch %{ix86} ppc
 BuildRequires: xvid-devel
 %endif
 BuildConflicts:        wine-devel
@@ -59,9 +58,16 @@ Avifile jest bibliotek
 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
 
+%description -l pt_BR
+Avifile busca criar uma biblioteca usável de suporte a arquivos AVI e
+um conjunto básico de utilitários (para reprodução, captura e edição)
+para o Linux. Contém classes C++ para leitura e criação de AVIs e
+interfaces para compressores e descompresseores de áudio e vídeo.
+
 %package devel
 Summary:       Header file required to build programs using libavifile
 Summary(pl):   Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
+Summary(pt_BR):        Componentes para desenvolvimento com a avifile
 Group:         X11/Development/Libraries
 Requires:      XFree86-devel
 Requires:      %{name} = %{version}
@@ -73,6 +79,9 @@ Header files required to build programs using libavifile.
 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
 libavifile.
 
+%description devel -l pt_BR
+Componentes para desenvolvimento com a avifile.
+
 %package aviplay
 Summary:       Player for AVI/ASF/WMF files
 Summary(pl):   Odtwarzacz plików AVI/ASF/WMF
@@ -148,7 +157,7 @@ Summary(pl):        Szybki kodek MPEG4
 Group:         X11/Libraries
 Requires:      %{name} = %{version}
 Requires:      divx4linux
-Obsoletes:  avifile-divx4
+Obsoletes:     avifile-divx4
 
 %description divx
 DivX MPEG-4 decoder and encoder.
@@ -158,7 +167,7 @@ Dekoder i koder MPEG-4 DivX.
 
 %package vorbis
 Summary:       Vorbis audio plugin
-Summary(pl):   Plugin vorbis audio.
+Summary(pl):   Plugin vorbis audio
 Group:         X11/Libraries
 Requires:      %{name} = %{version}
 
@@ -206,42 +215,57 @@ XVID decoder and encoder.
 Dekoder i koder XVID.
 
 %prep
-%setup -q -n avifile0.7-%{_ver}
+%setup -q -n avifile0.7-%{version}
 %patch0 -p1
-# was broken and need fixing; without this xmms and avi plugin is broken
-#%patch1 -p1
-#%patch2 -p1
-#%patch3 -p1
-#%patch4 -p1
-#%patch5 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 %build
-rm -f missing aclocal.m4
-%{__libtoolize}
-aclocal
-autoheader
-%{__autoconf}
-automake -a -c --foreign
+#rm -f missing aclocal.m4
+#%%{__libtoolize}
+#%%{__aclocal} -I m4
+#%%{__autoheader}
+#%%{__autoconf}
+#%%{__automake}
+
+#cd plugins/libmad/libmad
+#%%{__autoconf}
+#cd ../../..
 
-cd plugins/libmad/libmad
-       %{__autoconf}
-cd ../../..
+#cd libmmxnow
+#%%{__autoconf}
+#cd ..
 
-cd libmmxnow
-       %{__autoconf}
-cd ..
+./autogen.sh
 
 # This is The WRONG Way (tm)
+%if %{!?_without_qt:1}%{?_without_qt:0}
 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
+%endif
+
+#Temporary removed -I/usr/include/freetype2 cause it break build, I don't know why :(
 
-%configure CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
+%configure \
+       CPPFLAGS="-I/usr/include/divx -I/usr/include/xvid -I/usr/include/freetype2" \
+       AS="%{__cc}" \
+       FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
        --with-qt-includes=%{_includedir}/qt \
-       --with-libac3-path=%{_prefix} \
+       --with-qt-libraries=%{_libdir} \
+       --enable-a52 \
        --enable-release \
        --enable-ffmpeg \
+       --enable-ffmpeg-a52 \
+       %{?_with_divx:--enable-divx4} \
+%ifarch i586 i686 athlon
+       --enable-x86opt \
+%else
        --disable-x86opt \
-       %{?_without_qt:--without-qt}
+%endif
+       %{?_without_qt:--without-qt} \
+       %{?_without_qt:--disable-samples}
 
 touch lib/dummy.cpp
 %{__make}
@@ -250,14 +274,9 @@ touch lib/dummy.cpp
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
 
-# avoid relinking
-for f in plugins/*/*.la ; do
-       sed -e '/^relink_command/d' $f > $f.new
-       mv -f $f.new $f
-done
-
 %{__make} install \
-       DESTDIR="$RPM_BUILD_ROOT"
+       DESTDIR="$RPM_BUILD_ROOT" \
+       m4datadir="%{_aclocaldir}"
 
 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
 
@@ -274,75 +293,80 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
-%attr(755,root,root) %{_libdir}/*.so.*.*
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
 %dir %{_libdir}/avifile*
 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
-%attr(755,root,root) %{_libdir}/avifile*/audiodec.la
+%{_libdir}/avifile*/audiodec.la
 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
-%attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.la
+%{_libdir}/avifile*/mpeg_audiodec.la
 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
-%attr(755,root,root) %{_libdir}/avifile*/ac3pass.la
+%{_libdir}/avifile*/ac3pass.la
 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
-%attr(755,root,root) %{_libdir}/avifile*/mjpeg.la
+%{_libdir}/avifile*/mjpeg.la
 
 %files devel
 %defattr(644,root,root,755)
 %doc doc/README-DEVEL*
 %attr(755,root,root) %{_bindir}/avifile-config
 %attr(755,root,root) %{_bindir}/mmxnow-config
-%attr(755,root,root) %{_libdir}/lib*.la
+%{_libdir}/lib*.la
 %{_libdir}/lib*.so
 %{_includedir}/%{name}
+%{_includedir}/*.h
+%{_aclocaldir}/*.m4
 
-%{?!_without_qt:%files aviplay}
-%{?!_without_qt:%defattr(644,root,root,755)}
-%{?!_without_qt:%attr(755,root,root) %{_bindir}/aviplay}
-%{?!_without_qt:%{_datadir}/%{name}*}
-%{?!_without_qt:%{_applnkdir}/Multimedia/*}
-%{?!_without_qt:%{_pixmapsdir}/*}
+%if %{?_without_qt:0}%{!?_without_qt:1}
+%files aviplay
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/aviplay
+%{_mandir}/man1/aviplay.1*
+%{_datadir}/%{name}*
+%{_applnkdir}/Multimedia/*
+%{_pixmapsdir}/*
 
-%{?!_without_qt:%files utils}
-%{?!_without_qt:%defattr(644,root,root,755)}
-%{?!_without_qt:%attr(755,root,root) %{_bindir}/avi[bcmrt]*}
-%{?!_without_qt:%attr(755,root,root) %{_bindir}/kv4lsetup}
+%files utils
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/avi[bcmrt]*
+%attr(755,root,root) %{_bindir}/kv4lsetup
+%endif
 
 %ifarch %{ix86}
 %files win32
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
-%attr(755,root,root) %{_libdir}/avifile*/win32.la
+%{_libdir}/avifile*/win32.la
 %endif
 
 %files ffmpeg
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
-%attr(755,root,root) %{_libdir}/avifile*/ffmpeg.la
+%{_libdir}/avifile*/ffmpeg.la
 
-%ifarch %{ix86}
+%if %{?_with_divx:1}%{!?_with_divx:0}
 %files divx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
-%attr(755,root,root) %{_libdir}/avifile*/divx*.la
+%{_libdir}/avifile*/divx*.la
 %endif
 
 %files vorbis
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
-%attr(755,root,root) %{_libdir}/avifile*/vorbis*.la
+%{_libdir}/avifile*/vorbis*.la
 
 %files mad
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
-%attr(755,root,root) %{_libdir}/avifile*/mad*.la
+%{_libdir}/avifile*/mad*.la
 
 %files lame_audioenc
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
-%attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.la
+%{_libdir}/avifile*/mp3lamebin_audioenc.la
 
-%ifarch %{ix86} ppc sparc sparc64 sparcv9
+%ifarch %{ix86} ppc
 %files xvid
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
-%attr(755,root,root) %{_libdir}/avifile*/xvid.la
+%{_libdir}/avifile*/xvid.la
 %endif
This page took 0.087627 seconds and 4 git commands to generate.