]> git.pld-linux.org Git - packages/automake.git/blobdiff - automake.spec
- up to 1.11.4
[packages/automake.git] / automake.spec
index e29a6ffae6350c216c71cd834e868f40c7651864..51bff626a245d3ac62aad85f7370102575239266 100644 (file)
@@ -1,47 +1,57 @@
 #
 # Conditional build:
-%bcond_without regeneration    # without full regeneration
-#
+%bcond_with            bootstrap       # without full regeneration
+
 %include       /usr/lib/rpm/macros.perl
 Summary:       GNU automake - Makefile configuration tools
-Summary(de.UTF-8):   GNU automake - Makefile-Konfigurationstools
-Summary(es.UTF-8):   GNU automake - herramientas de configuración de Makefile
-Summary(fr.UTF-8):   automake de GNU - Outils de configuration des makefiles
-Summary(ko.UTF-8):   스스로 Makefile을 만들어주는 GNU 도구
-Summary(pl.UTF-8):   GNU Automake - generator plików Makefile
-Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
-Summary(ru.UTF-8):   GNU automake - инструменты для автоматической генерации Makefile'ов
-Summary(tr.UTF-8):   Makefile yapılandırma araçları
-Summary(uk.UTF-8):   GNU automake - інструменти для автоматичної генерації Makefile'ів
+Summary(de.UTF-8):     GNU automake - Makefile-Konfigurationstools
+Summary(es.UTF-8):     GNU automake - herramientas de configuración de Makefile
+Summary(fr.UTF-8):     automake de GNU - Outils de configuration des makefiles
+Summary(ko.UTF-8):     스스로 Makefile을 만들어주는 GNU 도구
+Summary(pl.UTF-8):     GNU Automake - generator plików Makefile
+Summary(pt_BR.UTF-8):  GNU automake - ferramentas de configuração de Makefile
+Summary(ru.UTF-8):     GNU automake - инструменты для автоматической генерации Makefile'ов
+Summary(tr.UTF-8):     Makefile yapılandırma araçları
+Summary(uk.UTF-8):     GNU automake - інструменти для автоматичної генерації Makefile'ів
 Name:          automake
-Version:       1.10
-Release:       2
+Version:       1.11.4
+Release:       1
 Epoch:         1
-License:       GPL
+License:       GPL v2+
 Group:         Development/Building
-Source0:       ftp://sources.redhat.com/pub/automake/%{name}-%{version}.tar.bz2
-# Source0-md5: 0e2e0f757f9e1e89b66033905860fded
+Source0:       http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
+# Source0-md5: d1dd41acf56a30d8da7bf20c5ac223db
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-man.patch
 Patch2:                %{name}-no_versioned_dir.patch
 Patch3:                %{name}-morearchs.patch
 URL:           http://sources.redhat.com/automake/
-%if %{with regeneration}
-BuildRequires: autoconf >= 2.60
-BuildRequires: automake
+%if %{with bootstrap}
+BuildRequires: autoconf >= 2.62
 %else
-BuildRequires: autoconf = 2.60
+BuildRequires: autoconf >= 2.68
+BuildRequires: automake >= 1:1.10a
 %endif
+BuildRequires: help2man
 BuildRequires: rpm-perlprov
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.7
+BuildRequires: xz
 Requires(pre): fileutils
 Requires:      filesystem >= 3.0-2
 Requires:      perl(File::Glob)
+%if %(%{__perl} -le 'use threads; print 1' || echo 0)
+# required only if perl was built with threads
+Requires:      perl(Thread::Queue)
+Requires:      perl(threads)
+%endif
 Conflicts:     autoconf < 2.60
 Conflicts:     libtool < 2:1.5-11
-#BuildArch:    noarch -- autoconf doesn't allow
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _enable_debug_packages  0
+
 %description
 Automake is an experimental Makefile generator. Automake was inspired
 by the 4.4BSD make and include files, but aims to be portable and to
@@ -98,15 +108,27 @@ Makefile'ів.
 %patch2 -p1
 %patch3 -p1
 
+%if %{without bootstrap}
+# prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
+mkdir m4-tmp
+cd m4-tmp
+ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
+%endif
+
 %build
-%if %{with regeneration}
-%{__aclocal} -I m4
+%if %{without bootstrap}
+%{__aclocal} -I m4-tmp
 %endif
 %{__autoconf}
-%if %{with regeneration}
+%if %{without bootstrap}
 %{__automake}
 %endif
-%configure
+
+# NOTE: _target macro becames "noarch" if ./builder passes --target=noarch, so
+# be sure use plain /usr/bin/rpmbuild.
+%configure \
+       --host=%{_host} \
+       --build=%{_host}
 %{__make}
 
 %install
@@ -117,26 +139,29 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
        DESTDIR=$RPM_BUILD_ROOT \
        pkgvdatadir=%{_datadir}/automake
 
-install aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%postun        -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README THANKS TODO
-%attr(755,root,root) %{_bindir}/*
-%{_infodir}/automake*
-
-%{_mandir}/man1/*
+%attr(755,root,root) %{_bindir}/aclocal*
+%attr(755,root,root) %{_bindir}/automake*
+%{_infodir}/automake.info*
+%{_mandir}/man1/aclocal.1*
+%{_mandir}/man1/aclocal-1.11.1*
+%{_mandir}/man1/automake.1*
+%{_mandir}/man1/automake-1.11.1*
 
 %{_datadir}/aclocal-*
 %dir %{_datadir}/automake
@@ -146,6 +171,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/automake/INSTALL
 %{_datadir}/automake/texinfo.tex
 %{_datadir}/automake/ansi2knr*
+%attr(755,root,root) %{_datadir}/automake/ar-lib
 %attr(755,root,root) %{_datadir}/automake/acinstall
 %attr(755,root,root) %{_datadir}/automake/compile
 %attr(755,root,root) %{_datadir}/automake/config.guess
This page took 0.05509 seconds and 4 git commands to generate.