]> git.pld-linux.org Git - packages/audacity.git/blobdiff - audacity.spec
- resampling library defaults to soxr now
[packages/audacity.git] / audacity.spec
index c0dbcbd150c8c6e315ddbd2e916945e81be76f01..2aa3270022355b951327f6a9451480db97d91a52 100644 (file)
@@ -2,27 +2,32 @@
 # - internal portaudio crashes when only OSS is available on startup
 # - use system portaudio (>= 19, but relies on local changes)
 # - use system portSMF?
-# - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12)
+# - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12), libavutil
 # - use system sbsms (>= 1.6.0, but relies on local changes)
+# - use system libnyquist (if ever; currently it's a part of audacity project)
 #
 # Conditional build:
-%bcond_with    libresample     # using libresample (default libsamplerate)
+%bcond_with    libresample     # using libresample for resampling (default is soxr)
+%bcond_with    libsamplerate   # using libsamplerate for resampling (default is soxr)
 %bcond_with    ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
 #
+%if %{without libresample} && %{without libsamplerate}
+%define        with_soxr       1
+%endif
 Summary:       Audacity - manipulate digital audio waveforms
 Summary(pl.UTF-8):     Audacity - narzędzie do obróbki plików dźwiękowych
 Summary(ru.UTF-8):     Кроссплатформенный звуковой редактор
 Name:          audacity
-Version:       2.0.2
-Release:       0.1
+Version:       2.0.3
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Sound
 #Source0Download: http://code.google.com/p/audacity/downloads/list
-Source0:       http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.bz2
-# Source0-md5: c838bc4485b0af104a7f6d9c6955a284
+Source0:       http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.xz
+# Source0-md5: 648cce8a9ce86eebfc53921172ee9d89
 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
 Source1:       http://audacity.googlecode.com/files/%{name}-manual-%{version}.zip
-# Source1-md5: 2c80017f602dd6239ec3b6b0c25e68df
+# Source1-md5: e11a2b16ec3234b4fdab0a4d396b9def
 Source2:       %{name}.desktop
 Source3:       %{name}-icon.png
 Patch0:                %{name}-system-libs.patch
@@ -31,18 +36,22 @@ Patch2:             %{name}-no-macos.patch
 # modified from http://audioscience.com/internet/download/drivers/released/v4/06/portaudio_asihpi_406.patch
 Patch3:                portaudio_asihpi_406.patch
 URL:           http://audacity.sourceforge.net/
+BuildRequires: alsa-lib-devel
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: expat-devel >= 1.95
 %{?with_ffmpeg:BuildRequires:  ffmpeg-devel >= 0.8.0}
 BuildRequires: flac-c++-devel >= 1.2.0
 BuildRequires: gettext-devel
+BuildRequires: gtk+2-devel >= 2.0
+BuildRequires: jack-audio-connection-kit-devel
 BuildRequires: hpklinux-devel >= 4.06
+BuildRequires: lame-libs-devel
 BuildRequires: libid3tag-devel >= 0.15.0b-2
 BuildRequires: libjpeg-devel
 BuildRequires: libmad-devel >= 0.14.2b-4
 %{?with_libresample:BuildRequires:     libresample-devel >= 0.1.3}
-%{!?with_libresample:BuildRequires:    libsamplerate-devel >= 0.1.2}
+%{?with_libsamplerate:BuildRequires:   libsamplerate-devel >= 0.1.2}
 #BuildRequires:        libsbsms-devel >= 1.6.0
 BuildRequires: libsndfile-devel >= 1.0.0
 BuildRequires: libstdc++-devel
@@ -50,6 +59,7 @@ BuildRequires:        libvorbis-devel >= 1:1.0
 #BuildRequires:        portaudio-devel >= 19
 BuildRequires: pkgconfig
 BuildRequires: soundtouch-devel >= 1.3.0
+%{?with_soxr:BuildRequires:    soxr-devel >= 0.0.5}
 BuildRequires: speex-devel
 BuildRequires: twolame-devel >= 0.3.9
 BuildRequires: unzip
@@ -62,9 +72,10 @@ Requires:    lame-libs
 Requires:      libid3tag >= 0.15.0b-2
 Requires:      libmad >= 0.14.2b-4
 %{?with_libresample:Requires:  libresample >= 0.1.3}
-%{!?with_libresample:Requires: libsamplerate >= 0.1.2}
+%{?with_libsamplerate:Requires:        libsamplerate >= 0.1.2}
 Requires:      libsndfile >= 1.0.0
 Requires:      soundtouch >= 1.3.0
+%{?with_soxr:Requires: soxr >= 0.0.5}
 Requires:      twolame-libs >= 0.3.9
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -112,19 +123,16 @@ cd ../..
 
 export WX_CONFIG=$(which wx-gtk2-unicode-config)
 %configure \
-%if %{with libresample}
-       --with-libresample=system \
-%else
-       --with-libresample=no \
-       --with-libsamplerate=system \
-%endif
-       --with%{!?with_ffmpeg:out}-ffmpeg \
+       --with-ffmpeg%{!?with_ffmpeg:=no} \
        --with-help \
        --with-id3tag=system \
        --with-libmad=system \
+       %{?with_libresample:--with-libresample=system} \
+       %{?with_libsamplerate:--with-libsamplerate=system} \
        --with-libsndfile=system \
        --with-libflac=system \
        --with-sbsms=local \
+       %{?with_soxr:--with-soxr=system} \
        --with-vorbis=system
 
 %{__make}
@@ -142,10 +150,9 @@ cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
 
 # unsupported
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS*
 
 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
-%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
This page took 0.03828 seconds and 4 git commands to generate.