]> git.pld-linux.org Git - packages/arts.git/blobdiff - arts.spec
- updated to 030317 snapshot
[packages/arts.git] / arts.spec
index 8b6cd690028b39bd67777a93aacf017ef7d6a88f..9c504913a62b1d70c1dab410ed57e60c68a15604 100644 (file)
--- a/arts.spec
+++ b/arts.spec
@@ -1,17 +1,25 @@
+#
+# _with_nas            - enable NAS audio support
+# _without_alsa                - disable ALSA support
+#
+
+%define                _state          snapshots
+%define                _ver            030317
+
 Summary:       aRts sound server
 Summary(pl):   Serwer d¼wiêku
 Summary(pt_BR):        Servidor de sons usado pelo KDE
 Name:          arts
-%define        _kdever 3.0.3
-Version:       1.0.3
-Release:       2
-Epoch:         11
+Version:       1.2
+Release:       0.%{_ver}.1
+Epoch:         12
 License:       LGPL
 Vendor:                The KDE Team
 Group:         Libraries
-Source0:       ftp://ftp.kde.org/pub/kde/stable/%{_kdever}/src/%{name}-%{version}.tar.bz2
+Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
+Patch0:                http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-video-20030314.patch
 %ifnarch sparc sparcv9 sparc64
-BuildRequires: alsa-lib-devel
+%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
 %endif
 BuildRequires: audiofile-devel
 BuildRequires: glib2-devel >= 2.0.0
@@ -20,15 +28,17 @@ BuildRequires:      libpng-devel
 # not needed, only ./configure check for this
 #BuildRequires:        libvorbis-devel
 #BuildRequires:        mad-devel
+%{?_with_nas:BuildRequires:    nas-devel}
+%{!?_with_nas:BuildConflicts:  nas-devel}
 BuildRequires: pkgconfig
-BuildRequires: qt-devel >= 3.0.5
-Requires:      qt >= 3.0.5
+BuildRequires: qt-devel >= 3.1
 URL:           http://www.kde.org/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
 %define                _htmldir        /usr/share/doc/kde/HTML
 
+%define                no_install_post_chrpath         1
+
 %description
 aRts sound server.
 
@@ -61,6 +71,7 @@ Summary:      QT dependend part of aRts
 Summary(pl):   Czê¶æ aRts wymagaj±ca QT
 Group:         X11/Libraries
 Requires:      %{name} >= %{version}
+Requires:      qt >= 3.1
 
 %description qt
 QT dependend part of aRts.
@@ -73,7 +84,7 @@ Summary:      Sound server - header files
 Summary(pl):   Serwer d¼wiêku - pliki nag³ówkowe
 Summary(pt_BR):        Arquivos para desenvolvimento com o o aRts
 Group:         Development/Libraries
-Requires:      qt-devel >= 3.0.3
+Requires:      qt-devel >= 3.1
 Requires:      %{name} >= %{version}
 
 %description devel
@@ -90,6 +101,7 @@ Arquivos para desenvolvimento com o o aRts.
 Summary:       GLib dependend part of aRts
 Summary(pl):   Czê¶æ aRts wymagaj±ca GLib
 Group:         X11/Libraries
+Requires:      glib >= 1.2.6
 
 %description glib
 GLib dependend part of aRts.
@@ -98,23 +110,17 @@ GLib dependend part of aRts.
 Czê¶æ aRts wymagaj±ca GLib.
 
 %prep
-%setup -q
-
+%setup -q -n %{name}-%{_ver}
+%patch0 -p1
 %build
 kde_htmldir="%{_htmldir}"; export kde_htmldir
 kde_icondir="%{_pixmapsdir}"; export kde_icondir
 
-#%{__make} -f Makefile.cvs
-
-if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
-       CFLAGS="`pkg-config libpng12 --cflags` %{rpmcflags}"
-fi
-
 %configure \
        --%{?debug:en}%{!?debug:dis}able-debug \
        --enable-final \
        --with-xinerama \
-       --with-alsa 
+       --with%{?_without_alsa:out}-alsa
 
 %{__make}
 
@@ -126,6 +132,15 @@ rm -rf $RPM_BUILD_ROOT
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%post X11   -p /sbin/ldconfig
+%postun X11 -p /sbin/ldconfig
+
+%post qt   -p /sbin/ldconfig
+%postun qt -p /sbin/ldconfig
+
+%post glib   -p /sbin/ldconfig
+%postun glib -p /sbin/ldconfig
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -138,34 +153,30 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/artsrec
 %attr(755,root,root) %{_bindir}/artsshell
 %attr(755,root,root) %{_bindir}/artswrapper
-%attr(755,root,root) %{_libdir}/lib[am]*.so.*.*
-%attr(755,root,root) %{_libdir}/libs[!h]*.so.*.*
-%attr(755,root,root) %{_libdir}/lib[ams]*.la
-%attr(755,root,root) %{_libdir}/libkmedia*.so.*.*
-%attr(755,root,root) %{_libdir}/libkmedia*.la
+##%attr(755,root,root) %{_bindir}/testdhandle
+%{_libdir}/lib[!gqx]*.la
+%attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
 %{_libdir}/mcop
 
-%files X11
+%files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
-%attr(755,root,root) %{_libdir}/libx11globalcomm.la
+%attr(755,root,root) %{_bindir}/artsc-config
+%attr(755,root,root) %{_bindir}/mcopidl
+%{_libdir}/*.so
+%{_includedir}/arts
+%{_includedir}/artsc
 
-%files qt
+%files X11
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
-%attr(755,root,root) %{_libdir}/libqtmcop.la
+%{_libdir}/libx11globalcomm.la
+%attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
 
 %files glib
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
-%attr(755,root,root) %{_libdir}/libgmcop.la
+%{_libdir}/libgmcop.la
+%attr(755,root,root) %{_libdir}/libgmcop.so.*
 
-%files devel
+%files qt
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/artsc-config
-%attr(755,root,root) %{_bindir}/mcopidl
-%{_libdir}/lib[mqsxg]*.so
-%{_libdir}/libarts[!k]*.so
-%{_libdir}/libkmedia*.so
-%{_includedir}/arts
-%{_includedir}/artsc
+%{_libdir}/libqtmcop.la
+%attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.044637 seconds and 4 git commands to generate.