]> git.pld-linux.org Git - packages/apr.git/blobdiff - apr.spec
- updated to 1.2.6, removed obsolete branch patch
[packages/apr.git] / apr.spec
index ec6274254bcb30e533f5efdca8c5284130511689..8238ba85188fdb1176442cb5ca5785693a6cfe69 100644 (file)
--- a/apr.spec
+++ b/apr.spec
@@ -1,22 +1,33 @@
+#
+# Conditional build (Linux 2.4 compat, switch after Ac):
+%bcond_with    epoll           # use epoll() syscall (requires Linux 2.6)
+%bcond_with    sendfile64      # use sendfile64 on even if it requires Linux 2.6
+%bcond_with    tcpnodelaycork  # use TCP_NODELAY|TCP_CORK flags (requires Linux 2.6)
+#
+# Linux 2.4.32 supports sendfile64 only on i386 and mips (only 32-bit archs matter)
+%ifnarch ppc sparc sparc64
+%define                with_sendfile64         1
+%endif
 Summary:       Apache Portable Runtime
 Summary(pl):   Apache Portable Runtime - przeno¶na biblioteka uruchomieniowa
 Name:          apr
-Version:       1.0.1
-Release:       2
+Version:       1.2.6
+Release:       1
 Epoch:         1
 License:       Apache v2.0
 Group:         Libraries
-Source0:       http://www.apache.org/dist/apr/%{name}-%{version}.tar.gz
-# Source0-md5: 0a3cb911ea1823cfa3e5863892774705
+Source0:       http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
+# Source0-md5: b1948b5ff68cedae6d0406ae842274c1
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-metuxmpm.patch
-# EPOLL PATCH: TO BE DROPPED AFTER AC
 Patch2:                %{name}-no-epoll.patch
+Patch3:                %{name}-libtool.patch
 URL:           http://apr.apache.org/
 BuildRequires: autoconf >= 2.13
 BuildRequires: automake
 BuildRequires: libtool >= 1.3.3
-BuildRequires: perl-base
+BuildRequires: libuuid-devel
+BuildRequires: sed >= 4.0
 BuildRequires: python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -49,6 +60,9 @@ Summary:      Header files and development documentation for apr
 Summary(pl):   Pliki nag³ówkowe i dokumentacja programisty do apr
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      libuuid-devel
+Requires:      automake
+Requires:      libtool
 
 %description devel
 Header files and development documentation for apr.
@@ -72,13 +86,17 @@ Statyczna biblioteka apr.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
+%{!?with_epoll:%patch2 -p1}
+%patch3 -p1
 
 %build
 install /usr/share/automake/config.* build
 ./buildconf
 %configure \
-%ifarch %{ix86}
+       %{!?with_tcpnodelaycork:apr_cv_tcp_nodelay_with_cork=no} \
+       %{!?with_sendfile64:ac_cv_func_sendfile64=no} \
+       --with-devrandom=/dev/urandom \
+%ifarch %{ix86} %{i8664}
 %ifnarch i386
        --enable-nonportable-atomics \
 %endif
@@ -95,12 +113,17 @@ rm -rf $RPM_BUILD_ROOT
 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
 
 mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
-install build/{*apr*.m4,*.awk,*.sh,config.*} $RPM_BUILD_ROOT%{_datadir}/build
+install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
 ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
 
-%{__perl} -pi -e 's@^(APR_SOURCE_DIR=).*@$1"%{_datadir}"@' $RPM_BUILD_ROOT%{_bindir}/apr-config
-%{__perl} -pi -e 's@^(apr_builddir|apr_builders)=.*@$1=%{_datadir}/build-1@' \
+sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
+       $RPM_BUILD_ROOT%{_bindir}/apr-1-config
+sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
        $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
+sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -128,6 +151,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_datadir}/build/config.*
 %attr(755,root,root) %{_datadir}/build/*.sh
 %attr(755,root,root) %{_datadir}/build/libtool
+%attr(755,root,root) %{_datadir}/build/gen-build.py
 %{_datadir}/build-1
 %{_pkgconfigdir}/apr-1.pc
 
This page took 0.03559 seconds and 4 git commands to generate.