]> git.pld-linux.org Git - packages/apr.git/blobdiff - apr.spec
- updated to 1.2.6, removed obsolete branch patch
[packages/apr.git] / apr.spec
index 3220b96e16db8bcdd5b1e1bce182a617c8183a6a..8238ba85188fdb1176442cb5ca5785693a6cfe69 100644 (file)
--- a/apr.spec
+++ b/apr.spec
@@ -1,18 +1,34 @@
-%define        snap    20030913101709
+#
+# Conditional build (Linux 2.4 compat, switch after Ac):
+%bcond_with    epoll           # use epoll() syscall (requires Linux 2.6)
+%bcond_with    sendfile64      # use sendfile64 on even if it requires Linux 2.6
+%bcond_with    tcpnodelaycork  # use TCP_NODELAY|TCP_CORK flags (requires Linux 2.6)
+#
+# Linux 2.4.32 supports sendfile64 only on i386 and mips (only 32-bit archs matter)
+%ifnarch ppc sparc sparc64
+%define                with_sendfile64         1
+%endif
 Summary:       Apache Portable Runtime
+Summary(pl):   Apache Portable Runtime - przeno¶na biblioteka uruchomieniowa
 Name:          apr
-Version:       0.9.4
-Release:       0.%{snap}.2
+Version:       1.2.6
+Release:       1
 Epoch:         1
-License:       GPL
+License:       Apache v2.0
 Group:         Libraries
-# http://www.apache.org/dist/apr/%{name}-%{version}.tar.gz
-Source0:       http://cvs.apache.org/snapshots/apr/%{name}_%{snap}.tar.gz
-# Source0-md5: d14874964cd7f686594534d9e949eaee
+Source0:       http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
+# Source0-md5: b1948b5ff68cedae6d0406ae842274c1
+Patch0:                %{name}-link.patch
+Patch1:                %{name}-metuxmpm.patch
+Patch2:                %{name}-no-epoll.patch
+Patch3:                %{name}-libtool.patch
 URL:           http://apr.apache.org/
-BuildRequires: libtool
-BuildRequires: autoconf
-BuildRequires: perl-base
+BuildRequires: autoconf >= 2.13
+BuildRequires: automake
+BuildRequires: libtool >= 1.3.3
+BuildRequires: libuuid-devel
+BuildRequires: sed >= 4.0
+BuildRequires: python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _includedir     /usr/include/apr
@@ -28,29 +44,63 @@ regardless of the platform on which their software is built, relieving
 them of the need to code special-case conditions to work around or
 take advantage of platform-specific deficiencies or features.
 
+%description -l pl
+Celem projektu APR (Apache Portable Runtime) jest stworzenie i
+utrzymywanie bibliotek dostarczaj±cych przewidywalnego i spójnego
+interfejsu do le¿±cych u podstaw implementacji zale¿nych od platformy.
+G³ównym celem jest dostarczenie API, którego mog± u¿ywaæ programi¶ci
+maj±c pewno¶æ, ¿e zachowuje siê w sposób przewidywalny, je¶li nie
+identyczny, niezale¿nie od platformy na jakiej oprogramowanie jest
+budowane oraz bez potrzeby kodowania specjalnych warunków do
+obchodzenia lub wykorzystywania specyficznych dla platform ró¿nic lub
+mo¿liwo¶ci.
+
 %package devel
-Summary:       Header files and develpment documentation for apr
+Summary:       Header files and development documentation for apr
+Summary(pl):   Pliki nag³ówkowe i dokumentacja programisty do apr
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      libuuid-devel
+Requires:      automake
 Requires:      libtool
 
 %description devel
-Header files and develpment documentation for apr.
+Header files and development documentation for apr.
+
+%description devel -l pl
+Pliki nag³ówkowe i dokumentacja programisty do apr.
 
 %package static
 Summary:       Static apr library
+Summary(pl):   Statyczna biblioteka apr
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{epoch}:%{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 Static apr library.
 
+%description static -l pl
+Statyczna biblioteka apr.
+
 %prep
-%setup  -q -n %{name}
+%setup -q
+%patch0 -p1
+%patch1 -p1
+%{!?with_epoll:%patch2 -p1}
+%patch3 -p1
 
 %build
+install /usr/share/automake/config.* build
 ./buildconf
 %configure \
+       %{!?with_tcpnodelaycork:apr_cv_tcp_nodelay_with_cork=no} \
+       %{!?with_sendfile64:ac_cv_func_sendfile64=no} \
+       --with-devrandom=/dev/urandom \
+%ifarch %{ix86} %{i8664}
+%ifnarch i386
+       --enable-nonportable-atomics \
+%endif
+%endif
        --enable-threads
 %{__make}
 
@@ -62,20 +112,28 @@ rm -rf $RPM_BUILD_ROOT
 
 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
 
-install build/{*apr*.m4,*.awk,*.sh,config.*}   $RPM_BUILD_ROOT%{_datadir}/build
+mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
+install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
+ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
 
-perl -pi -e "s#$RPM_BUILD_DIR/%{name}#%{_datadir}#g" $RPM_BUILD_ROOT%{_bindir}/*
-perl -pi -e "s#$RPM_BUILD_DIR/%{name}.*#%{_datadir}/build#g" $RPM_BUILD_ROOT%{_datadir}/build/*
-
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
+       $RPM_BUILD_ROOT%{_bindir}/apr-1-config
+sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
+       $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
+sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc CHANGES STATUS docs/*.html
+%doc CHANGES docs/*.html
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
@@ -93,6 +151,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_datadir}/build/config.*
 %attr(755,root,root) %{_datadir}/build/*.sh
 %attr(755,root,root) %{_datadir}/build/libtool
+%attr(755,root,root) %{_datadir}/build/gen-build.py
+%{_datadir}/build-1
+%{_pkgconfigdir}/apr-1.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.114483 seconds and 4 git commands to generate.