]> git.pld-linux.org Git - packages/apache1.git/blobdiff - apache1.spec
- notes
[packages/apache1.git] / apache1.spec
index 362e7ec1804ce6da1194d2bf5c5c62d2782c3408..a454fe1ea28af8d3656b26dfb18eb4075384a7c6 100644 (file)
@@ -31,7 +31,7 @@ Summary(uk):  
 Summary(zh_CN):        Internet ÉÏÓ¦ÓÃ×î¹ã·ºµÄ Web ·þÎñ³ÌÐò¡£
 Name:          apache1
 Version:       1.3.33
-Release:       3.7
+Release:       3.11
 License:       Apache Group
 Group:         Networking/Daemons
 Source0:       http://www.apache.org/dist/httpd/apache_%{version}.tar.gz
@@ -88,15 +88,21 @@ URL:                http://www.apache.org/
 BuildRequires: db-devel >= 4.1
 BuildRequires: mm-devel >= 1.3.0
 %{?with_rewrite_ldap:BuildRequires:    openldap-devel}
-BuildRequires: rpmbuild(macros) >= 1.159
+BuildRequires: rpmbuild(macros) >= 1.177
 BuildRequires: rpm-perlprov
 PreReq:                mm
 PreReq:                perl-base
 PreReq:                rc-scripts
 Requires(pre): /bin/id
 %if %{without minimal}
+# essental modules (maybe remove these in future if all Requires in
+# place for other packages).
 Requires:      %{name}-mod_access = %{version}-%{release}
 Requires:      %{name}-mod_alias = %{version}-%{release}
+Requires:      %{name}-mod_log_config = %{version}-%{release}
+Requires:      %{name}-mod_mime = %{version}-%{release}
+# for errordocs
+Requires:      %{name}-mod_include = %{version}-%{release}
 %endif
 Requires(pre): /usr/bin/getent
 Requires(pre): /usr/bin/getgid
@@ -1114,8 +1120,6 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,monit} \
 %{__make} -j1 install-quiet \
        root=$RPM_BUILD_ROOT
 
-#mv -f $RPM_BUILD_ROOT%{_datadir}/html/manual $RPM_BUILD_ROOT%{_datadir}
-
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/apache1
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apache
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/apache1
@@ -1186,8 +1190,7 @@ rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/modules
 ln -s %{_libexecdir} $RPM_BUILD_ROOT%{_sysconfdir}/modules
 ln -s /var/log/apache $RPM_BUILD_ROOT%{_sysconfdir}/logs
 
-#htpasswd
-ln -sf ln -sf %{_bindir}/htpasswd $RPM_BUILD_ROOT%{_sbindir}/
+ln -sf %{_bindir}/htpasswd $RPM_BUILD_ROOT%{_sbindir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -1263,21 +1266,20 @@ if [ "$1" = "2" ]; then
 fi
 
 %triggerpostun -- %{name} <= 1.3.31-5
-echo "WARNING!!!"
-echo "Since that version autoindex module has been separated to package %{name}-mod_autoindex"
-echo "If you want to have the same functionality do:"
-echo "poldek --upgrade %{name}-mod_autoindex"
-echo
+%banner %{name} -e -a <<EOF
+WARNING!!!
+ Since that version autoindex module has been separated to package %{name}-mod_autoindex
+ If you want to have the same functionality do:
+poldek --upgrade %{name}-mod_autoindex
+
+EOF
 
 %triggerpostun -- %{name} < 1.3.33-3.4
-echo "WARNING!!!"
-echo "Since that version following modules have been separated to subpackages"
-echo "If you want to have the same functionality do:"
-echo "poldek --upgrade %{name}-MODULENAME"
-echo
-cat <<EOF
-       mod_access
-       mod_alias
+%banner %{name} -e -a <<EOF
+WARNING!!!
+ Since that version following modules have been separated to subpackages
+ If you want to have the same functionality do:
+ poldek --upgrade %{name}-MODULENAME
        mod_asis
        mod_cern_meta
        mod_cgi
@@ -1294,7 +1296,6 @@ cat <<EOF
        mod_userdir
 EOF
 
-# XXXXXXXXXXXXXXXXXXX
 %post mod_access
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
@@ -1309,464 +1310,449 @@ if [ "$1" = "0" ]; then
        fi
 fi
 
-%post mod_alias
+%post mod_actions
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_alias
+%postun mod_actions
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_asis
+%post mod_alias
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_asis
+%postun mod_alias
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_cern_meta
+%post mod_asis
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_cern_meta
+%postun mod_asis
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_cgi
+%post mod_auth
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_cgi
+%postun mod_auth
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_env
+%post mod_auth_anon
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_env
+%postun mod_auth_anon
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_include
+%post mod_auth_db
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_include
+%postun mod_auth_db
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_log_agent
-if [ -f /var/lock/subsys/apache ]; then
-       /etc/rc.d/init.d/apache restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
-fi
+%triggerpostun mod_auth_db -- apache-mod_auth_db <= 1.3.20-2
+%{apxs} -e -A -n auth_dbm %{_libexecdir}/mod_auth_dbm.so 1>&2
 
-%postun mod_log_agent
+%post mod_auth_digest
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
+       else
+               echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
        fi
 fi
 
-%post mod_log_config
-if [ -f /var/lock/subsys/apache ]; then
-       /etc/rc.d/init.d/apache restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
-fi
-
-%postun mod_log_config
+%postun mod_auth_digest
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_log_referer
+%post mod_autoindex
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_log_referer
+%postun mod_autoindex
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_mime
+%triggerpostun mod_autoindex -- apache1-mod_autoindex < 1.3.33-1.85
+%{apxs} -e -A -n autoindex %{_libexecdir}/mod_autoindex.so 1>&2
+sed -i -e '
+       s,^Include.*mod_autoindex.conf,Include %{_sysconfdir}/conf.d/*_mod_autoindex.conf,
+' /etc/apache/apache.conf
+
+%post mod_cern_meta
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_mime
+%postun mod_cern_meta
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_mime_magic
+%post mod_cgi
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_mime_magic
+%postun mod_cgi
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_negotiation
+%post mod_define
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_negotiation
+%postun mod_define
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_setenvif
+%post mod_digest
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_setenvif
+%postun mod_digest
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_speling
+%post mod_dir
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_speling
+%postun mod_dir
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_userdir
+%post mod_env
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_userdir
+%postun mod_env
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
-# XXXXXXXXXXXXXXXXXXX
 
-%post mod_actions
+%post mod_expires
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_actions
+%postun mod_expires
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_auth
+%post mod_headers
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_auth
+%postun mod_headers
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_auth_anon
+%post mod_imap
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_auth_anon
+%postun mod_imap
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_auth_db
+%post mod_include
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_auth_db
+%postun mod_include
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%triggerpostun mod_auth_db -- apache-mod_auth_db <= 1.3.20-2
-%{apxs} -e -A -n auth_dbm %{_libexecdir}/mod_auth_dbm.so 1>&2
-
-%post mod_auth_digest
-if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/apache ]; then
-               /etc/rc.d/init.d/apache restart 1>&2
-       else
-               echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
-       fi
+%post mod_info
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_auth_digest
+%postun mod_info
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_autoindex
+%post mod_log_agent
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_autoindex
+%postun mod_log_agent
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%triggerpostun mod_autoindex -- apache1-mod_autoindex < 1.3.33-1.85
-%{apxs} -e -A -n autoindex %{_libexecdir}/mod_autoindex.so 1>&2
-sed -i -e '
-       s,^Include.*mod_autoindex.conf,Include %{_sysconfdir}/conf.d/*_mod_autoindex.conf,
-' /etc/apache/apache.conf
-
-%post mod_define
+%post mod_log_config
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_define
+%postun mod_log_config
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_digest
+%post mod_log_forensic
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_digest
+%postun mod_log_forensic
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_dir
+%post mod_log_referer
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_dir
+%postun mod_log_referer
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_expires
+%post mod_mime
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_expires
+%postun mod_mime
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_headers
+%post mod_mime_magic
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_headers
+%postun mod_mime_magic
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_imap
+%post mod_mmap_static
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_imap
+%postun mod_mmap_static
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_info
+%post mod_negotiation
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_info
+%postun mod_negotiation
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_log_forensic
+%post mod_proxy
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_log_forensic
+%postun mod_proxy
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_mmap_static
+%triggerpostun mod_proxy -- apache1-mod_proxy < 1.3.33-1.85
+%{apxs} -e -A -n proxy %{_libexecdir}/libproxy.so 1>&2
+sed -i -e '
+       s,^Include.*mod_proxy.conf,Include %{_sysconfdir}/conf.d/*_mod_proxy.conf,
+' /etc/apache/apache.conf
+
+%post mod_rewrite
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_mmap_static
+%postun mod_rewrite
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%post mod_proxy
+%post mod_setenvif
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_proxy
+%postun mod_setenvif
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%triggerpostun mod_proxy -- apache1-mod_proxy < 1.3.33-1.85
-%{apxs} -e -A -n proxy %{_libexecdir}/libproxy.so 1>&2
-sed -i -e '
-       s,^Include.*mod_proxy.conf,Include %{_sysconfdir}/conf.d/*_mod_proxy.conf,
-' /etc/apache/apache.conf
-
-%post mod_rewrite
+%post mod_speling
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 else
        echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%postun mod_rewrite
+%postun mod_speling
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
@@ -1807,6 +1793,20 @@ if [ "$1" = "0" ]; then
        fi
 fi
 
+%post mod_userdir
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
+fi
+
+%postun mod_userdir
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
+       fi
+fi
+
 %post mod_usertrack
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
@@ -1911,7 +1911,7 @@ sed -i -e '
 %files index
 %defattr(644,root,root,755)
 %config(noreplace,missingok) %{_datadir}/html/index.html
-# note: html extensions are not the same as (g)libc locale names
+# NOTE: html extensions are not the same as (g)libc locale names
 %lang(ca) %{_datadir}/html/index.html.ca
 %lang(cs) %{_datadir}/html/index.html.cz
 %lang(de) %{_datadir}/html/index.html.de
@@ -2219,12 +2219,22 @@ sed -i -e '
 %defattr(644,root,root,755)
 %{_includedir}
 
-# XXXXXXXXXXXXXXXXXX
+%files -n htpasswd-%{name}
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/htpasswd
+%{_sbindir}/htpasswd
+%{_mandir}/man1/htpasswd.1*
+
 %files mod_access
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_access.conf
 %attr(755,root,root) %{_libexecdir}/mod_access.so
 
+%files mod_actions
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_actions.conf
+%attr(755,root,root) %{_libexecdir}/mod_actions.so
+
 %files mod_alias
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_alias.conf
@@ -2235,87 +2245,11 @@ sed -i -e '
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_asis.conf
 %attr(755,root,root) %{_libexecdir}/mod_asis.so
 
-%files mod_cern_meta
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_cern_meta.conf
-%attr(755,root,root) %{_libexecdir}/mod_cern_meta.so
-
-%files mod_cgi
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_cgi.conf
-%attr(755,root,root) %{_libexecdir}/mod_cgi.so
-
-%files mod_env
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_env.conf
-%attr(755,root,root) %{_libexecdir}/mod_env.so
-
-%files mod_include
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_include.conf
-%attr(755,root,root) %{_libexecdir}/mod_include.so
-
-%files mod_log_agent
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_log_agent.conf
-%attr(755,root,root) %{_libexecdir}/mod_log_agent.so
-
-%files mod_log_config
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_log_config.conf
-%attr(755,root,root) %{_libexecdir}/mod_log_config.so
-
-%files mod_log_referer
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_log_referer.conf
-%attr(755,root,root) %{_libexecdir}/mod_log_referer.so
-
-%files mod_mime
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_mime.conf
-%attr(755,root,root) %{_libexecdir}/mod_mime.so
-
-%files mod_mime_magic
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_mime_magic.conf
-%attr(755,root,root) %{_libexecdir}/mod_mime_magic.so
-
-%files mod_negotiation
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_negotiation.conf
-%attr(755,root,root) %{_libexecdir}/mod_negotiation.so
-
-%files mod_setenvif
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_setenvif.conf
-%attr(755,root,root) %{_libexecdir}/mod_setenvif.so
-
-%files mod_speling
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_speling.conf
-%attr(755,root,root) %{_libexecdir}/mod_speling.so
-
-%files mod_userdir
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_userdir.conf
-%attr(755,root,root) %{_libexecdir}/mod_userdir.so
-# XXXXXXXXXXXXXXXXXX
-
-%files mod_actions
-%defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_actions.conf
-%attr(755,root,root) %{_libexecdir}/mod_actions.so
-
 %files mod_auth
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_auth.conf
 %attr(755,root,root) %{_libexecdir}/mod_auth.so
 
-%files -n htpasswd-%{name}
-%attr(755,root,root) %{_bindir}/htpasswd
-%{_sbindir}/htpasswd
-%{_mandir}/man1/htpasswd.1*
-
 %files mod_auth_anon
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_auth_anon.conf
@@ -2338,6 +2272,16 @@ sed -i -e '
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_autoindex.conf
 %attr(755,root,root) %{_libexecdir}/mod_autoindex.so
 
+%files mod_cern_meta
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_cern_meta.conf
+%attr(755,root,root) %{_libexecdir}/mod_cern_meta.so
+
+%files mod_cgi
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_cgi.conf
+%attr(755,root,root) %{_libexecdir}/mod_cgi.so
+
 %files mod_define
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_define.conf
@@ -2353,6 +2297,11 @@ sed -i -e '
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_dir.conf
 %attr(755,root,root) %{_libexecdir}/mod_dir.so
 
+%files mod_env
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_env.conf
+%attr(755,root,root) %{_libexecdir}/mod_env.so
+
 %files mod_expires
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_expires.conf
@@ -2368,21 +2317,56 @@ sed -i -e '
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_imap.conf
 %attr(755,root,root) %{_libexecdir}/mod_imap.so
 
+%files mod_include
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_include.conf
+%attr(755,root,root) %{_libexecdir}/mod_include.so
+
 %files mod_info
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_info.conf
 %attr(755,root,root) %{_libexecdir}/mod_info.so
 
+%files mod_log_agent
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_log_agent.conf
+%attr(755,root,root) %{_libexecdir}/mod_log_agent.so
+
+%files mod_log_config
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_log_config.conf
+%attr(755,root,root) %{_libexecdir}/mod_log_config.so
+
 %files mod_log_forensic
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_log_forensic.conf
 %attr(755,root,root) %{_libexecdir}/mod_log_forensic.so
 
+%files mod_log_referer
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_log_referer.conf
+%attr(755,root,root) %{_libexecdir}/mod_log_referer.so
+
+%files mod_mime
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_mime.conf
+%attr(755,root,root) %{_libexecdir}/mod_mime.so
+
+%files mod_mime_magic
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_mime_magic.conf
+%attr(755,root,root) %{_libexecdir}/mod_mime_magic.so
+
 %files mod_mmap_static
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_mmap_static.conf
 %attr(755,root,root) %{_libexecdir}/mod_mmap_static.so
 
+%files mod_negotiation
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_negotiation.conf
+%attr(755,root,root) %{_libexecdir}/mod_negotiation.so
+
 %files mod_proxy
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_proxy.conf
@@ -2394,6 +2378,16 @@ sed -i -e '
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_rewrite.conf
 %attr(755,root,root) %{_libexecdir}/mod_rewrite.so
 
+%files mod_setenvif
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_setenvif.conf
+%attr(755,root,root) %{_libexecdir}/mod_setenvif.so
+
+%files mod_speling
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_speling.conf
+%attr(755,root,root) %{_libexecdir}/mod_speling.so
+
 %files mod_status
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_status.conf
@@ -2404,6 +2398,11 @@ sed -i -e '
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_unique_id.conf
 %attr(755,root,root) %{_libexecdir}/mod_unique_id.so
 
+%files mod_userdir
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_userdir.conf
+%attr(755,root,root) %{_libexecdir}/mod_userdir.so
+
 %files mod_usertrack
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_usertrack.conf
This page took 0.061499 seconds and 4 git commands to generate.