]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/blobdiff - apache1-mod_auth_mysql.spec
- link mod_auth_mysql.so with libmysqlclient (module was seriously broken!)
[packages/apache1-mod_auth_mysql.git] / apache1-mod_auth_mysql.spec
index e78cc7018f6401ae6c52eb96dce11e5fb8226a5f..0e60c6a2a8fd282f8943a7fa21cf7743330e9edb 100644 (file)
@@ -1,4 +1,5 @@
 %define                mod_name        auth_mysql
+%define        apxs            /usr/sbin/apxs
 Summary:       This is the MySQL authentication module for Apache
 Summary(cs):   Základní autentizace pro WWW server Apache pomocí MySQL
 Summary(da):   Autenticering for webtjeneren Apache fra en MySQL-database
@@ -12,36 +13,21 @@ Summary(pl):        Modu
 Summary(pt_BR):        Autenticação via MySQL para o Apache
 Summary(sv):   Grundläggande autenticering för webbservern Apache med en MySQL-databas
 Name:          apache-mod_%{mod_name}
-Version:       0.11
+Version:       2.20a
 Release:       2
 License:       GPL
 Group:         Networking/Daemons
-Group(cs):     Sí»ové/Démoni
-Group(da):     Netværks/Dæmoner
-Group(de):     Netzwerkwesen/Server
-Group(es):     Red/Servidores
-Group(fr):     Réseau/Serveurs
-Group(is):     Net/Púkar
-Group(it):     Rete/Demoni
-Group(no):     Nettverks/Daemoner
-Group(pl):     Sieciowe/Serwery
-Group(pt):     Rede/Servidores
-Group(ru):     óÅÔØ/äÅÍÏÎÙ
-Group(sl):     Omre¾ni/Stre¾niki
-Group(sv):     Nätverk/Demoner
-Group(uk):     íÅÒÅÖÁ/äÅÍÏÎÉ
-Source0:       ftp://ftp.kcilink.com/pub/mod_%{mod_name}.c.gz
-Source1:       ftp://ftp.kciLink.com/pub/mysql-group-auth.txt
-Patch0:                %{name}-name.patch
+Source0:       http://web.oyvax.com/src/mod_auth_mysql-%{version}.tar.gz
+URL:           http://www.diegonet.com/support/mod_auth_mysql.shtml
 BuildRequires: mysql-devel
-BuildRequires: /usr/sbin/apxs
+BuildRequires: %{apxs}
 BuildRequires: apache(EAPI)-devel
-Prereq:                /usr/sbin/apxs
+Requires(post,preun):  %{_sbindir}/apxs
 Requires:      apache(EAPI)
 Requires:      apache-mod_auth
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 This is an authentication module for Apache that allows you to
@@ -90,12 +76,16 @@ servade av en webbserver genom att kontrollera data i en
 MySQL-databas.
 
 %prep
-%setup -q -T -c
-gzip -dc %{SOURCE0} > mod_%{mod_name}.c
-%patch -p1
+%setup -q -n mod_%{mod_name}-%{version}
 
 %build
-%{_sbindir}/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
+aclocal
+autoconf
+%configure \
+       --with-apxs=%{apxs} \
+       --with-mysql=%{_prefix}
+
+%{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -103,22 +93,20 @@ install -d $RPM_BUILD_ROOT%{_pkglibdir}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
-install %{SOURCE1} .
-
-gzip -9nf *.txt
+gzip -9nf README* USAGE
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
This page took 0.157792 seconds and 4 git commands to generate.