]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- rel 5
[packages/amarok.git] / amarok.spec
index d258fabe1337352990415194ff4b4cef6f85564b..e303f15afd8f8ebc259c11a57b33f85b74e36ff5 100644 (file)
@@ -1,8 +1,11 @@
 # TODO:
-#      * postgresql support alongside mysql
-#      * NMM audio backend support (fix build - propably some BRs)
-#      * make descriptions less useless
-#      * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
+# - postgresql support alongside mysql
+# - NMM audio backend support (fix build - propably some BRs)
+# - make descriptions less useless
+# - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
+# - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
+# - main package pulls /usr/bin/ruby
+# - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
 #
 # Conditional builds:
 %bcond_with    gstreamer       # enable gstreamer (gst10 not stable)
 %bcond_without xine            # disable xine engine
 %bcond_without xmms            # disable xmms wrapping
 %bcond_without zeroconf        # disable support for zeroconf
-%bcond_without included_sqlite # don't use included sqlite (VERY BAD IDEA)
+%bcond_without included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
 %bcond_without helix           # disable HelixPlayer engine
 %bcond_without mp3players      # disable iPod and iRiver MP3 players support
-%bcond_with    nmm             # enable NMM audio backend
+%bcond_with    nmm             # enable NMM audio backend
 %bcond_with    mysql           # enable MySQL support
 %bcond_with    pgsql           # enable PostgreSQL support
 #
 Summary:       A KDE audio player
 Summary(pl):   Odtwarzacz audio dla KDE
 Name:          amarok
-%define                _ver 1.4.1
-%define                _rel beta1
-Version:       %{_ver}
-Release:       0.%{_rel}.1
+Version:       1.4.4
+Release:       5
 License:       GPL
 Group:         X11/Applications/Multimedia
-Source0:       http://dl.sourceforge.net/amarok/%{name}-%{_ver}-%{_rel}.tar.bz2
-# Source0-md5: ee043cf6efa3f2ac7b470eb6c050c0f7
+#Source0:      http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
+Source0:       http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
+# Source0-md5: 56a9aec42088c338b81252f8e0651781
 Patch0:                %{name}-helixplayer-morearchs.patch
+Patch1:                %{name}-libnjb.patch
+Patch2:                %{name}-smp.patch
+Patch3:                %{name}-sparc.patch
+Patch4:                kde-ac260-lt.patch
+Patch5:                kde-common-PLD.patch
 URL:           http://amarok.kde.org/
 BuildRequires: SDL-devel
 BuildRequires: alsa-lib-devel
@@ -46,9 +53,11 @@ BuildRequires:       kdebase-devel
 BuildRequires: kdemultimedia-devel >= 9:3.1.93
 %{?with_mp3players:BuildRequires:      libgpod-devel >= 0.2.0}
 %{?with_mp3players:BuildRequires:      libifp-devel}
+%{?with_mp3players:BuildRequires:      libmtp-devel}
+%{?with_mp3players:BuildRequires:      libnjb-devel}
 BuildRequires: libltdl-devel
 %{?with_pgsql:BuildRequires:           libpqxx-devel}
-BuildRequires: libtunepimp-devel >= 0.4.0
+BuildRequires: libtunepimp-devel >= 0.5.1-6
 BuildRequires: libvisual-devel >= 0.4.0
 BuildRequires: mpeg4ip-devel
 %{?with_mysql:BuildRequires:           mysql-devel}
@@ -56,17 +65,22 @@ BuildRequires:      pcre-devel
 BuildRequires: pkgconfig
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.129
+BuildRequires: ruby-devel >= 1.8
 BuildRequires: sed >= 4.0
-%{!?with_included_sqlite:BuildRequires:        sqlite3-devel}
+%{!?with_included_sqlite:BuildRequires:        sqlite3-devel >= 3.3}
 BuildRequires: taglib-devel >= 1.4
 %{?with_xine:BuildRequires:    xine-lib-devel >= 1.1.1}
 %{?with_xmms:BuildRequires:    xmms-devel}
+Requires(post):        /sbin/ldconfig
 Requires:      %{name}-plugin = %{version}-%{release}
 Requires:      kdebase-core >= 9:3.1.93
 Requires:      kdemultimedia-audiocd >= 9:3.1.93
 Obsoletes:     amarok-arts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# temporary hack for proper libgpod::itdb_get_mountpoint() detection.
+%define                filterout_ld    -Wl,--as-needed
+
 %description
 A KDE audio player.
 
@@ -190,8 +204,14 @@ Wi
 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
 
 %prep
-%setup -q -n %{name}-%{_ver}-%{_rel}
+%setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p0
+%patch3 -p0
+%patch4 -p1
+%patch5 -p1
+
 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
        amarok/src/amarok.desktop \
 
@@ -203,7 +223,7 @@ Wi
        1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
        1s,#!.*bin/env.*python,#!%{_bindir}/python,
        1s,#!.*bin/env.*bash,#!/bin/bash,
-' amarok/src/scripts/*/*.{py,rb,sh}
+' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
 
 %build
 cp -f /usr/share/automake/config.sub admin
@@ -221,7 +241,10 @@ cp -f /usr/share/automake/config.sub admin
        --with%{!?with_akode:out}-akode \
        --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
        --with%{!?with_nmm:out}-nmm \
+       --with%{!?with_xmms:out}-xmms \
        --with%{!?with_mp3players:out}-libgpod \
+       --with%{!?with_mp3players:out}-libnjb \
+       --with%{!?with_mp3players:out}-libmtp \
        --with%{!?with_mp3players:out}-ifp \
        --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
        --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
@@ -248,12 +271,13 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+/sbin/ldconfig
 if [ "$1" = 1 ]; then
        echo "Remember to install libvisual-plugins-* packages if you"
        echo "want to have a visualizations in amaroK."
 fi
 
-%post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
 %files -f %{name}.lang
@@ -263,6 +287,8 @@ fi
 %attr(755,root,root) %{_bindir}/amarokapp
 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
 %attr(755,root,root) %{_bindir}/amarok_libvisual
+%attr(755,root,root) %{_bindir}/amarok_proxy.rb
+%attr(755,root,root) %{_bindir}/amarok_daapserver.rb
 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
 %{_libdir}/kde3/konqsidebar_universalamarok.la
 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
@@ -271,14 +297,28 @@ fi
 %{_libdir}/kde3/libamarok_void-engine_plugin.la
 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
 %{_libdir}/libamarok.la
+%{_libdir}/kde3/libamarok_daap-mediadevice.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
+%{_libdir}/kde3/libamarok_massstorage-device.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
+%{_libdir}/kde3/libamarok_nfs-device.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
+%{_libdir}/kde3/libamarok_smb-device.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
+%{_libdir}/ruby_lib/http11.rb
+%{_libdir}/ruby_lib/libhttp11.la
+%attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so.0.0.0
 %dir %{_datadir}/apps/amarok
 %dir %{_datadir}/apps/amarok/scripts
+%{_datadir}/apps/amarok/ruby_lib
 %{_datadir}/apps/amarok/*.rc
 %{_datadir}/apps/amarok/data
 %{_datadir}/apps/amarok/icons
 %{_datadir}/apps/amarok/images
 %{_datadir}/apps/amarok/themes
 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
+%{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
+%{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
@@ -287,17 +327,31 @@ fi
 %{_datadir}/config.kcfg/amarok.kcfg
 %{_datadir}/services/amarok_generic-mediadevice.desktop
 %{_datadir}/services/amarok_void-engine_plugin.desktop
+%{_datadir}/services/amarok_daap-mediadevice.desktop
+%{_datadir}/services/amarok_massstorage-device.desktop
+%{_datadir}/services/amarok_nfs-device.desktop
+%{_datadir}/services/amarok_smb-device.desktop
+%{_datadir}/services/amaroklastfm.protocol
+%{_datadir}/services/amarokitpc.protocol
+%{_datadir}/services/amarokpcast.protocol
+%{_datadir}/servicetypes/amarok_codecinstall.desktop
 %{_datadir}/servicetypes/amarok_plugin.desktop
 %{_desktopdir}/kde/amarok.desktop
 %{_iconsdir}/*/*/apps/amarok.*
 # TODO: move to subpackage
 %if %{with mp3players}
-%{_libdir}/kde3/libamarok_ipod-mediadevice.la
 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
-%attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
-%{_datadir}/services/amarok_ipod-mediadevice.desktop
+%{_libdir}/kde3/libamarok_ipod-mediadevice.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
+%{_libdir}/kde3/libamarok_mtp-mediadevice.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
+%{_libdir}/kde3/libamarok_njb-mediadevice.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
 %{_datadir}/services/amarok_ifp-mediadevice.desktop
+%{_datadir}/services/amarok_ipod-mediadevice.desktop
+%{_datadir}/services/amarok_mtp-mediadevice.desktop
+%{_datadir}/services/amarok_njb-mediadevice.desktop
 %endif
 
 %if %{with akode}
@@ -333,7 +387,6 @@ fi
 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
 %{_datadir}/config.kcfg/xinecfg.kcfg
 %{_datadir}/services/amarok_xine-engine.desktop
-#%{_datadir}/services/amarok_xineengine_plugin.desktop
 %endif
 
 %if %{with xmms}
@@ -396,7 +449,7 @@ fi
 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
-%attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
+%attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
 
 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
@@ -410,6 +463,17 @@ fi
 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
 
+%dir %{_datadir}/apps/amarok/scripts/score_default
+%{_datadir}/apps/amarok/scripts/score_default/COPYING
+%{_datadir}/apps/amarok/scripts/score_default/README
+%attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
+%{_datadir}/apps/amarok/scripts/score_default/score_default.spec
+%dir %{_datadir}/apps/amarok/scripts/score_impulsive
+%{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
+%{_datadir}/apps/amarok/scripts/score_impulsive/README
+%attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
+%{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
+
 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
 
@@ -418,5 +482,5 @@ fi
 %{_datadir}/apps/amarok/scripts/amarok_live/README
 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
-%attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
+%attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
 %endif
This page took 0.037051 seconds and 4 git commands to generate.