]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- rel 5
[packages/amarok.git] / amarok.spec
index 1671b76945fd499174e2963a41741d5119e55c31..e303f15afd8f8ebc259c11a57b33f85b74e36ff5 100644 (file)
@@ -1,9 +1,11 @@
 # TODO:
-#      - postgresql support alongside mysql
-#      - NMM audio backend support (fix build - propably some BRs)
-#      - make descriptions less useless
-#      - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
-#      - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
+# - postgresql support alongside mysql
+# - NMM audio backend support (fix build - propably some BRs)
+# - make descriptions less useless
+# - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
+# - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
+# - main package pulls /usr/bin/ruby
+# - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
 #
 # Conditional builds:
 %bcond_with    gstreamer       # enable gstreamer (gst10 not stable)
 Summary:       A KDE audio player
 Summary(pl):   Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       1.4.2
-Release:       0.1
+Version:       1.4.4
+Release:       5
 License:       GPL
 Group:         X11/Applications/Multimedia
 #Source0:      http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
-Source0:       http://sunsite.icm.edu.pl/pub/unix/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
-# Source0-md5: a1e5aac4294eb049021d1e2889c0d214
+Source0:       http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
+# Source0-md5: 56a9aec42088c338b81252f8e0651781
 Patch0:                %{name}-helixplayer-morearchs.patch
 Patch1:                %{name}-libnjb.patch
+Patch2:                %{name}-smp.patch
+Patch3:                %{name}-sparc.patch
+Patch4:                kde-ac260-lt.patch
+Patch5:                kde-common-PLD.patch
 URL:           http://amarok.kde.org/
 BuildRequires: SDL-devel
 BuildRequires: alsa-lib-devel
@@ -47,10 +53,11 @@ BuildRequires:      kdebase-devel
 BuildRequires: kdemultimedia-devel >= 9:3.1.93
 %{?with_mp3players:BuildRequires:      libgpod-devel >= 0.2.0}
 %{?with_mp3players:BuildRequires:      libifp-devel}
-BuildRequires: libltdl-devel
+%{?with_mp3players:BuildRequires:      libmtp-devel}
 %{?with_mp3players:BuildRequires:      libnjb-devel}
+BuildRequires: libltdl-devel
 %{?with_pgsql:BuildRequires:           libpqxx-devel}
-BuildRequires: libtunepimp-devel >= 0.4.0
+BuildRequires: libtunepimp-devel >= 0.5.1-6
 BuildRequires: libvisual-devel >= 0.4.0
 BuildRequires: mpeg4ip-devel
 %{?with_mysql:BuildRequires:           mysql-devel}
@@ -64,12 +71,16 @@ BuildRequires:      sed >= 4.0
 BuildRequires: taglib-devel >= 1.4
 %{?with_xine:BuildRequires:    xine-lib-devel >= 1.1.1}
 %{?with_xmms:BuildRequires:    xmms-devel}
+Requires(post):        /sbin/ldconfig
 Requires:      %{name}-plugin = %{version}-%{release}
 Requires:      kdebase-core >= 9:3.1.93
 Requires:      kdemultimedia-audiocd >= 9:3.1.93
 Obsoletes:     amarok-arts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# temporary hack for proper libgpod::itdb_get_mountpoint() detection.
+%define                filterout_ld    -Wl,--as-needed
+
 %description
 A KDE audio player.
 
@@ -196,6 +207,11 @@ Wi
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p0
+%patch3 -p0
+%patch4 -p1
+%patch5 -p1
+
 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
        amarok/src/amarok.desktop \
 
@@ -225,8 +241,10 @@ cp -f /usr/share/automake/config.sub admin
        --with%{!?with_akode:out}-akode \
        --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
        --with%{!?with_nmm:out}-nmm \
+       --with%{!?with_xmms:out}-xmms \
        --with%{!?with_mp3players:out}-libgpod \
        --with%{!?with_mp3players:out}-libnjb \
+       --with%{!?with_mp3players:out}-libmtp \
        --with%{!?with_mp3players:out}-ifp \
        --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
        --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
@@ -253,12 +271,13 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+/sbin/ldconfig
 if [ "$1" = 1 ]; then
        echo "Remember to install libvisual-plugins-* packages if you"
        echo "want to have a visualizations in amaroK."
 fi
 
-%post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
 %files -f %{name}.lang
@@ -268,6 +287,8 @@ fi
 %attr(755,root,root) %{_bindir}/amarokapp
 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
 %attr(755,root,root) %{_bindir}/amarok_libvisual
+%attr(755,root,root) %{_bindir}/amarok_proxy.rb
+%attr(755,root,root) %{_bindir}/amarok_daapserver.rb
 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
 %{_libdir}/kde3/konqsidebar_universalamarok.la
 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
@@ -276,14 +297,28 @@ fi
 %{_libdir}/kde3/libamarok_void-engine_plugin.la
 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
 %{_libdir}/libamarok.la
+%{_libdir}/kde3/libamarok_daap-mediadevice.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
+%{_libdir}/kde3/libamarok_massstorage-device.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
+%{_libdir}/kde3/libamarok_nfs-device.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
+%{_libdir}/kde3/libamarok_smb-device.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
+%{_libdir}/ruby_lib/http11.rb
+%{_libdir}/ruby_lib/libhttp11.la
+%attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so.0.0.0
 %dir %{_datadir}/apps/amarok
 %dir %{_datadir}/apps/amarok/scripts
+%{_datadir}/apps/amarok/ruby_lib
 %{_datadir}/apps/amarok/*.rc
 %{_datadir}/apps/amarok/data
 %{_datadir}/apps/amarok/icons
 %{_datadir}/apps/amarok/images
 %{_datadir}/apps/amarok/themes
 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
+%{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
+%{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
@@ -292,7 +327,13 @@ fi
 %{_datadir}/config.kcfg/amarok.kcfg
 %{_datadir}/services/amarok_generic-mediadevice.desktop
 %{_datadir}/services/amarok_void-engine_plugin.desktop
-#%{_datadir}/services/lastfm.protocol
+%{_datadir}/services/amarok_daap-mediadevice.desktop
+%{_datadir}/services/amarok_massstorage-device.desktop
+%{_datadir}/services/amarok_nfs-device.desktop
+%{_datadir}/services/amarok_smb-device.desktop
+%{_datadir}/services/amaroklastfm.protocol
+%{_datadir}/services/amarokitpc.protocol
+%{_datadir}/services/amarokpcast.protocol
 %{_datadir}/servicetypes/amarok_codecinstall.desktop
 %{_datadir}/servicetypes/amarok_plugin.desktop
 %{_desktopdir}/kde/amarok.desktop
@@ -303,10 +344,13 @@ fi
 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
+%{_libdir}/kde3/libamarok_mtp-mediadevice.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
 %{_libdir}/kde3/libamarok_njb-mediadevice.la
 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
 %{_datadir}/services/amarok_ifp-mediadevice.desktop
 %{_datadir}/services/amarok_ipod-mediadevice.desktop
+%{_datadir}/services/amarok_mtp-mediadevice.desktop
 %{_datadir}/services/amarok_njb-mediadevice.desktop
 %endif
 
This page took 0.029323 seconds and 4 git commands to generate.