]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- merged from DEVEL
[packages/amarok.git] / amarok.spec
index f5042c0a735b07a0fe1776195cbeb4a4562bf82d..9bc0e6bc643b89eae1b1f62531a226c5d4d90c39 100644 (file)
@@ -1,30 +1,56 @@
 #
+# TODO:
+#      * postgresql support alongside mysql
+#      * NMM audio backend support (fix build - propably some BRs)
+#      * make descriptions less useless
+#      * HelixPlayer engine (fix build - propably some BRs)
+#
 # Conditional builds:
+%bcond_without arts            # disable arts engine
 %bcond_without gstreamer       # disable gstreamer
+%bcond_without mas             # disable MAS audio backend
+%bcond_without xine            # disable xine engine
 %bcond_without xmms            # disable xmms wrapping
-#
+%bcond_without zeroconf        # disable suport for zeroconf
+%bcond_with    helix           # enable HelixPlayer engine
+%bcond_with    nmm             # enable NMM audio backend
+%bcond_with    mysql           # enable mysql support
+%bcond_with    akode           # enable aKode engine (too buggy/incomplete)
 Summary:       A KDE audio player
 Summary(pl):   Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       1.0.1
-Release:       2
+Version:       1.3
+Release:       1
 License:       GPL
 Group:         X11/Applications/Multimedia
-Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
-# Source0-md5: 3572e1bbbc76d3985af9a982f22a5da8
+Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
+# Source0-md5: 2dd100584795fb20c621fdbc96cbee1e
+Patch0:                kde-common-gcc4.patch
 URL:           http://amarok.kde.org/
-Buildrequires: alsa-lib-devel
-Buildrequires: arts-qt-devel
-Buildrequires: automake
-%{?with_gstreamer:BuildRequires:       gstreamer-devel >= 0.8.1}
+BuildRequires: SDL-devel
+BuildRequires: alsa-lib-devel
+BuildRequires: arts-qt-devel
+BuildRequires: automake
+%{?with_gstreamer:BuildRequires:       gstreamer-plugins-devel >= 0.8.1}
+BuildRequires: kdebase-devel
+%{?with_akode:BuildRequires:   kdemultimedia-akode}
 BuildRequires: kdemultimedia-devel >= 9:3.1.93
+BuildRequires: libltdl-devel
+BuildRequires: libmusicbrainz-devel
+BuildRequires: libvisual-devel >= 0.2.0
+BuildRequires: pcre-devel
 BuildRequires: rpmbuild(macros) >= 1.129
 BuildRequires: sed >= 4.0
-BuildRequires: taglib-devel >= 0.95
-BuildRequires: unsermake >= 040511
-BuildRequires: xine-lib-devel
-%{?with_xmms:Buildrequires:    xmms-devel}
+BuildRequires: sqlite3-devel
+BuildRequires: taglib-devel >= 1.4
+#BuildRequires:        unsermake >= 040511
+%{?with_xine:BuildRequires:            xine-lib-devel >= 2:1.0-0.rc5.0}
+%{?with_xmms:BuildRequires:            xmms-devel}
+%{?with_mysql:BuildRequires:           mysql-devel}
+#BuildRequires:        kdebindings-kjsembed-devel
+Requires:      %{name}-plugin = %{version}-%{release}
 Requires:      kdebase-core >= 9:3.1.93
+Requires:      kdemultimedia-audiocd >= 9:3.1.93
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -33,11 +59,53 @@ A KDE audio player.
 %description -l pl
 Odtwarzacz audio dla KDE.
 
+%package arts
+Summary:       Plugin arts
+Summary(pl):   Wtyczka arts
+Group:         X11/Applications/Multimedia
+PreReq:                %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description arts
+Plugin arts.
+
+%description arts -l pl
+Wtyczka arts.
+
+%package akode
+Summary:       Plugin akode
+Summary(pl):   Wtyczka akode
+Group:         X11/Applications/Multimedia
+PreReq:                %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description akode
+Plugin akode.
+
+%description akode -l pl
+Wtyczka akode.
+
 %package gstreamer
 Summary:       Plugin gstreamer
 Summary(pl):   Wtyczka gstreamer
 Group:         X11/Applications/Multimedia
+# deps, to get it working:
+# mp3 decoder: gstreamer-mad
+# ogg decoder: gstreamer-vorbis
+# audio output driver: gstreamer-audiosink-alsa
+# from gstreamer-audio-effects to control volume, etc
+# needed libs:
+#  at least /usr/lib/gstreamer-0.8/libgstresample.so 
+#  probably /usr/lib/gstreamer-0.8/libgstadder.so
+#  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
+# gstreamer-musicbrainz for being able to edit id3 tags on files.
+Requires:      gstreamer-audio-effects
+Requires:      gstreamer-audiosink
+Requires:      gstreamer-mad
+Requires:      gstreamer-vorbis
+Requires:      gstreamer-musicbrainz
 Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
 
 %description gstreamer
 Plugin gstreamer.
@@ -45,19 +113,60 @@ Plugin gstreamer.
 %description gstreamer -l pl
 Wtyczka gstreamer.
 
+%package xine
+Summary:       Plugin xine
+Summary(pl):   Wtyczka xine
+Group:         X11/Applications/Multimedia
+Requires:      %{name} = %{version}-%{release}
+Requires:      xine-plugin-audio
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description xine
+Plugin xine.
+
+%description xine -l pl
+Wtyczka xine.
+
+%package zeroconf
+Summary:       Zeroconf data
+Summary(pl):   Dane dla zeroconf
+Group:         X11/Applications/Multimedia
+PreReq:                %{name} = %{version}-%{release}
+Requires:      kdenetwork-kdnssd
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description zeroconf
+Zeroconf data.
+
+%description zeroconf -l pl
+Zeroconf data.
+
 %prep
-%setup -q -n %{name}-%{version}
+%setup -q
+%patch0 -p1
+%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
+       amarok/src/amarok.desktop \
 
 %build
-cp -f %{_datadir}/automake/config.sub admin
+cp -f /usr/share/automake/config.sub admin
 
-export UNSERMAKE=%{_datadir}/unsermake/unsermake
+#export UNSERMAKE=/usr/share/unsermake/unsermake
 
 %{__make} -f admin/Makefile.common cvs
 
 %configure \
        --disable-rpath \
-       --with-qt-libraries=%{_libdir}
+       %{!?with_arts:--without-arts} \
+       %{?with_mas:--with-mas} \
+       %{!?with_xine:--without-xine} \
+       %{!?with_gstreamer:--without-gstreamer} \
+       %{!?with_akode:--without-akode} \
+       %{?with_helix:--with-helix} \
+       %{?with_nmm:--with-nmm} \
+       %{?with_mysql:--with-mysql} \
+       --disable-final \
+       --with-qt-libraries=%{_libdir} \
+       --without-included-sqlite
 
 %{__make}
 
@@ -69,17 +178,46 @@ rm -rf $RPM_BUILD_ROOT
        kde_htmldir=%{_kdedocdir} \
        kde_libs_htmldir=%{_kdedocdir}
 
+# remove bogus dir
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
+
 %find_lang amarok --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+echo "Remember to install libvisual-plugins-* packages if you"
+echo "want to have a visualizations in amarok."
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README TODO
 %attr(755,root,root) %{_bindir}/amarok
-%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper}
+%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
 %attr(755,root,root) %{_bindir}/amarokapp
+%attr(755,root,root) %{_bindir}/amarok_libvisual
+#%attr(755,root,root) %{_bindir}/release_amarok
+%{_libdir}/kde3/konqsidebar_universalamarok.la
+%attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
+%{_libdir}/kde3/libamarok_void-engine_plugin.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
+%{_datadir}/apps/amarok
+%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
+%{_datadir}/apps/konqsidebartng/add/amarok.desktop
+%{_datadir}/apps/konqsidebartng/entries/amarok.desktop
+%{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
+%{_datadir}/apps/profiles/amarok.profile.xml
+%{_datadir}/config/amarokrc
+%{_datadir}/config.kcfg/amarok.kcfg
+%{_datadir}/services/amarok_void-engine_plugin.desktop
+%{_datadir}/servicetypes/amarok_plugin.desktop
+%{_desktopdir}/kde/amarok.desktop
+%{_iconsdir}/*/*/apps/amarok.*
+
+%if %{with arts}
+%files arts
+%defattr(644,root,root,755)
 %{_libdir}/kde3/libamarok_artsengine_plugin.la
 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
 %{_libdir}/libamarokarts.la
@@ -87,18 +225,38 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/mcop/Amarok
 %{_libdir}/mcop/amarokarts.mcopclass
 %{_libdir}/mcop/amarokarts.mcoptype
-%{_datadir}/apps/amarok
-%{_datadir}/config.kcfg/amarok.kcfg
 %{_datadir}/services/amarok_artsengine_plugin.desktop
-%{_datadir}/servicetypes/amarok_plugin.desktop
-%{_desktopdir}/kde/amarok.desktop
-%{_iconsdir}/[!l]*/*/apps/amarok.png
-%{_datadir}/config/*
+%endif
+
+%if %{with akode}
+%files akode
+%defattr(644,root,root,755)
+%{_libdir}/kde3/libamarok_aKode-engine.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
+%{_datadir}/services/amarok_aKode-engine.desktop
+%endif
 
 %if %{with gstreamer}
 %files gstreamer
 %defattr(644,root,root,755)
 %{_libdir}/kde3/libamarok_gstengine_plugin.la
 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
+%{_datadir}/config.kcfg/gstconfig.kcfg
 %{_datadir}/services/amarok_gstengine_plugin.desktop
 %endif
+
+%if %{with xine}
+%files xine
+%defattr(644,root,root,755)
+%{_libdir}/kde3/libamarok_xine-engine.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
+%{_datadir}/config.kcfg/xinecfg.kcfg
+%{_datadir}/services/amarok_xine-engine.desktop
+#%{_datadir}/services/amarok_xineengine_plugin.desktop
+%endif
+
+%if %{with zeroconf}
+%files zeroconf
+%defattr(644,root,root,755)
+%{_datadir}/apps/zeroconf/_shoutcast._tcp
+%endif
This page took 0.080699 seconds and 4 git commands to generate.