]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- "Player" category
[packages/amarok.git] / amarok.spec
index 0f018f7bfd0c82a583538332a22d6aaa29b9cd38..91059151eaa7c65514c3d85b13a692c9cbb907d3 100644 (file)
@@ -1,19 +1,30 @@
-
-%define                _snap   031119
-
+#
+# Conditional builds:
+%bcond_without gstreamer       # disable gstreamer
+%bcond_without xmms            # disable xmms wrapping
+#
 Summary:       A KDE audio player
 Summary(pl):   Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       0.7.0.%{_snap}
-Release:       1
+Version:       1.1.1
+Release:       0.1     
 License:       GPL
 Group:         X11/Applications/Multimedia
-# From kdenonbeta kde cvs module
-Source0:       http://www.kernel.pl/~adgor/kde/%{name}-%{_snap}.tar.bz2
-# Source0-md5: 0346b67a96d44668483eecc6bc89bac1
-BuildRequires: kdemultimedia-devel >= 9:3.1.93 
+Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
+# Source0-md5: 6c0cccd4c8b508a2e0c9b0f187a907cf
+URL:           http://amarok.kde.org/
+Buildrequires: alsa-lib-devel
+Buildrequires: arts-qt-devel
+Buildrequires: automake
+%{?with_gstreamer:BuildRequires:       gstreamer-devel >= 0.8.1}
+BuildRequires: kdemultimedia-devel >= 9:3.1.93
+BuildRequires: rpmbuild(macros) >= 1.129
 BuildRequires: sed >= 4.0
-BuildRequires: taglib-devel >= 0.95    
+BuildRequires: sqlite >= 3.0.0
+BuildRequires: taglib-devel >= 1.3
+BuildRequires: unsermake >= 040511
+BuildRequires: xine-lib-devel
+%{?with_xmms:Buildrequires:    xmms-devel}
 Requires:      kdebase-core >= 9:3.1.93
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -23,16 +34,34 @@ A KDE audio player.
 %description -l pl
 Odtwarzacz audio dla KDE.
 
+%package gstreamer
+Summary:       Plugin gstreamer
+Summary(pl):   Wtyczka gstreamer
+Group:         X11/Applications/Multimedia
+Requires:      %{name} = %{version}-%{release}
+
+%description gstreamer
+Plugin gstreamer.
+
+%description gstreamer -l pl
+Wtyczka gstreamer.
+
 %prep
-%setup -q -n %{name}-%{_snap}
+%setup -q -n %{name}-%{version}
+
+%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
+       amarok/src/amarok.desktop \
 
 %build
+cp -f %{_datadir}/automake/config.sub admin
+
+export UNSERMAKE=%{_datadir}/unsermake/unsermake
 
-%{__make} -f admin/Makefile.common cvs 
+%{__make} -f admin/Makefile.common cvs
 
 %configure \
        --disable-rpath \
-       --enable-final
+       --with-qt-libraries=%{_libdir}
 
 %{__make}
 
@@ -41,29 +70,42 @@ rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       kde_appsdir=%{_applnkdir} \
-       kde_htmldir=%{_kdedocdir}
-install -d $RPM_BUILD_ROOT%{_desktopdir}/kde
-
-mv $RPM_BUILD_ROOT{%{_applnkdir}/Multimedia/amarok.desktop,%{_desktopdir}/kde} 
+       kde_htmldir=%{_kdedocdir} \
+       kde_libs_htmldir=%{_kdedocdir}
 
-# Grrr...
-sed -i 's/Categories=Audio/Categories=AudioVideo/' \
-       $RPM_BUILD_ROOT%{_desktopdir}/kde/amarok.desktop
-
-%find_lang %{name} --with-kde
+%find_lang amarok --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
+%doc AUTHORS ChangeLog README TODO
 %attr(755,root,root) %{_bindir}/amarok
+%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
+%attr(755,root,root) %{_bindir}/amarokapp
+%attr(755,root,root) %{_bindir}/release_amarok
+%{_libdir}/kde3/libamarok_artsengine_plugin.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
 %{_libdir}/libamarokarts.la
 %attr(755,root,root) %{_libdir}/libamarokarts.so
 %{_libdir}/mcop/Amarok
 %{_libdir}/mcop/amarokarts.mcopclass
 %{_libdir}/mcop/amarokarts.mcoptype
 %{_datadir}/apps/amarok
+%{_datadir}/config.kcfg/amarok.kcfg
+%{_datadir}/config.kcfg/gstconfig.kcfg
+%{_datadir}/services/amarok_artsengine_plugin.desktop
+%{_datadir}/servicetypes/amarok_plugin.desktop
 %{_desktopdir}/kde/amarok.desktop
 %{_iconsdir}/[!l]*/*/apps/amarok.png
+%{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
+%{_datadir}/config/*
+
+%if %{with gstreamer}
+%files gstreamer
+%defattr(644,root,root,755)
+%{_libdir}/kde3/libamarok_gstengine_plugin.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
+%{_datadir}/services/amarok_gstengine_plugin.desktop
+%endif
This page took 0.027463 seconds and 4 git commands to generate.