]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- added MySql support
[packages/amarok.git] / amarok.spec
index 07dc253d0116e11669ecfef3cd0ad0875af143e2..4cdbf80dbfb4abf294a4ef5e66cabf81946f5644 100644 (file)
@@ -1,18 +1,42 @@
+#
+# Conditional builds:
+%bcond_without arts            # disable arts engine
+%bcond_without gstreamer       # disable gstreamer
+%bcond_without xine            # disable xine engine
+%bcond_without xmms            # disable xmms wrapping
+%bcond_with    mysql           # enable mysql support
+#
 
+%define                _beta   beta1
 Summary:       A KDE audio player
 Summary(pl):   Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       0.8.3
+Version:       1.2.%{_beta}
 Release:       0.1
 License:       GPL
 Group:         X11/Applications/Multimedia
-Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
-# Source0-md5: bdd9532e983ca85711e93929c008a5ba
-URL:           http://amarok.sf.net/
+Source0:       http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
+# Source0-md5: 4477bf2c90f3afe4ae343f07978e59a5
+URL:           http://amarok.kde.org/
+Buildrequires: alsa-lib-devel
+Buildrequires: arts-qt-devel
+Buildrequires: automake
+%{?with_gstreamer:BuildRequires:       gstreamer-devel >= 0.8.1}
 BuildRequires: kdemultimedia-devel >= 9:3.1.93
-BuildRequires: rpmbuild(macros) >= 1.129       
+Buildrequires: libmusicbrainz-devel
+Buildrequires: libvisual-devel >= 0.2.0
+BuildRequires: mysql-devel
+Buildrequires: pcre-devel
+BuildRequires: rpmbuild(macros) >= 1.129
 BuildRequires: sed >= 4.0
-BuildRequires: taglib-devel >= 0.95    
+BuildRequires: sqlite3-devel
+BuildRequires: taglib-devel >= 1.3
+BuildRequires: unsermake >= 040511
+%{?with_xine:BuildRequires:    xine-lib-devel >= 2:1.0-0.rc5.0}
+%{?with_xmms:BuildRequires:    xmms-devel}
+%{?with_mysql:BuildRequires:   mysql-devel}
+#BuildRequires:        kdebindings-kjsembed-devel 
+Requires:      %{name}-plugin = %{version}-%{release}
 Requires:      kdebase-core >= 9:3.1.93
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -22,13 +46,67 @@ A KDE audio player.
 %description -l pl
 Odtwarzacz audio dla KDE.
 
+%package arts
+Summary:       Plugin arts
+Summary(pl):   Wtyczka arts
+Group:         X11/Applications/Multimedia
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description arts
+Plugin arts.
+
+%description arts -l pl
+Wtyczka arts.
+
+%package gstreamer
+Summary:       Plugin gstreamer
+Summary(pl):   Wtyczka gstreamer
+Group:         X11/Applications/Multimedia
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description gstreamer
+Plugin gstreamer.
+
+%description gstreamer -l pl
+Wtyczka gstreamer.
+
+%package xine
+Summary:       Plugin xine
+Summary(pl):   Wtyczka xine
+Group:         X11/Applications/Multimedia
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description xine
+Plugin xine.
+
+%description xine -l pl
+Wtyczka xine.
+
 %prep
-%setup -q
+%setup -q -n %{name}-1.2-%{_beta}
+
+%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
+       amarok/src/amarok.desktop \
 
 %build
+cp -f %{_datadir}/automake/config.sub admin
+
+export UNSERMAKE=%{_datadir}/unsermake/unsermake
+
+%{__make} -f admin/Makefile.common cvs
+
 %configure \
        --disable-rpath \
-       --enable-final
+       %{!?with_arts:--without-arts} \
+       %{!?with_xine:--without-xine} \
+       %{!?with_gstreamer:--without-gstreamer} \
+       %{?with_gstreamer:--with-mysql} \
+       --enable-mysql \
+       --with-qt-libraries=%{_libdir} \
+       --without-included-sqlite
 
 %{__make}
 
@@ -37,29 +115,64 @@ rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       kde_appsdir=%{_applnkdir} \
-       kde_htmldir=%{_kdedocdir}
-install -d $RPM_BUILD_ROOT%{_desktopdir}/kde
+       kde_htmldir=%{_kdedocdir} \
+       kde_libs_htmldir=%{_kdedocdir}
 
-mv $RPM_BUILD_ROOT{%{_applnkdir}/Multimedia/amarok.desktop,%{_desktopdir}/kde} 
+# remove bogus dir
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
 
-# Grrr...
-sed -i 's/Categories=Audio/Categories=AudioVideo/' \
-       $RPM_BUILD_ROOT%{_desktopdir}/kde/amarok.desktop
-
-%find_lang %{name} --with-kde
+%find_lang amarok --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
+%doc AUTHORS ChangeLog README TODO
 %attr(755,root,root) %{_bindir}/amarok
+%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
+%attr(755,root,root) %{_bindir}/amarokapp
+%attr(755,root,root) %{_bindir}/amarok_libvisual
+%attr(755,root,root) %{_bindir}/release_amarok
+%{_libdir}/kde3/libamarok_void-engine_plugin.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
+%{_datadir}/apps/amarok
+%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
+%{_datadir}/config.kcfg/amarok.kcfg
+%{_datadir}/services/amarok_void-engine_plugin.desktop
+%{_datadir}/servicetypes/amarok_plugin.desktop
+%{_desktopdir}/kde/amarok.desktop
+%{_iconsdir}/*/*/apps/amarok.png
+%{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
+%{_datadir}/config/*
+
+%if %{with arts}
+%files arts
+%defattr(644,root,root,755)
+%{_libdir}/kde3/libamarok_artsengine_plugin.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
 %{_libdir}/libamarokarts.la
 %attr(755,root,root) %{_libdir}/libamarokarts.so
 %{_libdir}/mcop/Amarok
 %{_libdir}/mcop/amarokarts.mcopclass
 %{_libdir}/mcop/amarokarts.mcoptype
-%{_datadir}/apps/amarok
-%{_desktopdir}/kde/amarok.desktop
-%{_iconsdir}/[!l]*/*/apps/amarok.png
+%{_datadir}/services/amarok_artsengine_plugin.desktop
+%endif
+
+%if %{with gstreamer}
+%files gstreamer
+%defattr(644,root,root,755)
+%{_libdir}/kde3/libamarok_gstengine_plugin.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
+%{_datadir}/config.kcfg/gstconfig.kcfg
+%{_datadir}/services/amarok_gstengine_plugin.desktop
+%endif
+
+%if %{with xine}
+%files xine
+%defattr(644,root,root,755)
+%{_libdir}/kde3/libamarok_xine-engine.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
+%{_datadir}/services/amarok_xine-engine.desktop
+%{_datadir}/services/amarok_xineengine_plugin.desktop
+%endif
This page took 0.036235 seconds and 4 git commands to generate.