]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- updated TODO
[packages/amarok.git] / amarok.spec
index 34a8543908ad1c2fe3f38bf2066794fa8dbaf8d3..2996fcd0d63b01a87513ca01d0561a4d62c5b056 100644 (file)
@@ -1,37 +1,51 @@
 #
+# TODO:
+#      * postgresql support alongside mysql
+#      * NMM audio backend support (fix build - propably some BRs)
+#      * make descriptions less useless
+#      * HelixPlayer engine (fix build - propably some BRs)
+#
 # Conditional builds:
 %bcond_without arts            # disable arts engine
 %bcond_without gstreamer       # disable gstreamer
+%bcond_without  mas            # disable MAS audio backend
 %bcond_without xine            # disable xine engine
 %bcond_without xmms            # disable xmms wrapping
+%bcond_without zeroconf        # disable suport for zeroconf
+%bcond_with     helixplayer     # enable HelixPlayer engine
+%bcond_with     nmm             # enable NMM audio backend
 %bcond_with    mysql           # enable mysql support
+%bcond_with    akode           # enable aKode engine (too buggy/incomplete)
 #
-
-%define                _beta   beta3
+%define        _beta   beta3
 Summary:       A KDE audio player
 Summary(pl):   Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       1.2.%{_beta}
-Release:       0.1
+Version:       1.3
+Release:       0.%{_beta}.2
 License:       GPL
 Group:         X11/Applications/Multimedia
-Source0:       http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
-# Source0-md5: e6379b144cdec4eca0556619a03f294c
+Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
+# Source0-md5: e6587bcdd3dc9a811d40d00b89e13ceb
+Patch0:                kde-common-gcc4.patch
 URL:           http://amarok.kde.org/
-Buildrequires: alsa-lib-devel
-Buildrequires: arts-qt-devel
-Buildrequires: automake
+BuildRequires: SDL-devel
+BuildRequires: alsa-lib-devel
+BuildRequires: arts-qt-devel
+BuildRequires: automake
 %{?with_gstreamer:BuildRequires:       gstreamer-plugins-devel >= 0.8.1}
 BuildRequires: kdebase-devel
+%{?with_akode:BuildRequires:   kdemultimedia-akode}
 BuildRequires: kdemultimedia-devel >= 9:3.1.93
-Buildrequires: libmusicbrainz-devel
-Buildrequires: libvisual-devel >= 0.2.0
-Buildrequires: pcre-devel
+BuildRequires: libltdl-devel
+BuildRequires: libmusicbrainz-devel
+BuildRequires: libvisual-devel >= 0.2.0
+BuildRequires: pcre-devel
 BuildRequires: rpmbuild(macros) >= 1.129
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel
-BuildRequires: taglib-devel >= 1.3.1
-BuildRequires: unsermake >= 040511
+BuildRequires: taglib-devel >= 1.4
+#BuildRequires:        unsermake >= 040511
 %{?with_xine:BuildRequires:            xine-lib-devel >= 2:1.0-0.rc5.0}
 %{?with_xmms:BuildRequires:            xmms-devel}
 %{?with_mysql:BuildRequires:           mysql-devel}
@@ -51,7 +65,7 @@ Odtwarzacz audio dla KDE.
 Summary:       Plugin arts
 Summary(pl):   Wtyczka arts
 Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
+PreReq:                %{name} = %{version}-%{release}
 Provides:      %{name}-plugin = %{version}-%{release}
 
 %description arts
@@ -60,11 +74,29 @@ Plugin arts.
 %description arts -l pl
 Wtyczka arts.
 
+%package akode
+Summary:       Plugin akode
+Summary(pl):   Wtyczka akode
+Group:         X11/Applications/Multimedia
+PreReq:                %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description akode
+Plugin akode.
+
+%description akode -l pl
+Wtyczka akode.
+
 %package gstreamer
 Summary:       Plugin gstreamer
 Summary(pl):   Wtyczka gstreamer
 Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
+PreReq:                %{name} = %{version}-%{release}
+# needed libs
+# at least /usr/lib/gstreamer-0.8/libgstresample.so
+# probably /usr/lib/gstreamer-0.8/libgstadder.so
+# and probably /usr/lib/gstreamer-0.8/libgstvolume.so
+Requires:      gstreamer-audio-effects
 Provides:      %{name}-plugin = %{version}-%{release}
 
 %description gstreamer
@@ -77,7 +109,7 @@ Wtyczka gstreamer.
 Summary:       Plugin xine
 Summary(pl):   Wtyczka xine
 Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
+PreReq:                %{name} = %{version}-%{release}
 Provides:      %{name}-plugin = %{version}-%{release}
 
 %description xine
@@ -86,24 +118,41 @@ Plugin xine.
 %description xine -l pl
 Wtyczka xine.
 
-%prep
-%setup -q -n %{name}-1.2-%{_beta}
+%package zeroconf
+Summary:       Zeroconf data
+Summary(pl):   Dane dla zeroconf
+Group:         X11/Applications/Multimedia
+PreReq:                %{name} = %{version}-%{release}
+Requires:      kdenetwork-kdnssd
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description zeroconf
+Zeroconf data.
+
+%description zeroconf -l pl
+Zeroconf data.
 
+%prep
+%setup -q -n %{name}-%{version}-%{_beta}
+%patch0 -p1
 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
        amarok/src/amarok.desktop \
 
 %build
-cp -f %{_datadir}/automake/config.sub admin
+cp -f /usr/share/automake/config.sub admin
 
-export UNSERMAKE=%{_datadir}/unsermake/unsermake
+#export UNSERMAKE=/usr/share/unsermake/unsermake
 
 %{__make} -f admin/Makefile.common cvs
 
 %configure \
        --disable-rpath \
        %{!?with_arts:--without-arts} \
+       %{?with_mas:--with-mas} \
        %{!?with_xine:--without-xine} \
        %{!?with_gstreamer:--without-gstreamer} \
+       %{!?with_akode:--without-akode} \
+       %{?with_helix:--with-helix} \
        %{?with_mysql:--with-mysql} \
        --disable-final \
        --with-qt-libraries=%{_libdir} \
@@ -138,20 +187,23 @@ echo "want to have a visualizations in amarok."
 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
 %attr(755,root,root) %{_bindir}/amarokapp
 %attr(755,root,root) %{_bindir}/amarok_libvisual
-%attr(755,root,root) %{_bindir}/release_amarok
-%{_libdir}/kde3/libamarok_void-engine_plugin.la
+#%attr(755,root,root) %{_bindir}/release_amarok
 %{_libdir}/kde3/konqsidebar_universalamarok.la
-%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
+%{_libdir}/kde3/libamarok_void-engine_plugin.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
 %{_datadir}/apps/amarok
 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
+%{_datadir}/apps/konqsidebartng/add/amarok.desktop
+%{_datadir}/apps/konqsidebartng/entries/amarok.desktop
+%{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
+%{_datadir}/apps/profiles/amarok.profile.xml
+%{_datadir}/config/amarokrc
 %{_datadir}/config.kcfg/amarok.kcfg
 %{_datadir}/services/amarok_void-engine_plugin.desktop
 %{_datadir}/servicetypes/amarok_plugin.desktop
 %{_desktopdir}/kde/amarok.desktop
-%{_iconsdir}/*/*/apps/amarok.png
-%{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
-%{_datadir}/config/*
+%{_iconsdir}/*/*/apps/amarok.*
 
 %if %{with arts}
 %files arts
@@ -166,6 +218,14 @@ echo "want to have a visualizations in amarok."
 %{_datadir}/services/amarok_artsengine_plugin.desktop
 %endif
 
+%if %{with akode}
+%files akode
+%defattr(644,root,root,755)
+%{_libdir}/kde3/libamarok_aKode-engine.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
+%{_datadir}/services/amarok_aKode-engine.desktop
+%endif
+
 %if %{with gstreamer}
 %files gstreamer
 %defattr(644,root,root,755)
@@ -180,6 +240,13 @@ echo "want to have a visualizations in amarok."
 %defattr(644,root,root,755)
 %{_libdir}/kde3/libamarok_xine-engine.la
 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
+%{_datadir}/config.kcfg/xinecfg.kcfg
 %{_datadir}/services/amarok_xine-engine.desktop
-%{_datadir}/services/amarok_xineengine_plugin.desktop
+#%{_datadir}/services/amarok_xineengine_plugin.desktop
+%endif
+
+%if %{with zeroconf}
+%files zeroconf
+%defattr(644,root,root,755)
+%{_datadir}/apps/zeroconf/_shoutcast._tcp
 %endif
This page took 0.076068 seconds and 4 git commands to generate.