]> git.pld-linux.org Git - packages/allegro.git/blobdiff - allegro.spec
- 4.9.14
[packages/allegro.git] / allegro.spec
index b41726564ccd654b00c8c19ce059a1cbc50d6d28..d699e87789dddf93241826c10920d6eecd0788d7 100644 (file)
@@ -1,19 +1,20 @@
 #
-# TODO: Handle situations when there are no modules (most bconds turned off)
+# TODO: - Handle situations when there are no modules (most bconds turned off)
+#      - make bconds work again or remove
 #
 # Conditional build:
 %bcond_without alsa    # without ALSA modules
-%bcond_without arts    # without aRts module
-%bcond_without dga2    # without DGA2 module
-%bcond_without dbglib  # don't build debug versions of library
-%bcond_without esd     # without esound module
-%bcond_without fbcon   # without framebuffer module
-%bcond_without jack    # without JACK module
-%bcond_without proflib # don't debug profiling versions of library
-%bcond_without sse     # build without sse
+#%%bcond_without       arts    # without aRts module
+#%%bcond_without       dga2    # without DGA2 module
+#%%bcond_without       dbglib  # don't build debug versions of library
+#%%bcond_without       esd     # without esound module
+#%%bcond_without       fbcon   # without framebuffer module
+#%%bcond_without       jack    # without JACK module
+#%%bcond_without       proflib # don't debug profiling versions of library
+#%%bcond_without       sse     # build without sse
 %bcond_without static  # don't build static versions of library
-%bcond_without svga    # without svgalib module
-%bcond_without vga     # without vga module
+#%%bcond_without       svga    # without svgalib module
+#%%bcond_without       vga     # without vga module
 #
 Summary:       A game programming library
 Summary(de.UTF-8):     Eine Bibliothek zur Programmierung von Spielen
@@ -22,21 +23,20 @@ Summary(fr.UTF-8):  Une librairie de programmation de jeux
 Summary(it.UTF-8):     Una libreria per la programmazione di videogiochi
 Summary(pl.UTF-8):     Biblioteka do programowania gier
 Name:          allegro
-Version:       4.9.8
+Version:       4.9.14
 Release:       0.1
 License:       Giftware
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
-# Source0-md5: 98c4102dc5f5195576d9817d8ea00811
+# Source0-md5: 1a577fbcf4753f59049e434442c5089f
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-examples.patch
 Patch2:                %{name}-opt.patch
 Patch3:                %{name}-ldflags.patch
 Patch4:                %{name}-frame-pointer.patch
 Patch5:                %{name}-config.patch
-Patch6:                %{name}-headers.patch
 URL:           http://alleg.sourceforge.net/
-#%%{?with_alsa:BuildRequires:  alsa-lib-devel}
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
 #%%{?with_arts:BuildRequires:  artsc-devel}
 BuildRequires: cmake >= 2.6
 #%%{?with_esd:BuildRequires:   esound-devel}
@@ -47,12 +47,12 @@ BuildRequires:      cmake >= 2.6
 #BuildRequires:        sed >= 4.0
 #%%{?with_svga:BuildRequires:  svgalib-devel}
 #BuildRequires:        texinfo
-#BuildRequires:        xorg-lib-libX11-devel
-#BuildRequires:        xorg-lib-libXcursor-devel
-#BuildRequires:        xorg-lib-libXext-devel
-#BuildRequires:        xorg-lib-libXpm-devel
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXcursor-devel
+BuildRequires: xorg-lib-libXext-devel
+BuildRequires: xorg-lib-libXpm-devel
 #BuildRequires:        xorg-lib-libXxf86dga-devel
-#BuildRequires:        xorg-lib-libXxf86vm-devel
+BuildRequires: xorg-lib-libXxf86vm-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -425,7 +425,6 @@ biblioteki allegro.
 %patch3 -p1
 #%%patch4 -p1
 #%%patch5 -p1
-#%%patch6 -p1
 
 #find include/allegro5 -name '*.h' -print0 | xargs -0 %{__sed} -i -e 's@allegro5/@%{_headers_dir}/include/allegro5@'
 #%%{__sed} -i -e 's@allegro5/@../@' include/allegro5/internal/alconfig.h
@@ -434,12 +433,8 @@ biblioteki allegro.
 #TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
 #%%configure \
-#%     %{?with_static:--enable-static} \
 #%     %{?with_dbglib:--enable-dbglib} \
 #%     %{?with_proflib:--enable-proflib} \
-#%%if !%{with alsa}
-#      --disable-alsadigi \
-#      --disable-alsamidi \
 #%%endif
 #%     %{!?with_arts:--disable-artsdigi} \
 #%     %{!?with_dga2:--disable-xwin-dga2} \
@@ -459,7 +454,10 @@ biblioteki allegro.
 #%%endif
 mkdir Build
 cd Build
-%cmake ..
+%cmake .. \
+       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
+       %{?with_static:-DSHARED="off"} \
+       %{!?with_alsa:-DWANT_ALSA="off"}
 
 %{__make}
 #%%{__make} \
@@ -497,17 +495,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-#%%doc AUTHORS CHANGES THANKS readme.txt
+%doc CHANGES-4.9.txt docs/html/refman readme_a5.txt
 #%%attr(755,root,root) %{_libdir}/liballeg-%{version}.so
 #%%dir %{_libdir}/allegro
 #%%dir %{_libdir}/allegro/%{version}
 #%%{_libdir}/allegro/%{version}/modules.lst
 
-#%%files devel
-#%%defattr(644,root,root,755)
-#%%attr(755,root,root) %{_bindir}/allegro-config
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/allegro5-config
 #%%{_libdir}/liballeg_unsharable.a
-#%%{_includedir}/*
+%{_includedir}/*
 #%%{_aclocaldir}/allegro.m4
 #%%{_mandir}/man3/*
 #%%{_infodir}/*.info*
This page took 0.033022 seconds and 4 git commands to generate.