]> git.pld-linux.org Git - packages/SDL.git/blobdiff - SDL.spec
- added conditional svgalib and aalib support (ggi doesn't work yet)
[packages/SDL.git] / SDL.spec
index 6c15483468e056bc9ab16f159ccb83df0227e214..644d43066e3c8d6a0758d23bb82374fd6c0954fd 100644 (file)
--- a/SDL.spec
+++ b/SDL.spec
+#
+# Conditional build:
+# bcond_off_alsa - without ALSA support
+# bcond_on_svgalib - with svgalib support
+# bcond_on_aalib - with aalib support
+#
 Summary:       SDL (Simple DirectMedia Layer) - Game/Multimedia Library
 Name:          SDL
-Version:       1.0.2
+Version:       1.1.7
 Release:       1
+License:       LGPL
 Group:         X11/Libraries
-Copyright:     LGPL
-Source:                http://www.devolution.com/~slouken/SDL/release/%{name}-%{version}.tar.gz
-URL:           http://www.devolution.com/~slouken/SDL/
-BuildRequires: XFree86-devel
+Group(de):     X11/Libraries
+Group(pl):     X11/Biblioteki
+Source0:       http://www.libsdl.org/release/%{name}-%{version}.tar.gz
+Patch0:                SDL-svga.patch
+URL:           http://www.libsdl.org/
+%ifnarch sparc sparc64
+%{!?bcond_off_alsa:BuildRequires:      alsa-lib-devel}
+%endif
 BuildRequires: esound-devel
 BuildRequires: gtk+-devel >= 1.2.1
-BuildRoot:     /tmp/%{name}-%{version}-root
+BuildRequires: XFree86-devel
+BuildRequires: OpenGL-devel
+%{?bcond_on_svgalib:BuildRequires:     svgalib-devel}
+%{?bcond_on_aalib:BuildRequires:       aalib-devel}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _prefix         /usr/X11R6
+%define                _mandir         %{_prefix}/man
 
 %description
-SDL (Simple DirectMedia Layer) is a library that allows you portable, low
-level access to a video framebuffer, audio output, mouse, and keyboard. It
-can support both windowed and DGA modes of XFree86, and it is designed to be
-portable - applications linked with SDL can also be built on Win32 and BeOS.
+SDL (Simple DirectMedia Layer) is a library that allows you portable,
+low level access to a video framebuffer, audio output, mouse, and
+keyboard. It can support both windowed and DGA modes of XFree86, and
+it is designed to be portable - applications linked with SDL can also
+be built on Win32 and BeOS.
+
+%description -l pl
+SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
+przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
+myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
+jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
+konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
 
 %package devel
 Summary:       SDL - Header files
+Summary(pl):   SDL - Pliki nag³ówkowe
 Group:         X11/Libraries
+Group(de):     X11/Libraries
+Group(pl):     X11/Biblioteki
 Requires:      %{name} = %{version}
 
 %description devel
 SDL - Header files.
 
+%description -l pl devel
+SDL - Pliki nag³ówkowe.
+
 %package static
 Summary:       SDL - static libraries
+Summary(pl):   SDL - biblioteki statyczne
 Group:         X11/Libraries
+Group(de):     X11/Libraries
+Group(pl):     X11/Biblioteki
 Requires:      %{name} = %{version}
 
 %description static
 SDL - static libraries.
 
+%description -l pl static
+SDL - biblioteki statyczne.
+
 %prep
 %setup -q
+%patch -p1
+
 %build
-LDFLAGS="-s"; export LDFLAGS
 %configure \
+%ifnarch sparc sparc64
+       %{!?bcond_off_alsa:--enable-alsa} \
+%endif
        --enable-nasm \
        --enable-pthreads \
        --with-x \
        --enable-video-x11-dga \
        --enable-video-x11-mtrr \
+       --enable-video-x11-dgamouse \
        --enable-esd \
-       --disable-video-svga
+       %{?bcond_on_svga:--enable-video-svga} \
+       %{?bcond_on_aalib:--enable-video-aalib}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make install DESTDIR=$RPM_BUILD_ROOT
-
-strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       m4datadir=%{_aclocaldir}
 
 gzip -9nf BUGS README WhatsNew
 
@@ -73,7 +117,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/lib*.la
 %{_libdir}/libSDLmain.a
 %{_includedir}/SDL
-%{_datadir}/aclocal/*
+%{_aclocaldir}/*
+%{_mandir}/man3/*
 
 %files static
-%attr(644,root,root) %{_libdir}/lib*.a
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
This page took 0.037499 seconds and 4 git commands to generate.