]> git.pld-linux.org Git - packages/SDL.git/blobdiff - SDL.spec
- added conditional svgalib and aalib support (ggi doesn't work yet)
[packages/SDL.git] / SDL.spec
index 0f204787a71aedec7d5fbf83b56667a3d26bd543..644d43066e3c8d6a0758d23bb82374fd6c0954fd 100644 (file)
--- a/SDL.spec
+++ b/SDL.spec
+#
+# Conditional build:
+# bcond_off_alsa - without ALSA support
+# bcond_on_svgalib - with svgalib support
+# bcond_on_aalib - with aalib support
+#
 Summary:       SDL (Simple DirectMedia Layer) - Game/Multimedia Library
 Name:          SDL
-Version:       0.9.9
+Version:       1.1.7
 Release:       1
+License:       LGPL
 Group:         X11/Libraries
-Copyright:     LGPL
-Source:                http://www.devolution.com/~slouken/projects/SDL/SDL-0.9/src/%{name}-%{version}.tar.gz
-URL:           http://www.devolution.com/~slouken/projects/SDL
-BuildRoot:     /tmp/%{name}-%{version}-root
+Group(de):     X11/Libraries
+Group(pl):     X11/Biblioteki
+Source0:       http://www.libsdl.org/release/%{name}-%{version}.tar.gz
+Patch0:                SDL-svga.patch
+URL:           http://www.libsdl.org/
+%ifnarch sparc sparc64
+%{!?bcond_off_alsa:BuildRequires:      alsa-lib-devel}
+%endif
+BuildRequires: esound-devel
+BuildRequires: gtk+-devel >= 1.2.1
+BuildRequires: XFree86-devel
+BuildRequires: OpenGL-devel
+%{?bcond_on_svgalib:BuildRequires:     svgalib-devel}
+%{?bcond_on_aalib:BuildRequires:       aalib-devel}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _prefix         /usr/X11R6
+%define                _mandir         %{_prefix}/man
 
 %description
-SDL (Simple DirectMedia Layer) is a library that allows you portable, low
-level access to a video framebuffer, audio output, mouse, and keyboard. It
-can support both windowed and DGA modes of XFree86, and it is designed to be
-portable - applications linked with SDL can also be built on Win32 and BeOS.
+SDL (Simple DirectMedia Layer) is a library that allows you portable,
+low level access to a video framebuffer, audio output, mouse, and
+keyboard. It can support both windowed and DGA modes of XFree86, and
+it is designed to be portable - applications linked with SDL can also
+be built on Win32 and BeOS.
+
+%description -l pl
+SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
+przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
+myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
+jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
+konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
 
 %package devel
-Group:         X11/Libraries
 Summary:       SDL - Header files
+Summary(pl):   SDL - Pliki nag³ówkowe
+Group:         X11/Libraries
+Group(de):     X11/Libraries
+Group(pl):     X11/Biblioteki
+Requires:      %{name} = %{version}
 
 %description devel
 SDL - Header files.
 
+%description -l pl devel
+SDL - Pliki nag³ówkowe.
+
 %package static
-Group:         X11/Libraries
 Summary:       SDL - static libraries
+Summary(pl):   SDL - biblioteki statyczne
+Group:         X11/Libraries
+Group(de):     X11/Libraries
+Group(pl):     X11/Biblioteki
+Requires:      %{name} = %{version}
 
 %description static
 SDL - static libraries.
 
-%package extras
-Group:         X11/Utilities
-Summary:       SDL - Test programs and demos
-
-%description extras
-SDL - Test programs and demos
+%description -l pl static
+SDL - biblioteki statyczne.
 
 %prep
 %setup -q
-%build
-make config <<EOF
+%patch -p1
 
-EOF
-
-make DEBUG="$RPM_OPT_FLAGS"
-cd test
-make
-cd ..
-cd SDL-demos
-for i in PTC aliens draw fire flxplay maclib mixer plasma scrap screenlib stars ttflib warp xflame; do (cd $i;make SDL=../../);done;
-cd ..
+%build
+%configure \
+%ifnarch sparc sparc64
+       %{!?bcond_off_alsa:--enable-alsa} \
+%endif
+       --enable-nasm \
+       --enable-pthreads \
+       --with-x \
+       --enable-video-x11-dga \
+       --enable-video-x11-mtrr \
+       --enable-video-x11-dgamouse \
+       --enable-esd \
+       %{?bcond_on_svga:--enable-video-svga} \
+       %{?bcond_on_aalib:--enable-video-aalib}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/usr/bin/SDL
-mkdir -p $RPM_BUILD_ROOT%{_libdir}
-mkdir -p $RPM_BUILD_ROOT/usr/include/SDL
-cp -a lib/* $RPM_BUILD_ROOT%{_libdir}
-cp -a include/* $RPM_BUILD_ROOT/usr/include/SDL
-for i in checkkeys graywin loopwave pixelformat testalpha testbitmap testhread testkeys testlock testtimer testtypes testver testwin testwm; do cp -a test/$i $RPM_BUILD_ROOT/usr/bin/SDL; done;
-for i in PTC aliens draw fire flxplay maclib mixer netlib plasma scrap screenlib stars ttflib warp xflame; do cp -a SDL-demos/$i $RPM_BUILD_ROOT/usr/bin/sdl; done;
-find $RPM_BUILD_ROOT/usr/bin/SDL -name "*.[hco]" | xargs rm -f
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       m4datadir=%{_aclocaldir}
+
+gzip -9nf BUGS README WhatsNew
 
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
@@ -69,17 +107,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc BUGS COPYING INSTALL README TODO WhatsNew docs docs.html
-%{_libdir}/libSDLx11.so.*.*
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-/usr/include/SDL
+%doc *gz docs.html docs
+%attr(755,root,root) %{_bindir}/sdl-config
+%attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/lib*.la
+%{_libdir}/libSDLmain.a
+%{_includedir}/SDL
+%{_aclocaldir}/*
+%{_mandir}/man3/*
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
-
-%files extras
-%defattr(644,root,root,755)
-/usr/bin/SDL
This page took 0.097782 seconds and 4 git commands to generate.