]> git.pld-linux.org Git - packages/PackageKit.git/blobdiff - PackageKit.spec
- ensure helpers dir exists
[packages/PackageKit.git] / PackageKit.spec
index f4ab5791a12c23e660fe0e269bbb23ff327a391e..29a683239df7db5a92c21ceeb536125305e60244 100644 (file)
 # Conditional build:
 %bcond_without doc             # build without docs
 %bcond_without introspection   # gobject introspection, time to time broken
+%bcond_without static_libs     # static library
+%bcond_without python          # Python binding (used by entropy and portage backends)
+%bcond_without vala            # Vala binding
+# backends
 %bcond_with    alpm            # ALPM (Arch Linux package manager) backend
 %bcond_with    apt             # APT (Debian/Ubuntu) backend using C++ API
+%bcond_with    dnf             # DNF (Fedora/RHEL) backend
 %bcond_with    entropy         # Entropy (Sabayon) backend (Python)
-%bcond_with    hif             # HIF (Fedora/RHEL) backend
-%bcond_with    katja           # Katja (Slackware) backend
-%bcond_with    pisi            # PiSi (Pardus) backend (Python)
+%bcond_with    nix             # Nix (NixOS) backend [broken as of 1.2.0]
 %bcond_without poldek          # Poldek (PLD) backend
 %bcond_with    portage         # portage (Gentoo) backend (Python)
-%bcond_with    ports           # ports (FreeBSD) backend (Ruby)
-%bcond_with    urpmi           # urpmi (Mandriva/Mageia) backend (Perl)
-%bcond_with    zypp            # ZYPP (openSUSE/SLE) backend
-%bcond_without python          # Python binding (only for a few backends)
-%bcond_without vala            # Vala binding
-%bcond_with    browser         # browser plugin (patrys says: it's flawed by concept)
-# python binding is built when building any python binding
-%if %{without entropy} && %{without pisi} && %{without ports}
-%undefine      with_python
+%bcond_with    slack           # Slack (Slackware) backend
+%bcond_with    zypp            # ZYPP (openSUSE/SLE) backend [broken as of 1.2.0]
+
+%if %{without python}
+%undefine      with_entropy
+%undefine      with_portage
 %endif
+
 Summary:       System daemon that is a D-Bus abstraction layer for package management
 Summary(pl.UTF-8):     Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
 Name:          PackageKit
-Version:       1.0.9
+Version:       1.2.0
 Release:       1
 License:       GPL v2+
 Group:         Applications/System
-Source0:       http://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
-# Source0-md5: a54db27ae808fe728142c42093781f14
+Source0:       https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
+# Source0-md5: a37ba4a460ab15ac4374bfc0e792d377
 Patch0:                %{name}-poldek.patch
 Patch1:                %{name}-bashcomp.patch
-Patch2:                %{name}-format.patch
+Patch2:                %{name}-meson.patch
 Patch3:                consolekit-fallback.patch
-URL:           http://www.packagekit.org/
+URL:           https://www.freedesktop.org/software/PackageKit/
+%{?with_apt:BuildRequires:     AppStream-devel >= 0.11}
 BuildRequires: NetworkManager-devel >= 0.6.5
-# pkgconfig(libalpm) >= 8.2.0
-%{?with_alpm:BuildRequires:    alpm-devel >= 4}
-%{?with_hif:BuildRequires:     appstream-glib-devel}
-%{?with_apt:BuildRequires:     apt-devel >= 0.7}
-BuildRequires: autoconf >= 2.65
-BuildRequires: automake >= 1:1.11
+# pkgconfig(libalpm) >= 12.0.0
+%{?with_alpm:BuildRequires:    alpm-devel >= 5.2}
+%{?with_dnf:BuildRequires:     appstream-glib-devel}
+%{?with_apt:BuildRequires:     apt-devel >= 1.7}
 BuildRequires: connman-devel
-%{?with_katja:BuildRequires:   curl-devel}
+%{?with_slack:BuildRequires:   curl-devel}
 BuildRequires: dbus-devel >= 1.2.0
 BuildRequires: dbus-glib-devel >= 0.76
 BuildRequires: docbook-dtd412-xml
 BuildRequires: docbook-dtd42-xml
 BuildRequires: fontconfig-devel
 BuildRequires: gettext-tools
-BuildRequires: glib2-devel >= 1:2.32.0
+BuildRequires: glib2-devel >= 1:2.54.0
 %{?with_introspection:BuildRequires:   gobject-introspection-devel >= 0.9.9}
 BuildRequires: gstreamer-devel >= 1.0.0
 BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
-BuildRequires: gtk+2-devel >= 2:2.14.0
 BuildRequires: gtk+3-devel >= 3.0.0
 %{?with_doc:BuildRequires:     gtk-doc >= 1.11}
-BuildRequires: intltool >= 0.35.0
 BuildRequires: libarchive-devel
-%{?with_hif:BuildRequires:     libhif-devel >= 0.1.7}
-BuildRequires: libtool
+%{?with_dnf:BuildRequires:     libdnf-devel >= 0.43.1}
+%if %{with apt} || %{with nix}
+BuildRequires: libstdc++-devel >= 6:4.7
+%endif
+%{?with_slack:BuildRequires:   libstdc++-devel >= 6:5}
 BuildRequires: libxslt-progs
-%{?with_zypp:BuildRequires:    libzypp-devel >= 6.16.0}
+%{?with_zypp:BuildRequires:    libzypp-devel >= 15}
+BuildRequires: meson >= 0.47.0
+BuildRequires: ninja >= 1.5
+# nix-expr nix-main nix-store
+%{?with_nix:BuildRequires:     nix-devel >= 1.12}
 BuildRequires: pango-devel
 BuildRequires: pkgconfig
+# when released; just to detect which reboot modes to use (library not linked)
+#BuildRequires:        plymouth-devel >= 0.9.5
 %{?with_poldek:BuildRequires:  poldek-devel >= 0.30-1.rc6.4}
-BuildRequires: polkit-devel >= 0.98
+BuildRequires: polkit-devel >= 0.114
+# or 1:3.2
 %{?with_python:BuildRequires:  python-devel >= 1:2.7}
 BuildRequires: readline-devel
+%{?with_dnf:BuildRequires:     rpm-devel >= 4.?}
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.311
+BuildRequires: rpmbuild(macros) >= 1.736
+BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel >= 3
-BuildRequires: systemd-devel >= 1:209
+BuildRequires: systemd-devel >= 1:213
 BuildRequires: tar >= 1:1.22
 BuildRequires: udev-glib-devel
 %{?with_vala:BuildRequires:    vala >= 2:0.16}
 BuildRequires: xz
-%if %{with browser}
-BuildRequires: cairo-devel
-BuildRequires: nspr-devel >= 4.8
-BuildRequires: pango-devel
-BuildRequires: xulrunner-devel >= 8.0
-%endif
 Requires(post,postun): shared-mime-info
 Requires:      %{name}-backend
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      crondaemon
-Requires:      polkit >= 0.98
+Requires:      polkit >= 0.114
 Suggests:      ConsoleKit-x11
+Obsoletes:     PackageKit-backend-pisi
+Obsoletes:     PackageKit-backend-ports
 Obsoletes:     PackageKit-backend-smart
+Obsoletes:     PackageKit-backend-urpmi
 Obsoletes:     PackageKit-backend-yum
 Obsoletes:     PackageKit-docs < 0.8.4
 Obsoletes:     pm-utils-packagekit
@@ -111,7 +118,8 @@ zgodnego z wieloma dystrybucjami i architekturami.
 Summary:       packagekit-glib library
 Summary(pl.UTF-8):     Biblioteka packagekit-glib
 Group:         Libraries
-Requires:      glib2 >= 1:2.32.0
+Requires:      glib2 >= 1:2.54.0
+Obsoletes:     browser-plugin-packagekit < 1.1.0
 
 %description libs
 packagekit-glib library.
@@ -125,7 +133,7 @@ Summary(pl.UTF-8):  Pliki nagłówkowe biblioteki packagekit-glib
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      dbus-devel >= 1.2.0
-Requires:      glib2-devel >= 1:2.32.0
+Requires:      glib2-devel >= 1:2.54.0
 Requires:      sqlite3-devel
 
 %description devel
@@ -152,6 +160,9 @@ Summary(pl.UTF-8):  API języka Vala do biblioteki PackageKitu
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      vala >= 2:0.16
+%if "%{_rpmversion}" >= "4.6"
+BuildArch:     noarch
+%endif
 
 %description -n vala-packagekit
 Vala API for PackageKit library.
@@ -164,7 +175,7 @@ Summary:    PackageKit library API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki PackageKit
 Group:         Documentation
 Requires:      gtk-doc-common
-%if "%{_rpmversion}" >= "5"
+%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
 %endif
 
@@ -194,6 +205,7 @@ Summary:    PackageKit APTcc backend
 Summary(pl.UTF-8):     Backend PackageKit APTcc
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      AppStream >= 0.11
 Provides:      %{name}-backend = %{version}-%{release}
 
 %description backend-aptcc
@@ -203,6 +215,23 @@ A backend for PackageKit to enable APT support via C++ API.
 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
 C++.
 
+%package backend-dnf
+Summary:       PackageKit dnf backend
+Summary(pl.UTF-8):     Backend PackageKit oparty na bibliotece dnfhif
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-backend = %{version}-%{release}
+Obsoletes:     PackageKit-backend-hawkey
+Obsoletes:     PackageKit-backend-hif
+
+%description backend-dnf
+A backend for PackageKit to enable RPM packages support via dnf
+library (used in Fedora).
+
+%description backend-dnf -l pl.UTF-8
+Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
+dnf (używaną w dystrybucji Fedora).
+
 %package backend-entropy
 Summary:       PackageKit Entropy backend
 Summary(pl.UTF-8):     Backend PackageKit Entropy
@@ -220,53 +249,20 @@ Entropy package manager.
 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
 użyciu zarządcy pakietów Entropy.
 
-%package backend-hif
-Summary:       PackageKit hif backend
-Summary(pl.UTF-8):     Backend PackageKit oparty na bibliotece hif
+%package backend-nix
+Summary:       PackageKit Nix backend
+Summary(pl.UTF-8):     Backend PackageKit oparty na zarządcy pakietów Nix
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      libhif >= 0.1.7
+Requires:      nix >= 1.12
 Provides:      %{name}-backend = %{version}-%{release}
-Obsoletes:     PackageKit-backend-hawkey
 
-%description backend-hif
-A backend for PackageKit to enable RPM packages support via hif
-library (used in Fedora).
+%description backend-nix
+A backend for PackageKit to enable Nix packages support (used in
+NixOS).
 
-%description backend-hif -l pl.UTF-8
-Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
-hif (używaną w dystrybucji Fedora).
-
-%package backend-katja
-Summary:       PackageKit Katja backend
-Summary(pl.UTF-8):     Backend PackageKit Katja
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-Provides:      %{name}-backend = %{version}-%{release}
-
-%description backend-katja
-Katja backend for PackageKit to enable Slackware repositories support.
-
-%description backend-katja -l pl.UTF-8
-Backend PackageKit Katja dodający obsługę repozytoriów Slackware.
-
-%package backend-pisi
-Summary:       PackageKit PiSi backend
-Summary(pl.UTF-8):     Backend PackageKit PiSi
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      python-packagekit = %{version}-%{release}
-#Requires:     python-piksemel
-#Requires:     python-pisi
-Provides:      %{name}-backend = %{version}-%{release}
-
-%description backend-pisi
-A backend for PackageKit to enable PiSi packages support. PiSi
-packages are originated in Pardus distribution.
-
-%description backend-pisi -l pl.UTF-8
-Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
-wywodzą się z dystrybucji Pardus.
+%description backend-nix -l pl.UTF-8
+Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
 
 %package backend-poldek
 Summary:       PackageKit Poldek backend
@@ -300,42 +296,26 @@ A backend for PackageKit to enable Gentoo Portage support.
 Backend PackageKit dodający obsługę systemu Portage dystrybucji
 Gentoo.
 
-%package backend-ports
-Summary:       PackageKit Ports backend
-Summary(pl.UTF-8):     Backend PackageKit Ports
+%package backend-slack
+Summary:       PackageKit Slack backend
+Summary(pl.UTF-8):     Backend PackageKit Slack
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
-#Requires:     ruby-pkgtools
 Provides:      %{name}-backend = %{version}-%{release}
+Obsoletes:     PackageKit-backend-katja
 
-%description backend-ports
-A backend for PackageKit to enable FreeBSD Ports support.
+%description backend-slack
+Slack backend for PackageKit to enable Slackware repositories support.
 
-%description backend-ports -l pl.UTF-8
-Backend PackageKit dodający obsługę portów systemu FreeBSD.
-
-%package backend-urpmi
-Summary:       PackageKit URPMI backend
-Summary(pl.UTF-8):     Backend PackageKit URPMI
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-#Requires:     perl-URPM
-Provides:      %{name}-backend = %{version}-%{release}
-
-%description backend-urpmi
-A backend for PackageKit to enable RPM packages support through URPMI
-package manager (originated in Mandriva).
-
-%description backend-urpmi -l pl.UTF-8
-Backend PackageKit dodający obsługę pakietów RPM poprzez zarządcę
-URPMI (pochodzącego z dystrybucji Mandriva).
+%description backend-slack -l pl.UTF-8
+Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
 
 %package backend-zypp
 Summary:       PackageKit Zypp backend
 Summary(pl.UTF-8):     Backend PackageKit Zypp
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      libzypp >= 6.16.0
+Requires:      libzypp >= 15
 Provides:      %{name}-backend = %{version}-%{release}
 
 %description backend-zypp
@@ -351,7 +331,7 @@ Summary:    GStreamer codecs installer
 Summary(pl.UTF-8):     Instalator kodeków GStreamera
 Group:         Applications
 Requires:      %{name} = %{version}-%{release}
-Requires:      %{name}-gtk-module = %{version}-%{release}
+Requires:      %{name}-gtk3-module = %{version}-%{release}
 
 %description gstreamer-plugin
 The PackageKit GStreamer plugin allows any GStreamer application to
@@ -361,23 +341,11 @@ install codecs from configured repositories using PackageKit.
 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
 
-%package gtk-module
-Summary:       GTK+ module to detect and install missing fonts
-Summary(pl.UTF-8):     Moduł GTK+ do wykrywania i instalowania brakujących czcionek
-Group:         X11/Libraries
-
-%description gtk-module
-The PackageKit GTK+ module allows any pango application to install
-missing fonts from configured repositories using PackageKit.
-
-%description gtk-module -l pl.UTF-8
-Moduł GTK+ pozwala każdej aplikacji używającej pango zainstalować
-brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
-
 %package gtk3-module
 Summary:       GTK+ 3.x module to detect and install missing fonts
 Summary(pl.UTF-8):     Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
 Group:         X11/Libraries
+Obsoletes:     PackageKit-gtk-module < 1.2.0
 
 %description gtk3-module
 The PackageKit GTK+ 3.x module allows any pango application to install
@@ -393,7 +361,7 @@ Summary(pl.UTF-8):  Bashowe uzupełnianie parametrów dla poleceń konsolowych Pa
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion >= 2
-%if "%{_rpmversion}" >= "5"
+%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
 %endif
 
@@ -417,20 +385,6 @@ PackageKit Python bindings.
 %description -n python-packagekit -l pl.UTF-8
 Wiązania PackageKit dla Pythona.
 
-%package -n browser-plugin-packagekit
-Summary:       PackageKit's browser plugin
-Summary(pl.UTF-8):     Wtyczka PackageKit do przeglądarek WWW
-Group:         X11/Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      browser-plugins >= 2.0
-Requires:      browser-plugins(%{_target_base_arch})
-
-%description -n browser-plugin-packagekit
-PackageKit's plugin for browsers.
-
-%description -n browser-plugin-packagekit -l pl.UTF-8
-Wtyczka PackageKit do przeglądarek WWW.
-
 %prep
 %setup -q
 %patch0 -p1
@@ -438,68 +392,54 @@ Wtyczka PackageKit do przeglądarek WWW.
 %patch2 -p1
 %patch3 -p1
 
-%build
-%if %{with doc}
-%{__gtkdocize}
+%if %{with static_libs}
+%{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
 %endif
-%{__intltoolize}
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
+
+%build
 %{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
-%configure \
-       --disable-command-not-found \
-       --disable-dummy \
-       %{!?with_doc:--disable-gtk-doc} \
-       %{!?with_introspection:--disable-introspection} \
-       --disable-silent-rules \
-       --enable-bash-completion=%{bash_compdir} \
-       %{__enable_disable alpm} \
-       %{__enable_disable apt aptcc} \
-       %{__enable_disable browser browser-plugin} \
-       %{__enable_disable entropy} \
-       %{__enable_disable hif} \
-       %{__enable_disable katja} \
-       %{__enable_disable pisi} \
-       %{__enable_disable poldek} \
-       %{__enable_disable portage} \
-       %{__enable_disable ports} \
-       %{__enable_disable urpmi} \
-       %{__enable_disable zypp} \
-       --with-html-dir=%{_gtkdocdir} \
-       --with-mozilla-plugin-dir=%{_browserpluginsdir} \
-       --with-security-framework=polkit
-%{__make}
+%meson build \
+       -Dbash_command_not_found=false \
+       -Dbash_completion_dir=%{bash_compdir} \
+       %{!?with_introspection:-Dgobject_introspection=false} \
+       %{?with_doc:-Dgtk_doc=true} \
+       -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
+       %{!?with_python:-Dpython_backend=false} \
+       -Dpythonpackagedir=%{py_sitescriptdir} \
+       -Dsystemdsystemunitdir=%{systemdunitdir}
+
+# TODO:
+# -Ddnf_vendor=
+# -Dpackagekit_user=
+
+%ninja_build -C build
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-# use pk-gstreamer-install as codec installer
-ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
+%ninja_install -C build
 
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-{2,3}.0/modules/*.{la,a}
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/*.{la,a}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
 
-%if %{with browser}
-%{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/*.{la,a}
+%if %{without apt} && %{without entropy} && %{without portage}
+# common dir not created if no users built with PackageKit
+install -d $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers
 %endif
 
-# empty version of bg
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/bg_BG
-# empty version of fa (empty as well BTW)
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/fa_IR
-# outdated copy of it
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/it_IT
+# use pk-gstreamer-install as codec installer
+ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
+
+install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
+ln -sf ../packagekit-offline-update.service \
+        $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
+
+%if %{with python}
+%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
 
 %py_postclean
+%endif
 
 %find_lang %{name}
 
@@ -515,14 +455,6 @@ rm -rf $RPM_BUILD_ROOT
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%post -n browser-plugin-packagekit
-%update_browser_plugins
-
-%postun -n browser-plugin-packagekit
-if [ "$1" = 0 ]; then
-       %update_browser_plugins
-fi
-
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS HACKING MAINTAINERS NEWS README
@@ -533,6 +465,7 @@ fi
 %attr(755,root,root) %{_libexecdir}/packagekitd
 %attr(755,root,root) %{_libexecdir}/pk-offline-update
 %dir %{_libdir}/packagekit-backend
+%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
 %dir %{_sysconfdir}/PackageKit
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
@@ -548,7 +481,6 @@ fi
 %{_mandir}/man1/pkmon.1*
 %{systemdunitdir}/packagekit.service
 %{systemdunitdir}/packagekit-offline-update.service
-%dir %{systemdunitdir}/system-update.target.wants
 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
 %dir /var/cache/PackageKit
 %dir /var/cache/PackageKit/downloads
@@ -581,6 +513,7 @@ fi
 %if %{with vala}
 %files -n vala-packagekit
 %defattr(644,root,root,755)
+%{_datadir}/vala/vapi/packagekit-glib2.deps
 %{_datadir}/vala/vapi/packagekit-glib2.vapi
 %endif
 
@@ -609,6 +542,12 @@ fi
 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
 %endif
 
+%if %{with dnf}
+%files backend-dnf
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
+%endif
+
 %if %{with entropy}
 %files backend-entropy
 %defattr(644,root,root,755)
@@ -617,27 +556,10 @@ fi
 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
 %endif
 
-%if %{with hif}
-%files backend-hif
+%if %{with nix}
+%files backend-nix
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_hif.so
-%endif
-
-%if %{with katja}
-%files backend-katja
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_katja.so
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Katja.conf
-%dir /var/cache/PackageKit/metadata
-%ghost /var/cache/PackageKit/metadata/metadata.db
-%endif
-
-%if %{with pisi}
-%files backend-pisi
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
-%dir %{_datadir}/PackageKit/helpers/pisi
-%attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
+%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
 %endif
 
 %if %{with poldek}
@@ -654,23 +576,13 @@ fi
 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
 %endif
 
-%if %{with ports}
-%files backend-ports
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_ports.so
-%dir %{_datadir}/PackageKit/helpers/ports
-%attr(755,root,root) %{_datadir}/PackageKit/helpers/ports/portsBackend.rb
-%{_datadir}/PackageKit/helpers/ports/ruby_packagekit
-%endif
-
-%if %{with urpmi}
-%files backend-urpmi
+%if %{with slack}
+%files backend-slack
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_urpmi.so
-%dir %{_datadir}/PackageKit/helpers/urpmi
-%attr(755,root,root) %{_datadir}/PackageKit/helpers/urpmi/urpmi-dispatched-backend.pl
-%{_datadir}/PackageKit/helpers/urpmi/perl_packagekit
-%{_datadir}/PackageKit/helpers/urpmi/urpmi_backend
+%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
+%dir /var/cache/PackageKit/metadata
+%ghost /var/cache/PackageKit/metadata/metadata.db
 %endif
 
 %if %{with zypp}
@@ -685,13 +597,9 @@ fi
 %attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
 
-%files gtk-module
-%defattr(644,root,root,755)
-%doc contrib/gtk-module/{GLASS.txt,README}
-%attr(755,root,root) %{_libdir}/gtk-2.0/modules/libpk-gtk-module.so
-
 %files gtk3-module
 %defattr(644,root,root,755)
+%doc contrib/gtk-module/{GLASS.txt,README}
 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
 
@@ -705,9 +613,3 @@ fi
 %dir %{py_sitescriptdir}/packagekit
 %{py_sitescriptdir}/packagekit/*.py[co]
 %endif
-
-%if %{with browser}
-%files -n browser-plugin-packagekit
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_browserpluginsdir}/packagekit-plugin.so
-%endif
This page took 0.075719 seconds and 4 git commands to generate.