]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- fix packaging config file
[packages/OpenAL.git] / OpenAL.spec
index 745b0c481fd384d9860d150879f3c211ee2d1cb6..0510c9ad3a32f10c38ec85497ec845624adec24e 100644 (file)
@@ -1,46 +1,25 @@
 #
 # Conditional build:
-%bcond_without alsa    # without ALSA support
-%bcond_with    arts    # with aRts support
-%bcond_without doc     # don't build HTML documentation (from SGML source)
-%bcond_without esd     # without esd support
-%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
-                       # Currently broken.
+%bcond_without alsa            # without ALSA support
+%bcond_without portaudio       # without PortAudio support
+%bcond_without pulseaudio      # without PulseAudio support
 #
-# TODO:
-# - remove zip BR?
-#
-
-%define        _branch Linux_Spec1-0
-
 Summary:       Open Audio Library
-Summary(pl):   Otwarta Biblioteka D¼wiêku
+Summary(pl.UTF-8):     Otwarta Biblioteka Dźwięku
 Name:          OpenAL
-Version:       0.0.8
-%define        snap    20051015
-Release:       0.%{snap}.1
-License:       LGPL
+Version:       1.14
+Release:       3
+License:       LGPL v2+
 Group:         Libraries
-# from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
-# (without all Win and Mac stuff and demos)
-Source0:       %{name}-%{_branch}-%{snap}.tar.bz2
-# Source0-md5: 013a571cf588bec1d3a5628b5ed527ea
-Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-info.patch
+Source0:       http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
+# Source0-md5: 3d8b86c21a2f87a2a5e60f78f3b3f03d
+Patch0:                %{name}-link.patch
+#URL:          http://kcat.strangesoft.net/openal.html
 URL:           http://www.openal.org/
-BuildRequires: SDL-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
-%{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: autoconf
-BuildRequires: automake
-%{?with_doc:BuildRequires:     docbook-utils}
-%{?with_esd:BuildRequires:     esound-devel}
-%{?with_doc:BuildRequires:     gnome-doc-tools}
-BuildRequires: libvorbis-devel
-%{?with_mmx:BuildRequires:     nasm}
-BuildRequires: smpeg-devel
-BuildRequires: texinfo
-BuildRequires: zip
+BuildRequires: cmake
+%{?with_portaudio:BuildRequires:       portaudio-devel}
+%{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -51,76 +30,52 @@ developers and desktop users that rely on portable standards like
 OpenGL, for games and other multimedia applications. OpenAL is already
 supported by a number of hardware vendors and developers.
 
-%description -l pl
-OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
-interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
-Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
-którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
-aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
-dostarczycieli sprzêtu i programistów.
+%description -l pl.UTF-8
+OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
+stworzenia otwartego, niezależnego od producentów, międzyplatformowego
+interfejsu projektowania aplikacji w części obsługi dźwięku.
+Biblioteka adresowana jest do twórców aplikacji i użytkowników,
+którzy wybierają przenośne standardy, jak OpenGL, w grach i
+aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
+dostarczycieli sprzętu i programistów.
 
 %package devel
 Summary:       Headers for OpenAL
-Summary(pl):   Pliki nag³ówkowe do OpenAL
+Summary(pl.UTF-8):     Pliki nagłówkowe do OpenAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
 
-%description devel -l pl
-Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
+%description devel -l pl.UTF-8
+Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
 OpenAL.
 
-%package static
-Summary:       OpenAL static library
-Summary(pl):   Statyczna biblioteka OpenAL
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description static
-OpenAL static library.
-
-%description static -l pl
-Biblioteka OpenAL do konsolidacji statycznej.
-
 %prep
-%setup -q -n %{name}-%{_branch}-%{snap}
+%setup -q -n openal-soft-%{version}
 %patch0 -p1
-%patch1 -p1
-
-cp CREDITS docs
 
 %build
-cd linux
-cp -f /usr/share/automake/config.sub .
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
-%configure \
-       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
-       %{?with_arts:--enable-arts --enable-arts-dlopen} \
-       %{?with_esd:--enable-esd --enable-esd-dlopen} \
-       --enable-sdl \
-       --enable-vorbis \
-       --enable-smpeg \
-       --enable-capture \
-       --with-gcc=%{__cc}
+%cmake . \
+       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       -DCMAKE_VERBOSE_MAKEFILE=1 \
+       -DEXAMPLES=OFF \
+       -DLIB_INSTALL_DIR=%{_lib} \
+       %{!?with_alsa:-DALSA=OFF} \
+       %{!?with_portaudio:-DPORTAUDIO=OFF} \
+       %{!?with_pulseaudio:-DPULSEAUDIO=OFF}
 
 %{__make}
 
-cd ../docs/spec1-0
-%{?with_doc:%{__make} full-html}
-
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_infodir}
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
 
-%{__make} -C linux install \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
+install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -128,26 +83,16 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun        devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
 %files
 %defattr(644,root,root,755)
-%doc linux/{CREDITS,ChangeLog,NOTES,TODO}
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
+%attr(755,root,root) %{_bindir}/makehrtf
+%attr(755,root,root) %{_bindir}/openal-info
+%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
 
 %files devel
 %defattr(644,root,root,755)
-%doc linux/doc/LOKI* %{?with_doc:docs/spec1-0/oalspecs-full docs/spec1-1/OpenAL1-1Spec.pdf}
-%attr(755,root,root) %{_libdir}/lib*.so
-%attr(755,root,root) %{_bindir}/*-config
-%{_pkgconfigdir}/*
+%attr(755,root,root) %{_libdir}/libopenal.so
 %{_includedir}/AL
-%{_infodir}/openal.info*
-
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_pkgconfigdir}/openal.pc
This page took 0.108634 seconds and 4 git commands to generate.