]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
Version: 11.2.2
[packages/Mesa.git] / Mesa.spec
index 0f6a902e8bc58d389780850243013f0effd1a6be..e1d8d9fa29eeff1ee63b6eb94c631873e72b3639 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -2,7 +2,6 @@
 # TODO:
 # - check if gallium_i915 note is still valid, switch the bcond if not
 # - consider:
-# - ARM drivers (ilo,freedreno,vc4)?
 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
 # - resurrect static if it's useful (using plain xorg target? DRI doesn't support static)
 #
@@ -32,7 +31,7 @@
 # minimal supported xserver version
 %define                xserver_ver             1.5.0
 # other packages
-%define                libdrm_ver              2.4.63
+%define                libdrm_ver              2.4.66
 %define                dri2proto_ver           2.6
 %define                dri3proto_ver           1.0
 %define                glproto_ver             1.4.14
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       11.1.0
+# NOTE:                version 11.3.0 is being prepared on the MESA_11_3 branch
+Version:       11.2.2
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/mesa-%{version}.tar.xz
-# Source0-md5: 00a81d2b97cc62c08ae91f8914825f0b
+# Source0-md5: e0ec73f7273662a74366f0d76dd19ac3
 Patch0:                missing-type.patch
-Patch1:                x32.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -72,14 +71,15 @@ BuildRequires:      automake
 BuildRequires: elfutils-devel
 BuildRequires: expat-devel
 BuildRequires: gcc >= 6:4.2.0
+%{?with_nine:BuildRequires:    gcc-c++ >= 6:4.6}
 %{?with_opencl:BuildRequires:  gcc-c++ >= 6:4.7}
 BuildRequires: libdrm-devel >= %{libdrm_ver}
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 6:4.2.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
 BuildRequires: libtool >= 2:2.2
-%{?with_va:BuildRequires:      libva-devel >= 1.3.0}
-%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.35.0}
+%{?with_va:BuildRequires:      libva-devel >= 1.6.0}
+%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.38.0}
 BuildRequires: libvdpau-devel >= 1.1
 BuildRequires: libxcb-devel >= 1.10
 %{?with_gallium_radeon:BuildRequires:  llvm-devel >= 3.4.2}
@@ -525,7 +525,7 @@ R600/R700.
 Summary:       VA driver for Gallium State Tracker
 Summary(pl.UTF-8):     Sterownik VA do Gallium
 Group:         Libraries
-Requires:      libva >= 1.3.0
+Requires:      libva >= 1.6.0
 
 %description -n libva-driver-gallium
 VA driver for Gallium State Tracker.
@@ -717,6 +717,21 @@ X.org DRI driver for ATI Southern Islands card family.
 %description dri-driver-ati-radeon-SI -l pl.UTF-8
 Sterownik X.org DRI dla rodziny kart ATI Southern Islands.
 
+%package dri-driver-freedreno
+Summary:       X.org DRI driver for Adreno chips
+Summary(pl.UTF-8):     Sterownik X.org DRI dla układów Adreno
+License:       MIT
+Group:         X11/Libraries
+Requires:      xorg-driver-video-freedreno
+Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
+Requires:      xorg-xserver-server >= %{xserver_ver}
+
+%description dri-driver-freedreno
+X.org DRI driver for Adreno chips.
+
+%description dri-driver-freedreno -l pl.UTF-8
+Sterownik X.org DRI dla układów Adreno.
+
 %package dri-driver-intel-i915
 Summary:       X.org DRI driver for Intel i915 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i915
@@ -801,6 +816,21 @@ X.org DRI software rasterizer driver.
 %description dri-driver-swrast -l pl.UTF-8
 Sterownik X.org DRI obsługujący rysowanie programowe.
 
+%package dri-driver-vc4
+Summary:       X.org DRI driver for Broadcom VC4 chips
+Summary(pl.UTF-8):     Sterownik X.org DRI dla układów Broadcom VC4
+License:       MIT
+Group:         X11/Libraries
+Requires:      xorg-driver-video-modesetting
+Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
+Requires:      xorg-xserver-server >= %{xserver_ver}
+
+%description dri-driver-vc4
+X.org DRI driver for Broadcom VC4 chips.
+
+%description dri-driver-vc4 -l pl.UTF-8
+Sterownik X.org DRI dla układów Broadcom VC4.
+
 %package dri-driver-virgl
 Summary:       X.org DRI driver for QEMU VirGL
 Summary(pl.UTF-8):     Sterownik X.org DRI dla QEMU VirGL
@@ -1132,7 +1162,6 @@ ATI Radeon oparte na układach Southern Islands.
 %prep
 %setup -q -n mesa-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -1167,6 +1196,10 @@ nouveau
 %endif
 ilo \
 virgl \
+%ifarch arm
+freedreno \
+vc4 \
+%endif
 "
 
 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
@@ -1532,6 +1565,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
 
 %if %{with gallium}
+%ifarch arm
+%files dri-driver-vc4
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/vc4_dri.so
+%endif
+
 %files dri-driver-virgl
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/virtio_gpu_dri.so
This page took 0.105566 seconds and 4 git commands to generate.