]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
up to 21.2.4
[packages/Mesa.git] / Mesa.spec
index 9a4ad9115ef58d1ca4920746a09622f32c93f895..a43d5379bb4cc63202a861cebfe6620e94145f56 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver               7.1.0
 # other packages
-%define                libdrm_ver              2.4.105
+%define                libdrm_ver              2.4.107
 %define                dri2proto_ver           2.8
 %define                glproto_ver             1.4.14
 %define                zlib_ver                1.2.8
 %define                wayland_ver             1.18
 %define                libglvnd_ver            1.3.2
-%define                llvm_ver                8.0.0
+%define                llvm_ver                11.0.0
 %define                gcc_ver                 6:4.8.0
 
 %if %{without gallium}
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       21.1.0
+Version:       21.2.4
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 #Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 ## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
 Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
-# Source0-md5: 7482dd659c3708bdda247c96449d9d79
-Patch0:                nouveau_no_rtti.patch
-Patch1:                zink_x32.patch
+# Source0-md5: 2679399fdb3603fe8304b6aebcb56154
+Patch0:                zink_x32.patch
 URL:           https://www.mesa3d.org/
 %{?with_opencl_spirv:BuildRequires:    SPIRV-LLVM-Translator-devel >= 8.0.1.3}
 %{?with_gallium_zink:BuildRequires:    Vulkan-Loader-devel}
@@ -96,7 +95,7 @@ BuildRequires:        libselinux-devel
 BuildRequires: libstdc++-devel >= %{gcc_ver}
 BuildRequires: libunwind-devel
 %{?with_va:BuildRequires:      libva-devel}
-%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.39.0}
+%{?with_va:BuildRequires:      pkgconfig(libva) >= 1.1.0}
 %{?with_vdpau:BuildRequires:   libvdpau-devel >= 1.1}
 BuildRequires: libxcb-devel >= 1.13
 %{?with_gallium:BuildRequires: llvm-devel >= %{llvm_ver}}
@@ -262,11 +261,12 @@ Summary:  Header files for Mesa3D libGL library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
 License:       MIT
 Group:         X11/Development/Libraries
-Requires:      libdrm-devel >= %{libdrm_ver}
 %if %{with glvnd}
 Requires:      libglvnd-libGL-devel >= %{libglvnd_ver}
 %else
+Requires:      %{name}-khrplatform-devel = %{version}-%{release}
 Requires:      %{name}-libGL = %{version}-%{release}
+Requires:      libdrm-devel >= %{libdrm_ver}
 Requires:      libxcb-devel >= 1.13
 Requires:      pkgconfig(xcb-dri2) >= 1.8
 Requires:      pkgconfig(xcb-glx) >= 1.8.1
@@ -521,6 +521,7 @@ Pliki nagłówkowe biblioteki akceleracji Gallium3D dla Xorg.
 Summary:       Khronos platform header file
 Summary(pl.UTF-8):     Plik nagłówkowy platformy Khronos
 Group:         Development/Libraries
+Provides:      khrplatform-devel
 Conflicts:     Mesa-libEGL-devel < 8.0.1-2
 
 %description khrplatform-devel
@@ -529,6 +530,25 @@ Khronos platform header file.
 %description khrplatform-devel -l pl.UTF-8
 Plik nagłówkowy platformy Khronos.
 
+%package dri-devel
+Summary:       Direct Rendering Infrastructure interface header file
+Summary(pl.UTF-8):     Plik nagłówkowy interfejsu DRI (Direct Rendering Infrastructure)
+Group:         Development/Libraries
+Requires:      libdrm-devel >= %{libdrm_ver}
+# <GL/gl.h>
+%if %{with glvnd}
+Requires:      libglvnd-libGL-devel >= %{libglvnd_ver}
+Conflicts:     Mesa-libGL-devel < 22.1.0-2
+%else
+Requires:      Mesa-libGL-devel = %{version}-%{release}
+%endif
+
+%description dri-devel
+Direct Rendering Infrastructure interface header file.
+
+%description dri-devel -l pl.UTF-8
+Plik nagłówkowy interfejsu DRI (Direct Rendering Infrastructure).
+
 %package libXvMC-nouveau
 Summary:       Mesa implementation of XvMC API for NVidia adapters
 Summary(pl.UTF-8):     Implementacja Mesa API XvMC dla kart NVidia
@@ -736,6 +756,22 @@ X.org Gallium DRI driver for Adreno chips.
 %description dri-driver-freedreno -l pl.UTF-8
 Sterownik X.org DRI Gallium dla układów Adreno.
 
+%package dri-driver-intel-crocus
+Summary:       X.org DRI driver for Intel Gen4-Gen7 chips
+Summary(pl.UTF-8):     Sterownik X.org DRI dla układów Intel Gen4-Gen7
+License:       MIT
+Group:         X11/Libraries
+%{?with_swr:Requires:  cpuinfo(avx)}
+Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
+Requires:      xorg-xserver-server >= %{xserver_ver}
+Requires:      zlib >= %{zlib_ver}
+
+%description dri-driver-intel-crocus
+X.org Gallium DRI driver for Intel Gen4/Gen5/Gen6/Gen7 chips.
+
+%description dri-driver-intel-crocus -l pl.UTF-8
+Sterownik X.org DRI dla układów Intel Gen4/Gen5/Gen6/Gen7.
+
 %package dri-driver-intel-i915
 Summary:       X.org DRI driver for Intel i915 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i915
@@ -991,6 +1027,20 @@ X.org Gallium DRI driver based on Vulkan.
 %description dri-driver-zink -l pl.UTF-8
 Sterownik X.org DRI Gallium oparty na Vulkanie.
 
+%package pipe-driver-crocus
+Summary:       crocus driver for Mesa Gallium dynamic pipe loader
+Summary(pl.UTF-8):     Sterownik crocus dla dynamicznego systemu potoków szkieletu Mesa Gallium
+Group:         Libraries
+Requires:      zlib >= %{zlib_ver}
+
+%description pipe-driver-crocus
+crocus driver for Mesa Gallium dynamic pipe loader. It supports Intel
+Gen4/Gen5/Gen6/Gen7 chips.
+
+%description pipe-driver-crocus -l pl.UTF-8
+Sterownik crocus dla dynamicznego systemu potoków szkieletu Mesa
+Gallium. Obsługuje układy Intela Gen4/Gen5/Gen6/Gen7.
+
 %package pipe-driver-i915
 Summary:       i915 driver for Mesa Gallium dynamic pipe loader
 Summary(pl.UTF-8):     Sterownik i915 dla dynamicznego systemu potoków szkieletu Mesa Gallium
@@ -1025,6 +1075,19 @@ Gallium. Obsługuje układy Intela z rodziny kart Intel Iris (Gen8+:
 Broadwell, Skylake, Broxton, Kabylake, Coffeelake, Geminilake, Whiskey
 Lake, Comet Lake, Cannonlake, Ice Lake, Elkhart Lake).
 
+%package pipe-driver-kmsro
+Summary:       kmsro driver for Mesa Gallium dynamic pipe loader
+Summary(pl.UTF-8):     Sterownik kmsro dla dynamicznego systemu potoków szkieletu Mesa Gallium
+Group:         Libraries
+Requires:      zlib >= %{zlib_ver}
+
+%description pipe-driver-kmsro
+kmsro driver for Mesa Gallium dynamic pipe loader.
+
+%description pipe-driver-kmsro -l pl.UTF-8
+Sterownik kmsro dla dynamicznego systemu potoków szkieletu Mesa
+Gallium.
+
 %package pipe-driver-msm
 Summary:       msm (freedreno) driver for Mesa Gallium dynamic pipe loader
 Summary(pl.UTF-8):     Sterownik msm (freedreno) dla dynamicznego systemu potoków szkieletu Mesa Gallium
@@ -1392,6 +1455,27 @@ lavapipe - Mesa software Vulkan driver.
 %description vulkan-icd-lavapipe -l pl.UTF-8
 lavapipe - programowy sterownik Vulkan.
 
+%package vulkan-icd-panfrost
+Summary:       panfrost - Mesa Vulkan driver for Mali Midgard and Bifrost GPUs
+Summary(pl.UTF-8):     panfrost - sterownik Vulkan dla układów Mali Midgard i Bifrost
+License:       MIT
+Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
+Requires:      xorg-lib-libXrandr >= 1.3
+Requires:      xorg-lib-libxshmfence >= 1.1
+# wayland-client
+Requires:      wayland >= %{wayland_ver}
+Requires:      zlib >= %{zlib_ver}
+Suggests:      vulkan(loader)
+Provides:      vulkan(icd) = 1.0.3
+
+%description vulkan-icd-panfrost
+panfrost - Mesa Vulkan driver for Mali Midgard and Bifrost GPUs.
+
+%description vulkan-icd-panfrost -l pl.UTF-8
+panfrost - sterownik Vulkan dla układów Mali Midgard i Bifrost.
+
 %package vulkan-icd-radeon
 Summary:       radv - experimental Mesa Vulkan driver for AMD Radeon GPUs
 Summary(pl.UTF-8):     radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD
@@ -1416,7 +1500,6 @@ radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD.
 %prep
 %setup -q -n mesa-mesa-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 %if %{with opencl}
@@ -1439,7 +1522,7 @@ dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
 
 gallium_drivers="virgl swrast %{?with_gallium_zink:zink} \
 %ifarch %{ix86} %{x8664} x32
-svga iris %{?with_swr:swr} %{?with_gallium_i915:i915} \
+svga iris %{?with_swr:swr} %{?with_gallium_i915:i915} crocus \
 %endif
 %if %{with gallium_radeon}
 r300 r600 radeonsi \
@@ -1465,7 +1548,7 @@ vulkan_drivers="swrast %{?with_radv:amd} \
 intel \
 %endif
 %ifarch %{arm} aarch64
-freedreno broadcom \
+freedreno broadcom panfrost \
 %endif
 "
 
@@ -1616,9 +1699,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/GL/glxext.h
 %{_pkgconfigdir}/gl.pc
 %endif
-%dir %{_includedir}/GL/internal
-%{_includedir}/GL/internal/dri_interface.h
-%{_pkgconfigdir}/dri.pc
 
 %files libGLES
 %defattr(644,root,root,755)
@@ -1712,14 +1792,18 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/xatracker.pc
 %endif
 
-%if %{with egl}
-%if %{without glvnd}
+%if %{with egl} && %{without glvnd}
 %files khrplatform-devel
 %defattr(644,root,root,755)
 %dir %{_includedir}/KHR
 %{_includedir}/KHR/khrplatform.h
 %endif
-%endif
+
+%files dri-devel
+%defattr(644,root,root,755)
+%dir %{_includedir}/GL/internal
+%{_includedir}/GL/internal/dri_interface.h
+%{_pkgconfigdir}/dri.pc
 
 ### drivers: XvMC
 
@@ -1780,6 +1864,7 @@ rm -rf $RPM_BUILD_ROOT
 %ifarch %{ix86} %{x8664} x32
 %files dri-driver-intel-i915
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
 
 %files dri-driver-intel-i965
@@ -1787,6 +1872,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
 
 %if %{with gallium}
+%files dri-driver-intel-crocus
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/crocus_dri.so
+
 %files dri-driver-intel-iris
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/iris_dri.so
@@ -1828,6 +1917,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-dcss_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-drm_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ingenic-drm_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/mali-dp_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mcde_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mediatek_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/meson_dri.so
@@ -1886,6 +1976,10 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with gallium}
 %if %{with opencl}
 %ifarch %{ix86} %{x8664} x32
+%files pipe-driver-crocus
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/gallium-pipe/pipe_crocus.so
+
 %if %{with gallium_i915}
 %files pipe-driver-i915
 %defattr(644,root,root,755)
@@ -1897,7 +1991,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_iris.so
 %endif
 
-%ifarch %{arm}
+%ifarch %{arm} aarch64
+%files pipe-driver-kmsro
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/gallium-pipe/pipe_kmsro.so
+
 %files pipe-driver-msm
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_msm.so
@@ -1927,10 +2025,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_swrast.so
 
+%ifarch %{ix86} %{x8664} x32
 %files pipe-driver-vmwgfx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_vmwgfx.so
 %endif
+%endif
 
 # currently disabled as cannot be built with swrast
 %if %{with swr}
@@ -2021,6 +2121,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libvulkan_freedreno.so
 %{_datadir}/vulkan/icd.d/freedreno_icd.*.json
+
+%files vulkan-icd-panfrost
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libvulkan_panfrost.so
+%{_datadir}/vulkan/icd.d/panfrost_icd.*.json
 %endif
 
 %ifarch %{ix86} %{x8664} x32
This page took 0.038868 seconds and 4 git commands to generate.