]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- up to 8.0.4 but latest nouveau changes broke build
[packages/Mesa.git] / Mesa.spec
index 2f909a467a126ca56a58986bab2d1cb38cf30120..7756f4da378831683aa143009c9e5efb3bb9f6ba 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -6,10 +6,11 @@
 # - resurrect static if it's useful (using plain xorg target? DRI doesn't support static)
 #
 # Conditional build:
-%bcond_without egl             # EGL libraries
 %bcond_without gallium         # gallium drivers
-%bcond_with    gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
-%bcond_without gallium_nouveau # gallium nouveau driver
+%bcond_with    gallium_intel   # gallium i915 driver (instead of plain dri; doesn't work with AIGLX)
+%bcond_without gallium_nouveau # gallium nouveau driver (instead of plain dri)
+%bcond_with    dri_nouveau     # nouveau DRI driver (any kind; doesn't build with current libdrm)
+%bcond_without egl             # EGL libraries
 %bcond_without osmesa          # OSMesa libraries
 %bcond_without gbm             # Graphics Buffer Manager
 %bcond_without wayland         # Wayland EGL
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
-Version:       8.0.1
-Release:       3
+Version:       8.0.4
+Release:       1
 License:       MIT (core), SGI (GLU) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 24eeebf66971809d8f40775a379b36c9
+# Source0-md5: d546f988adfdf986cff45b1efa2d8a46
 Patch100:      %{name}-git.patch
 Patch0:                %{name}-realclean.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-wayland.patch
+Patch3:                llvm-3.1.patch
 URL:           http://www.mesa3d.org/
-BuildRequires: autoconf >= 2.59
+BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 BuildRequires: expat-devel
 BuildRequires: gcc >= 5:3.3
@@ -71,7 +73,7 @@ BuildRequires:        xorg-lib-libXxf86vm-devel
 BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
 BuildRequires: xorg-util-makedepend
-BuildRequires: xorg-xserver-server-devel
+BuildRequires: xorg-xserver-server-devel >= %{xserver_ver}
 %if %{with egl}
 BuildRequires: libxcb-devel
 BuildRequires: udev-devel >= 1:150
@@ -268,6 +270,9 @@ Summary:    Mesa implementation of GLES (OpenGL ES) libraries
 Summary(pl.UTF-8):     Implementacja Mesa bibliotek GLES (OpenGL ES)
 Group:         Libraries
 Requires:      %{name}-libglapi = %{version}-%{release}
+Provides:      OpenGLES
+Provides:      OpenGLESv1 = 1.1
+Provides:      OpenGLESv2 = 2.0
 
 %description libGLES
 This package contains shared libraries of Mesa implementation of GLES
@@ -292,6 +297,9 @@ Requires:   %{name}-khrplatform-devel = %{version}-%{release}
 # <EGL/egl.h> for <GLES/egl.h>
 Requires:      %{name}-libEGL-devel = %{version}-%{release}
 Requires:      %{name}-libGLES = %{version}-%{release}
+Provides:      OpenGLES-devel
+Provides:      OpenGLESv1-devel = 1.1
+Provides:      OpenGLESv2-devel = 2.0
 
 %description libGLES-devel
 Header files for Mesa GLES libraries.
@@ -397,6 +405,7 @@ Summary:    Mesa implementation of OpenVG (Vector Graphics Accelleration) API
 Summary(pl.UTF-8):     Implementacja Mesa API OpenVG (akceleracji grafiki wektorowej)
 License:       MIT
 Group:         Libraries
+Provides:      OpenVG = 1.1
 
 %description libOpenVG
 This package contains Mesa implementation of OpenVG - cross-platform
@@ -420,6 +429,7 @@ License:    MIT
 Group:         Development/Libraries
 Requires:      %{name}-khrplatform-devel = %{version}-%{release}
 Requires:      %{name}-libOpenVG = %{version}-%{release}
+Provides:      OpenVG-devel = 1.1
 
 %description libOpenVG-devel
 Header file for Mesa OpenVG library.
@@ -882,10 +892,11 @@ Sterownik Mesa softpipe dla API vdpau.
 
 %prep
 %setup -q
-%patch100 -p1
+#%patch100 -p1
 %patch0 -p0
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
@@ -896,6 +907,9 @@ dri_drivers="r200 radeon \
 i915 \
 %endif
 i965
+%if %{with dri_nouveau} && %{without gallium_nouveau}
+nouveau
+%endif
 %ifarch sparc sparcv9 sparc64
 ffb \
 %endif
@@ -909,7 +923,7 @@ i915 \
 %endif
 r300 \
 r600 \
-%if %{with gallium_nouveau}
+%if %{with dri_nouveau} && %{with gallium_nouveau}
 nouveau \
 %endif
 "
@@ -1278,6 +1292,7 @@ rm -rf $RPM_BUILD_ROOT
 %files dri-driver-ati-radeon-R600
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
+%endif
 
 %files dri-driver-intel-i915
 %defattr(644,root,root,755)
@@ -1287,12 +1302,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
 
-%if %{with gallium_nouveau}
+%if %{with dri_nouveau}
 %files dri-driver-nouveau
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
 %endif
-%endif
 
 %files dri-driver-swrast
 %defattr(644,root,root,755)
This page took 0.068855 seconds and 4 git commands to generate.