]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
Version: 19.0.2
[packages/Mesa.git] / Mesa.spec
index 923692d112c8c455bfdecb2042129dfa349cd509..53f162468c948c56e2cae141f4559b675760366e 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -1,3 +1,4 @@
+# TODO: libtizonia >= 0.10.0 as an alternative for bellagio?
 #
 # Conditional build:
 %bcond_without gallium         # gallium drivers
@@ -6,7 +7,8 @@
 %bcond_without egl             # EGL libraries
 %bcond_without gbm             # Graphics Buffer Manager
 %bcond_without nine            # Nine Direct3D 9+ state tracker (for Wine)
-%bcond_with    opencl          # OpenCL support (requires LLVM with RTTI)
+%bcond_without opencl          # OpenCL support
+%bcond_without ocl_icd         # OpenCL as ICD (installable client driver)
 %bcond_with    glvnd           # OpenGL vendor neutral dispatcher support
 %bcond_without omx             # OpenMAX (Bellagio OMXIL) support
 %bcond_without va              # VA library
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver               7.1.0
 # other packages
-%define                libdrm_ver              2.4.95
+%define                libdrm_ver              2.4.97
 %define                dri2proto_ver           2.8
 %define                glproto_ver             1.4.14
 %define                zlib_ver                1.2.8
 %define                wayland_ver             1.11
-%define                llvm_ver                6.0.0
+%define                llvm_ver                7.0.0
 %define                gcc_ver                 6:4.8.0
 
 %if %{without gallium}
 %undefine      with_wayland
 %endif
 
+%if %{without opencl}
+%undefine      with_ocl_icd
+%endif
+
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
-Version:       18.3.1
-Release:       0.1
+Version:       19.0.2
+Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 #Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 ## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
 Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
-# Source0-md5: 2ab9559b111f10d1a7617970626172e3
+# Source0-md5: 4a5e81eba57f6888a5be8fba0b9aa843
 Patch0:                nouveau_no_rtti.patch
 URL:           http://www.mesa3d.org/
-BuildRequires: meson >= 0.45
-BuildRequires:  ninja
 %{?with_opencl:BuildRequires:  clang-devel >= %{llvm_ver}}
 BuildRequires: elfutils-devel
 BuildRequires: expat-devel >= 1.95
@@ -76,6 +80,8 @@ BuildRequires:        libxcb-devel >= 1.13
 %{?with_radv:BuildRequires:    llvm-devel >= %{llvm_ver}}
 %{?with_opencl:BuildRequires:  llvm-libclc}
 %{?with_omx:BuildRequires:     libomxil-bellagio-devel}
+BuildRequires: meson >= 0.45
+BuildRequires: ninja
 BuildRequires: pkgconfig
 BuildRequires: pkgconfig(talloc) >= 2.0.1
 BuildRequires: pkgconfig(xcb-dri2) >= 1.8
@@ -1199,10 +1205,13 @@ r300 r600 radeonsi \
 %if %{with gallium_nouveau}
 nouveau
 %endif
-%ifarch %{arm}
+%ifarch %{arm} aarch64
 etnaviv \
 freedreno \
 imx \
+pl111 \
+tegra \
+v3d \
 vc4 \
 %endif
 "
@@ -1222,25 +1231,33 @@ vulkan_drivers=$(echo $vulkan_drivers | xargs | tr ' ' ',')
        -Ddri3=true \
        -Ddri-drivers=${dri_drivers} \
        -Ddri-drivers-path=%{_libdir}/xorg/modules/dri \
+       -Degl=%{?with_egl:true}%{!?with_egl:false} \
        -Dgallium-drivers=${gallium_drivers} \
        %{?with_hud_extra:-Dgallium-extra-hud=true} \
+       -Dgallium-nine=%{?with_nine:true}%{!?with_nine:false} \
+       -Dgallium-omx=%{?with_omx:bellagio}%{!?with_omx:disabled} \
+%if %{with opencl}
+%if %{with ocl_icd}
+       -Dgallium-opencl=icd \
+%else
+       -Dgallium-opencl=standalone \
+%endif
+%else
+       -Dgallium-opencl=disabled \
+%endif
+       -Dgallium-va=%{?with_va:true}%{!?with_va:false} \
        -Dgallium-vdpau=true \
        -Dgallium-xvmc=true \
-       -Dgallium-omx=%{?with_omx:bellagio}%{?!with_omx:disabled} \
-       -Dgallium-va=%{?with_va:true}%{?!with_va:false} \
-       -Dva-libs-path=%{_libdir}/libva/dri \
-       -Dgallium-xa=%{?with_xa:true}%{?!with_xa:false} \
-       -Dgallium-nine=%{?with_nine:true}%{?!with_nine:false} \
-       -Dgallium-opencl=%{?with_opencl:icd}%{?!with_opencl:disabled} \
-       -Dvulkan-drivers=${vulkan_drivers} \
-       -Dvulkan-icd-dir=/usr/share/vulkan/icd.d \
-       -Dgbm=%{?with_gbm:true}%{?!with_gbm:false} \
-       -Degl=%{?with_egl:true}%{?!with_egl:false} \
-       -Dglvnd=%{?with_glvnd:true}%{?!with_glvnd:false} \
+       -Dgallium-xa=%{?with_xa:true}%{!?with_xa:false} \
+       -Dgbm=%{?with_gbm:true}%{!?with_gbm:false} \
+       -Dglvnd=%{?with_glvnd:true}%{!?with_glvnd:false} \
        -Dlibunwind=true \
-       -Dlmsensors=%{?with_lm_sensors:true}%{?!with_lm_sensors:false} \
+       -Dlmsensors=%{?with_lm_sensors:true}%{!?with_lm_sensors:false} \
+       -Dosmesa=%{?with_gallium:gallium}%{!?with_gallium:classic} \
        -Dselinux=true \
-       -Dosmesa=%{?with_gallium:gallium}%{?!with_gallium:classic}
+       -Dva-libs-path=%{_libdir}/libva/dri \
+       -Dvulkan-drivers=${vulkan_drivers} \
+       -Dvulkan-icd-dir=/usr/share/vulkan/icd.d
 
 %meson_build -C build
 
@@ -1253,6 +1270,7 @@ rm -rf $RPM_BUILD_ROOT
 
 # not used externally
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglapi.so
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/vdpau/libvdpau_gallium.so
 
 %if %{without glvnd}
 # remove "OS ABI: Linux 2.4.20" tag, so private copies (nvidia or fglrx),
This page took 0.034636 seconds and 4 git commands to generate.