]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- package omxil drivers
[packages/Mesa.git] / Mesa.spec
index dd54d0db0d53d72d35d5722b3c0223fd294039aa..18533fcb43ec83a4d1a82f79906be47d08283123 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -11,7 +11,9 @@
 %bcond_without gallium_nouveau # gallium nouveau driver
 %bcond_without egl             # EGL libraries
 %bcond_without gbm             # Graphics Buffer Manager
-%bcond_without opencl          # OpenCL library
+%bcond_without opencl          # OpenCL support
+%bcond_without ocl_icd         # OpenCL as ICD (installable client driver)
+%bcond_without omx             # OpenMAX (Bellagio OMXIL) support
 %bcond_without wayland         # Wayland EGL
 %bcond_without xa              # XA state tracker (for vmwgfx xorg driver)
 %bcond_with    static_libs     # static libraries [not supported for DRI, thus broken currently]
@@ -24,7 +26,7 @@
 # minimal supported xserver version
 %define                xserver_ver             1.5.0
 # other packages
-%define                libdrm_ver              2.4.52
+%define                libdrm_ver              2.4.54
 %define                dri2proto_ver           2.6
 %define                dri3proto_ver           1.0
 %define                glproto_ver             1.4.14
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       10.1.0
+Version:       10.2.1
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
-Source0:       ftp://ftp.freedesktop.org/pub/mesa/10.1/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 3ec43f79dbcd9aa2a4a27bf1f51655b6
-Patch0:                %{name}-link.patch
+Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
+# Source0-md5: 093f9b5d077e5f6061dcd7b01b7aa51a
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 %{?with_opencl:BuildRequires:  clang-devel >= 3.1}
+BuildRequires: elfutils-devel
 BuildRequires: expat-devel
 BuildRequires: gcc >= 5:3.3
 %{?with_opencl:BuildRequires:  gcc-c++ >= 6:4.7}
@@ -56,6 +58,8 @@ BuildRequires:        libvdpau-devel >= 0.4.1
 BuildRequires: libxcb-devel >= 1.10
 BuildRequires: llvm-devel >= 3.3
 %{?with_opencl:BuildRequires:  llvm-libclc}
+%{?with_ocl_icd:BuildRequires: ocl-icd-devel}
+%{?with_omx:BuildRequires:     libomxil-bellagio-devel}
 BuildRequires: perl-base
 BuildRequires: pixman-devel
 BuildRequires: pkgconfig
@@ -63,7 +67,6 @@ BuildRequires:        pkgconfig(talloc) >= 2.0.1
 BuildRequires: pkgconfig(xcb-dri3)
 BuildRequires: pkgconfig(xcb-present)
 BuildRequires: python >= 2
-BuildRequires: python-libxml2
 BuildRequires: python-modules >= 2
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
@@ -76,7 +79,7 @@ BuildRequires:        xorg-lib-libXfixes-devel
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xorg-lib-libXvMC-devel >= 1.0.6
 BuildRequires: xorg-lib-libXxf86vm-devel
-BuildRequires: xorg-lib-libxshmfence-devel
+BuildRequires: xorg-lib-libxshmfence-devel >= 1.1
 BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 BuildRequires: xorg-proto-dri3proto-devel >= %{dri3proto_ver}
 BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
@@ -92,6 +95,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %if %{without gallium}
 %undefine      with_gallium_intel
 %undefine      with_gallium_nouveau
+%undefine      with_ocl_icd
 %undefine      with_opencl
 %undefine      with_xa
 %endif
@@ -166,7 +170,7 @@ Requires:   %{name}-libEGL = %{version}-%{release}
 Requires:      libdrm-devel >= %{libdrm_ver}
 Requires:      xorg-lib-libX11-devel
 Requires:      xorg-lib-libXdamage-devel
-Requires:      xorg-lib-libXext-devel
+Requires:      xorg-lib-libXext-devel >= 1.0.5
 Requires:      xorg-lib-libXfixes-devel
 Requires:      xorg-lib-libXxf86vm-devel
 Requires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
@@ -239,7 +243,7 @@ Requires:   OpenGL >= 1.5
 Requires:      libdrm-devel >= %{libdrm_ver}
 Requires:      xorg-lib-libX11-devel
 Requires:      xorg-lib-libXdamage-devel
-Requires:      xorg-lib-libXext-devel
+Requires:      xorg-lib-libXext-devel >= 1.0.5
 Requires:      xorg-lib-libXxf86vm-devel
 Requires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 Requires:      xorg-proto-glproto-devel >= %{glproto_ver}
@@ -361,6 +365,38 @@ Static OSMesa (off-screen renderer) library.
 %description libOSMesa-static -l pl.UTF-8
 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
 
+%package OpenCL-icd
+Summary:       Mesa implementation of OpenCL (Compuing Language) API ICD
+Summary(pl.UTF-8):     Implementacja Mesa API OpenCL (języka obliczeń) ICD
+License:       MIT
+Group:         Libraries
+Requires:      filesystem >= 4.0-29
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      llvm-libclc
+Requires:      udev-libs >= 1:151
+Provides:      OpenCL = 1.1
+
+%description OpenCL-icd
+This package contains Mesa implementation of OpenCL - standard for
+cross-platform, parallel programming of modern processors found in
+personal computers, servers and handheld/embedded devices. OpenCL
+specification can be found on Khronos Group site:
+<http://www.khronos.org/opencl/>. Mesa implements OpenCL 1.1.
+
+The implementation is provided as an installable client driver (ICD)
+for use with the ocl-icd loader.
+
+%description OpenCL-icd -l pl.UTF-8
+Ten pakiet zawiera implementację Mesa standardu OpenCL - standardu
+wieloplatformowego, równoległego programowania nowoczesnych
+procesorów, jakie znajdują się w komputerach osobistych, serwerach
+oraz urządzeniach przenośnych/wbudowanych. Specyfikację OpenCL można
+znaleźć na stronie Khronos Group: <http://www.khronos.org/opencl/>.
+Mesa zawiera implementację OpenCL w wersji 1.1.
+
+Implementacja dostarczona jest w postaci instalowalnego sterownika klienta
+(ICD), który może być użyty z loaderem ocl-icd.
+
 %package libOpenCL
 Summary:       Mesa implementation of OpenCL (Compuing Language) API
 Summary(pl.UTF-8):     Implementacja Mesa API OpenCL (języka obliczeń)
@@ -897,9 +933,59 @@ adapters based on Southern Islands chips.
 Sterownik Mesa radeonsi dla API vdpau. Obsługuje karty ATI Radeon
 oparte na układach Southern Islands.
 
+%package -n omxil-mesa-nouveau
+Summary:       Mesa nouveau driver for Bellagio OpenMAX IL API
+Summary(pl.UTF-8):     Sterownik Mesa nouveau dla API Bellagio OpenMAX IL
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.8
+Requires:      libomxil-bellagio
+
+%description -n omxil-mesa-nouveau
+Mesa nouveau driver for Bellagio OpenMAX IL API. It supports NVidia
+adapters (NV40-NV96, NVa0).
+
+%description -n omxil-mesa-nouveau -l pl.UTF-8
+Sterownik Mesa nouveau dla API Bellagio OpenMAX IL. Obsługuje karty
+NVidia (NV40-NV96, NVa0).
+
+%package -n omxil-mesa-r600
+Summary:       Mesa r600 driver for Bellagio OpenMAX IL API
+Summary(pl.UTF-8):     Sterownik Mesa r600 dla API Bellagio OpenMAX IL
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.8
+Requires:      libomxil-bellagio
+
+%description -n omxil-mesa-r600
+Mesa r600 driver for Bellagio OpenMAX IL API. It supports ATI Radeon
+adapters based on R600/R700 chips.
+
+%description -n omxil-mesa-r600 -l pl.UTF-8
+Sterownik Mesa r600 dla API Bellagio OpenMAX IL. Obsługuje karty ATI
+Radeon oparte na układach R600/R700.
+
+%package -n omxil-mesa-radeonsi
+Summary:       Mesa radeonsi driver for Bellagio OpenMAX IL API
+Summary(pl.UTF-8):     Sterownik Mesa radeonsi dla API Bellagio OpenMAX IL
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.8
+Requires:      libomxil-bellagio
+
+%description -n omxil-mesa-radeonsi
+Mesa radeonsi driver for Bellagio OpenMAX IL API. It supports ATI
+Radeon adapters based on Southern Islands chips.
+
+%description -n omxil-mesa-radeonsi -l pl.UTF-8
+Sterownik Mesa radeonsi dla API Bellagio OpenMAX IL. Obsługuje karty
+ATI Radeon oparte na układach Southern Islands.
+
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -951,12 +1037,14 @@ gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
 %endif
 %if %{with gallium}
        --enable-gallium-llvm \
-       --with-llvm-shared-libs \
+       --enable-llvm-shared-libs \
        %{__enable egl gallium-egl} \
        %{__enable gbm gallium-gbm} \
-       %{?with_opencl:--enable-opencl} \
+       %{__enable ocl_icd opencl-icd} \
+       %{__enable opencl opencl} \
        %{?with_egl:--enable-openvg} \
        --enable-vdpau \
+       %{?with_omx:--enable-omx} \
        %{?with_xa:--enable-xa} \
        --enable-xvmc \
        --with-gallium-drivers=${gallium_drivers} \
@@ -983,6 +1071,7 @@ rm -rf $RPM_BUILD_ROOT
 # not used externally
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglapi.so
 # dlopened
+%{?with_omx:%{__rm} $RPM_BUILD_ROOT%{_libdir}/bellagio/libomx_*.la}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/egl/egl_*.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gallium-pipe/pipe_*.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gbm/gbm_*.la
@@ -1126,6 +1215,14 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %if %{with opencl}
+%if %{with ocl_icd}
+%files OpenCL-icd
+%defattr(644,root,root,755)
+/etc/OpenCL/vendors/mesa.icd
+%attr(755,root,root) %{_libdir}/libMesaOpenCL.so
+%attr(755,root,root) %{_libdir}/libMesaOpenCL.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libMesaOpenCL.so.1
+%else
 %files libOpenCL
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libOpenCL.so.*.*.*
@@ -1136,6 +1233,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libOpenCL.so
 %{_includedir}/CL
 %endif
+%endif
 
 %if %{with egl} && %{with gallium}
 %files libOpenVG
@@ -1326,3 +1424,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_radeonsi.so.1
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_radeonsi.so
 %endif
+
+%if %{with gallium} && %{with omx}
+%if %{with gallium_nouveau}
+%files -n omxil-mesa-nouveau
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/bellagio/libomx_nouveau.so
+%endif
+
+%files -n omxil-mesa-r600
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/bellagio/libomx_r600.so
+
+%files -n omxil-mesa-radeonsi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/bellagio/libomx_radeonsi.so
+%endif
This page took 0.037847 seconds and 4 git commands to generate.