]> git.pld-linux.org Git - packages/ElectricFence.git/blobdiff - ElectricFence.spec
- release 3,
[packages/ElectricFence.git] / ElectricFence.spec
index 9e7b9dd5ab1dfe022cac89007f4a65f8abd196f6..d3f5a4fdb038c4bf949af794f31932f3d47269dc 100644 (file)
@@ -1,30 +1,40 @@
-Summary:       Electric Fence C memory debugging library
-Summary(de):   Electric Fence C Memory-Debugging-Library
+Summary:       A debugger which detects memory allocation violations
+Summary(de):   Debugger zum Erkennen von Speicherzugriffsverletzungen
 Summary(fr):   Bibliothèque C de débuggage mémoire Electric Fence
-Summary(pl):   Biblioteka Electric Fence
+Summary(pl):   Biblioteka do wykrywania b³edów alokacji pamiêci
 Summary(tr):   C için bellek hatasý ayýklama kitaplýðý
 Name:          ElectricFence
-Version:       2.1
-Release:       1
-Excludearch:   alpha
+Version:       2.2.2
+Release:       3
 Copyright:     GPL
 Group:         Development/Debuggers
 Group(pl):     Programowanie/Odpluskwiacze
-Source:                ftp://perens.com/pub/ElectricFence/%{name}-%{version}.tar.gz
-Patch0:                ElectricFence-glibc.patch
-Patch1:                ElectricFence-longjmp.patch
+Source:                ftp://perens.com/pub/ElectricFence/Beta/%{name}-%{version}.tar.gz
+Patch0:                ElectricFence-longjmp.patch
+Patch1:                ElectricFence-no_bash.spec
 BuildRoot:     /tmp/%{name}-%{version}-root
 
 %description
-Electric Fence is a libary that can be used for C programming and debugging.
-You link it in at compile time and it will warn you of possible problems
-such as free'ing memory that doesn't exist, etc.
+If you know what malloc() violations are, you'll be interested in
+ElectricFence. ElectricFence is a tool which can be used for C programming
+and debugging. It uses the virtual memory hardware of your system to detect
+when software overruns malloc() buffer boundaries, and/or to detect any
+accesses of memory released by free(). ElectricFence will then stop the
+program on the first instruction that caused a bounds violation and you can
+use your favorite debugger to display the offending statement.
+
+This package will install ElectricFence, which you can use if you're
+searching for a debugger to find malloc() violations.
 
 %description -l de
-Electric Fence ist eine Library, die für das Programmieren in C und für
-Debugging-Zwecke benutzt werden kann. Sie wird beim Kompilieren gelinkt und
-warnt vor möglichen Probleme, etwa vor der Freigabe von nicht existierendem
-Speicher und ähnlichem.
+Wenn Sie wissen, was malloc()-Verletzungen sind, sind Sie wahrscheinlich an
+ElectricFence interessiert. ElectricFence ist ein Tool, das zur C-
+Programmierung und zum Debugging benutzt werden kann. Es benutzt virtuelle
+Speicherhardware, um zu erkennen, wenn Software malloc()-Buffergrenzen
+übersteigt, und wenn Speicher mit free() freigegeben wird. ElectricFence
+beendet das Programm bei der Instruktion, die die Speicherverletzung
+ausgelöst hat, und Sie können Ihren Lieblingsdebugger benutzen, um den
+Befehl anzuzeigen.
 
 %description -l fr
 Electric Fence est une bibliothéque utilisée pour la programmation en C et
@@ -34,6 +44,12 @@ probl
 %description -l pl
 Electric Fence jest bibliotek± pomocn± podczas programowania w
 jêzyku C i "odpluskwianiu".
+Pakiet zawiera bibliotekê wspó³dzielon± która mo¿e byæ za³adowana przez
+zmienn± LD_PRELOAD w trakcie uruchamiania dowolnego programu dziêki temu nie
+potrzeba linkowaæ z t± bibliotek± ¶ledzonego programu. Pakiet zawiera tak¿e
+skrypt shellowy ef, któremu mo¿na ³aduje do pamiêci przez LD_PRELOAD
+libliotekê libefence i uruchamia program przekazyny do tego skryptu jako
+parametr.
 
 %description -l tr
 Electric Fence, C'de programlama ve hata ayýklama için kullanýlabilen bir
@@ -41,6 +57,18 @@ kitapl
 çýkabilecek sorunlar (var olmayan bir bellek parçasýnýn serbest býrakýlmasý
 gibi) konusunda uyarýr.
 
+%package static
+Summary:       Satatic Electric Fence library
+Summary(pl):   Biblioteka statyczna Electric Fence
+Group:         Development/Debuggers
+Group(pl):     Programowanie/Odpluskwiacze
+
+%description static
+Satatic Electric Fence library.
+
+%description -l pl static
+Biblioteka statyczna Electric Fence.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -51,54 +79,31 @@ make CFLAGS="$RPM_OPT_FLAGS"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/usr/{lib,man/man3}
+mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib,share/man/man3}
 
-make   LIB_INSTALL_DIR=$RPM_BUILD_ROOT/usr/lib \
-       MAN_INSTALL_DIR=$RPM_BUILD_ROOT/usr/man/man3 \
+make   BIN_INSTALL_DIR=$RPM_BUILD_ROOT%{_bindir} \
+       LIB_INSTALL_DIR=$RPM_BUILD_ROOT%{_libdir} \
+       MAN_INSTALL_DIR=$RPM_BUILD_ROOT%{_mandir}/man3 \
        install
 
-echo .so libefence.3 > $RPM_BUILD_ROOT/usr/man/man3/efence.3
+strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*so.*.*
 
-gzip -9nf $RPM_BUILD_ROOT/usr/man/man3/* \
+gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
        README CHANGES
 
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc *gz
-/usr/lib/lib*.a
-/usr/man/man3/*
-
-%changelog
-* Sun Apr 11 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.1-1]
-- added Group(pl),
-- gzipping %doc.
+%attr(755,root,root) %{_bindir}/ef
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%{_mandir}/man3/*
 
-* Wed Dec 30 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-  [2.0.5-11d]
-- build for PLD, 
-- major changes.
-
-* Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
-- create efence.3 (problem #830)
-
-* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
-- build root
-
-* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
-- translations modified for de
-
-* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
-- need to use sigsetjmp() and siglongjmp() for proper testing
-
-* Fri May 01 1998 Prospector System <bugs@redhat.com>
-- translations modified for de, fr, tr
-
-* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
-- use ExcludeArch instead of Exclude
-
-* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
-- built against glibc
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
This page took 0.113543 seconds and 4 git commands to generate.