]> git.pld-linux.org Git - packages/ElectricFence.git/blobdiff - ElectricFence.spec
-typo
[packages/ElectricFence.git] / ElectricFence.spec
index fea8536eb28f1d41ff5356feff20ff66e7b3c95b..973dfb835185410549aced52cee8c7b716816010 100644 (file)
@@ -1,30 +1,47 @@
-Summary:       Electric Fence C memory debugging library
-Summary(de):   Electric Fence C Memory-Debugging-Library
+Summary:       A debugger which detects memory allocation violations
+Summary(de):   Debugger zum Erkennen von Speicherzugriffsverletzungen
+Summary(es):   Electric Fence biblioteca de depuración de memoria en C
 Summary(fr):   Bibliothèque C de débuggage mémoire Electric Fence
-Summary(pl):   Biblioteka Electric Fence
+Summary(pl):   Biblioteka do wykrywania b³edów alokacji pamiêci
+Summary(pt_BR):        Electric Fence biblioteca de depuração de memória em C
 Summary(tr):   C için bellek hatasý ayýklama kitaplýðý
 Name:          ElectricFence
-Version:       2.2.0
-Release:       4
+Version:       2.2.2
+Release:       3
 Copyright:     GPL
 Group:         Development/Debuggers
 Group(pl):     Programowanie/Odpluskwiacze
-Source:                ftp://perens.com/pub/ElectricFence/%{name}-%{version}.tar.gz
+Source:                ftp://perens.com/pub/ElectricFence/Beta/%{name}-%{version}.tar.gz
 Patch0:                ElectricFence-longjmp.patch
-patch1:                ElectricFence-shlib.patch
-BuildRoot:     /tmp/%{name}-%{version}-root
+Patch1:                ElectricFence-no_bash.spec
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Electric Fence is a libary that can be used for C programming and debugging.
-Package contain shared library libefence which can be loaded by LD_PRELOAD
-without relinking debuged program. Package contain also ef shell script
-which preloads libefence and runs program passed as parameter.
+If you know what malloc() violations are, you'll be interested in
+ElectricFence. ElectricFence is a tool which can be used for C programming
+and debugging. It uses the virtual memory hardware of your system to detect
+when software overruns malloc() buffer boundaries, and/or to detect any
+accesses of memory released by free(). ElectricFence will then stop the
+program on the first instruction that caused a bounds violation and you can
+use your favorite debugger to display the offending statement.
+
+This package will install ElectricFence, which you can use if you're
+searching for a debugger to find malloc() violations.
 
 %description -l de
-Electric Fence ist eine Library, die für das Programmieren in C und für
-Debugging-Zwecke benutzt werden kann. Sie wird beim Kompilieren gelinkt und
-warnt vor möglichen Probleme, etwa vor der Freigabe von nicht existierendem
-Speicher und ähnlichem.
+Wenn Sie wissen, was malloc()-Verletzungen sind, sind Sie wahrscheinlich an
+ElectricFence interessiert. ElectricFence ist ein Tool, das zur C-
+Programmierung und zum Debugging benutzt werden kann. Es benutzt virtuelle
+Speicherhardware, um zu erkennen, wenn Software malloc()-Buffergrenzen
+übersteigt, und wenn Speicher mit free() freigegeben wird. ElectricFence
+beendet das Programm bei der Instruktion, die die Speicherverletzung
+ausgelöst hat, und Sie können Ihren Lieblingsdebugger benutzen, um den
+Befehl anzuzeigen.
+
+%description -l es
+Electric Fence es una biblioteca que puede ser usada para programación y
+depuración en C. Tu lo "linkas" en tiempo de compilación y te avisará sobre
+posibles problemas, como liberación de memoria no alocada, etc.
 
 %description -l fr
 Electric Fence est une bibliothéque utilisée pour la programmation en C et
@@ -34,12 +51,16 @@ probl
 %description -l pl
 Electric Fence jest bibliotek± pomocn± podczas programowania w
 jêzyku C i "odpluskwianiu".
-Pakiet zawiera bibliotekê wspó³dzielon± która mo¿e byæ za³adowana przez
+Pakiet zawiera bibliotekê wspó³dzielon±, która mo¿e byæ za³adowana przez
 zmienn± LD_PRELOAD w trakcie uruchamiania dowolnego programu dziêki temu nie
 potrzeba linkowaæ z t± bibliotek± ¶ledzonego programu. Pakiet zawiera tak¿e
-skrypt shellowy ef, któremu mo¿na ³aduje do pamiêci przez LD_PRELOAD
-libliotekê libefence i uruchamia program przekazyny do tego skryptu jako
-parametr.
+skrypt pow³oki ef, który ³aduje do pamiêci przez LD_PRELOAD bibliotekê
+libefence i uruchamia program przekazany do tego skryptu jako parametr.
+
+%description -l pt_BR
+Electric Fence é uma biblioteca que pode ser usada para programação e
+depuração em C. Você o "linka" em tempo de compilação e ele o avisará sobre
+possíveis problemas como liberação de memória não alocada, etc.
 
 %description -l tr
 Electric Fence, C'de programlama ve hata ayýklama için kullanýlabilen bir
@@ -71,79 +92,29 @@ make CFLAGS="$RPM_OPT_FLAGS"
 rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib,share/man/man3}
 
-make   BIN_INSTALL_DIR=$RPM_BUILD_ROOT/usr/bin \
-       LIB_INSTALL_DIR=$RPM_BUILD_ROOT/usr/lib \
+make   BIN_INSTALL_DIR=$RPM_BUILD_ROOT%{_bindir} \
+       LIB_INSTALL_DIR=$RPM_BUILD_ROOT%{_libdir} \
        MAN_INSTALL_DIR=$RPM_BUILD_ROOT%{_mandir}/man3 \
        install
 
-strip --strip-unneeded $RPM_BUILD_ROOT/usr/lib/lib*so.*.*
+strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*so.*.*
 
 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
        README CHANGES
 
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc *gz
-%attr(755,root,root) /usr/bin/ef
-%attr(755,root,root) /usr/lib/lib*.so.*.*
+%attr(755,root,root) %{_bindir}/ef
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
 %{_mandir}/man3/*
 
 %files static
 %defattr(644,root,root,755)
-/usr/lib/lib*.a
-
-%changelog
-* Sun May  9 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.2-4]
-- now package is FHS 2.0 compliant.
-
-* Sat Apr 24 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.2-3]
-- fixed makin man page for EF,
-- recompiles on new rpm.
-
-* Thu Apr 15 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.2-2]
-- removed "Excludearch: alpha",
-- added a patch to properly build the shared library (Maciej W. Ró¿ycki
-  <macro@ds2.pg.gda.pl>).
-
-* Mon Apr 12 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.2-1]
-- added static subpackage; main package contains now shared library which
-  can be preloaded for any executable without relinking,
-- added static subpackage.
-
-* Sun Apr 11 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.1-1]
-- added Group(pl),
-- gzipping %doc.
-
-* Wed Dec 30 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-  [2.0.5-11d]
-- build for PLD, 
-- major changes.
-
-* Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
-- create efence.3 (problem #830)
-
-* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
-- build root
-
-* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
-- translations modified for de
-
-* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
-- need to use sigsetjmp() and siglongjmp() for proper testing
-
-* Fri May 01 1998 Prospector System <bugs@redhat.com>
-- translations modified for de, fr, tr
-
-* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
-- use ExcludeArch instead of Exclude
-
-* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
-- built against glibc
+%{_libdir}/lib*.a
This page took 0.029448 seconds and 4 git commands to generate.